Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenns und Teilergebnis?


Betrifft: Summewenns und Teilergebnis? von: Robert
Geschrieben am: 06.01.2018 20:19:43

Hallo zusammen,

Ich suche nach einer Formel in folgender Tabelle:

https://www.herber.de/bbs/user/118738.xlsx

Voraussetzung:
1. Filtern nach Namen
2. Eingabe der Start-KW (Von KW)
3. Eingabe der End-KW (Bis KW)

Ergebnis:
Summe aller Zellen in der Tabelle unter Berücksichtigung des jeweiligen Faktors und der oben genannten Voraussetzungen.

Ist die Voraussetzung zu komplex?
Habe mit summewenns und teilergebnis schon rum probiert, die Formel wurde aber viel zu lang...
Bevor ich aufgebe, dachte ich frage hier mal.

  

Betrifft: AW: Summewenns und Teilergebnis? von: Daniel
Geschrieben am: 06.01.2018 21:14:58

Hi
wenn man die Tabelle etwas ergänzt und sinnvolle Hilfszeilen und -spalten nicht scheut, bleibt das Formelwerk kurz und übersichtlich.
https://www.herber.de/bbs/user/118739.xlsx

Gurß Daniel


  

Betrifft: mit Summenprodukt + Teilergebnis + Indirekt von: WF
Geschrieben am: 07.01.2018 09:26:04

Hi,

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(3:11)))*(B2:K2>=C14)*(B2:K2<=C15)*B3:K11)

Salut WF


  

Betrifft: AW: mit Summenprodukt + Teilergebnis + Indirekt von: Robert
Geschrieben am: 07.01.2018 09:31:59

Haha, der Wahnsinn! Die Formel funktioniert. Super danke!

Danke auch an den 1. Vorschlag. Hat mir auch sehr weiter geholfen.


  

Betrifft: AW: mit Summenprodukt + Teilergebnis + Indirekt von: Robert
Geschrieben am: 07.01.2018 09:36:10

Die unterschiedlichen Faktoren werden bei der Formel zwar nicht berücksichtigt, hab dafür aber jetzt eine 2. Tabelle mit Sverweis generiert, wo ich dann einfach den Faktor für jede Zelle mit berücksichtigen kann.
Aber danke für die klasse Tipps! Hätte das sonst nie hin bekommen.


Beiträge aus dem Excel-Forum zum Thema "Summewenns und Teilergebnis?"