Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

ADRESSE in Formel verwenden

ADRESSE in Formel verwenden
21.03.2019 14:36:50
Jens
Hallo zusammen,
ich habe folgende Array-Formel:
{=SUMMENPRODUKT(IDENTISCH($D$3:$D$5000;D3)*1)-WENN($D3="";$P$2;1)}
Diese Formel erstreckt sich über Zeile 3 bis 5000. Jetzt will ich die so umbauen, dass die Formel über alle 4997 Zeilen identisch bleibt, sich aber auf unterschiedliche Zeilenbereiche bezieht.
D.h. anstelle:
Für die Zeilen 3 bis 200 die Formel:
{=SUMMENPRODUKT(IDENTISCH($D$3:$D$200;D3)*1)-WENN($D3="";$P$2;1)}
Für die Zeilen 201 bis 700 die Formel:
{=SUMMENPRODUKT(IDENTISCH($D$201:$D$700;D3)*1)-WENN($D201="";$P$2;1)}
Für die Zeilen 701 bis 5000 die Formel:
{=SUMMENPRODUKT(IDENTISCH($D$701:$D$5000;D3)*1)-WENN($D701="";$P$2;1)}
soll jetzt über alle Zeilen eine einzige Formel gelten.
Dazu hatte ich die Idee, die Formel ADRESSE zu verwenden, und in zwei zusätzlichen Spalten die Zeilenbereiche zu schreiben. Damit würde für mich die neue Formel so aussehen:
In Zelle B3 steht 3 und in Zelle C3 steht 200 (ab Zeile 201 steht in B201=201 und C201=700 und entsprechend ab Zeile 701 steht B701=701 und C701=5000):
{=SUMMENPRODUKT(IDENTISCH(ADRESSE(B3;4):ADRESSE(C3;4);D3)*1)-WENN($D3="";$P$2;1)}
Leider will die Formel nicht. Sie gibt mir ein Error zurück:
"Mit dieser Formel gibt es ein Problem.
Sie möchten gar keine Formel eingeben?
..."
Hoffe ihr versteht was ich machen will. Vielen Dank für die Hilfe.

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zelladresse ja, ADDRESSE() nein & ohne {} ...
21.03.2019 15:05:55
neopa
Hallo Jens,
... Deine Formel ist eine Matrixfunktion(alität)sformel die keines(!) spez. Formelabschluss wie eine klassische Matrixformel benötigt.
Das was Du weiter schreibst und wie ich es interpretiere, könntest Du mit folgender Formel in einer Zelle der Zeile 3:
=SUMMENPRODUKT(IDENTISCH(INDEX(D:D;VERWEIS(ZEILE();{3;201;701})):
INDEX(D:D;WAHL(VERGLEICH(ZEILE();{3;201;701});200;700;5000));D3)*1)-WENN(D3="";P$2;1)

Gruß Werner
.. , - ...
AW: Zelladresse ja, ADDRESSE() nein & ohne {} ...
22.03.2019 11:05:43
Jens
Hallo Werner,
vielen Dank. Das hat funktioniert.
Grüße
Jens
AW: bitte owT
22.03.2019 13:25:52
neopa
Gruß Werner
.. , - ...
Anzeige

46 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige