Bewegliches Datum berechnen. Spezial Glarus

Bild

Betrifft: Bewegliches Datum berechnen. Spezial Glarus
von: Martin
Geschrieben am: 18.11.2015 16:04:56

Hallo Zusammen
damit ich einen Feiertagskalender automatisiert erstellen kann, benötige ich noch eine Formel für einen etwas speziellen beweglichen Feiertag.
Näfelser Fahrt:
Eigentlich ist es immer der erste Donnerstag im April, ausser der Termin fällt in die Karwoche, dann ist es der zweite Donnerstag nach Ostern im April.
Der Forumsbeitrag welcher sich auf diesen Feiertag bezieht ist nicht Lösung des Problems, da nicht vollständig.
https://www.herber.de/forum/archiv/1284to1288/1287905_Formelfehler.html
Das Berechnungsjahr sollte über die veränderbare Jahreszahl in Zelle "K6" bezogen werden.
Danke für die Hilfe
Gruss
Martin

Bild

Betrifft: AW: Bewegliches Datum berechnen. Spezial Glarus
von: Rudi Maintaire
Geschrieben am: 18.11.2015 16:30:05
Hallo,
nach ein bisschen Recherche:
=(DATUM(K6;4;1)-REST(DATUM(K6;4;1)-6;7)+7-1)+(DATUM(K6;4;1)-REST(DATUM(K6;4;1)-6;7) +7-1=RUNDEN((TAG(MINUTE(K6/38)/2+55)&".4."&K6)/7;)*7-9) *14
Gilt nur nach 1900, nicht für 2079 und nicht nach 2203.
Gruß
Rudi

Bild

Betrifft: AW: Bewegliches Datum berechnen. Spezial Glarus
von: Martin
Geschrieben am: 19.11.2015 11:31:31
Bin aktuell auswärts werde nach Rückkehr prüfen

Bild

Betrifft: AW: Bewegliches Datum berechnen. Spezial Glarus
von: Martin
Geschrieben am: 19.11.2015 16:55:52
Hallo Zusammen
Kann mir nicht erklären, warum der Thread doppelt im Forum gelandet ist.
Aber Danke trotzdem an alle, übrigens werde die Lösung von Josef B. mit der Gauss Oster-Regel verwenden.
Gruss
Martin

Bild

Betrifft: Ergänzend
von: RPP63
Geschrieben am: 18.11.2015 16:44:59
Hi!
Weil ich auch dran war, hier meine Lösung mit Hilfsspalten:

 ABCD
1Jahr1. DOGrün-DONäfelser
22000Do 06.04.00Do 20.04.00Do 06.04.00
32001Do 05.04.01Do 12.04.01Do 05.04.01
42002Do 04.04.02Do 28.03.02Do 04.04.02
52003Do 03.04.03Do 17.04.03Do 03.04.03
62004Do 01.04.04Do 08.04.04Do 01.04.04
72005Do 07.04.05Do 24.03.05Do 07.04.05
82006Do 06.04.06Do 13.04.06Do 06.04.06
92007Do 05.04.07Do 05.04.07Do 12.04.07
102008Do 03.04.08Do 20.03.08Do 03.04.08
112009Do 02.04.09Do 09.04.09Do 02.04.09
122010Do 01.04.10Do 01.04.10Do 08.04.10
132011Do 07.04.11Do 21.04.11Do 07.04.11
142012Do 05.04.12Do 05.04.12Do 12.04.12
152013Do 04.04.13Do 28.03.13Do 04.04.13
162014Do 03.04.14Do 17.04.14Do 03.04.14
172015Do 02.04.15Do 02.04.15Do 09.04.15
182016Do 07.04.16Do 24.03.16Do 07.04.16
192017Do 06.04.17Do 13.04.17Do 06.04.17
202018Do 05.04.18Do 29.03.18Do 05.04.18
212019Do 04.04.19Do 18.04.19Do 04.04.19
222020Do 02.04.20Do 09.04.20Do 02.04.20

Formeln der Tabelle
ZelleFormel
B2=--("1.4."&A2)-REST(--("1.4."&A2)-6;7)+6
C2=RUNDEN((TAG(MINUTE(A2/38)/2+55)&".4."&A2)/7;0)*7-9
D2=WENN(B2=C2;C2+7;B2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Überprüfung hiermit OK:
http://www.feiertagskalender.ch/kalender.php?geo=3056&jahr=2015&hl=de&klasse=5&ft_id=16
Gruß Ralf

Bild

Betrifft: AW: Ergänzend
von: Rudi Maintaire
Geschrieben am: 18.11.2015 16:50:35
Hallo,
dann ist es der zweite Donnerstag nach Ostern im April.
dann doch D2: =WENN(B2=C2;C2+14;B2)
da der 2. Do nach Ostern 2 Wochen nach GrüDo ist.
Gruß
Rudi

Bild

Betrifft: Jein
von: RPP63
Geschrieben am: 18.11.2015 17:04:49
Hi!
Meine Recherche ergab:
- Normal der erste Do im April
- Wenn der erste Do im April = Gründonnerstag, dann ist dieser Feiertag am zweiten Do im April.
Insofern müsste meine Formel, die sich ja auch mit der Internet-FT-Liste (siehe meinen Link) deckt, stimmen.
Meine ungelenke Geschichte ohne Hilfsspalten:
=WENN(DATUM(A2;4;1)-REST(DATUM(A2;4;-5);7)+6=RUNDEN(DATUM(A2;4;TAG(MINUTE(A2/38)/2+55))/7;0)*7-9; RUNDEN(DATUM(A2;4;TAG(MINUTE(A2/38)/2+55))/7;0)*7-2;DATUM(A2;4;1)-REST(DATUM(A2;4;-5);7)+6)
Gruß Ralf

Bild

Betrifft: AW: Jein
von: Rudi Maintaire
Geschrieben am: 18.11.2015 21:13:50
Hallo,
ich hab mich ja nur auf die Angaben des Fragestellers bezogen.
Gruß
Rudi

Bild

Betrifft: Und dessen Angabe war missverständlich, ...
von: Luc:-?
Geschrieben am: 19.11.2015 01:38:09
Rudi,
bzw schlecht formuliert. Ich hatte das erst als 2.Do im April verstanden, beim Nachlesen dann aber auch auf 2.Do nach Ostern korrigiert. Da du aber was von Internet-Recherche geschrieben hattest, habe ich das ebenso wie Ralf nachgeprüft und bin schließlich bei http://www.feiertage-schweiz.ch/kalender gelandet. Aus den Angaben für 2010-2037 war dann ersichtlich, dass es dann der 2.Do im April ist und so dem Wochentag der Schlacht vom 9.4.1388 sogar eher entspricht, denn das muss damals auch ein 2.Do im April gewesen sein… ;-)
Im Übrigen hat der Fragesteller die Frage inzwischen 2× gepostet und oben hat SeppB eine 2teilige KurzFml eingestellt, die der von amos auf Ol-Xl analog sein dürfte/könnte (beide hatten dort über die Oster-Fml-Problematik diskutiert).
Ansonsten hat die von dir verwendete Oster-Fml-Basis (oder „nur“ deine Fml?) weder ein Problem mit dem Jahr 1900 (die Probleme liegen dort vor dem 1.3.!) noch dem sog Problemjahr 2079. Ab 2100 sollte man ggf die sehr genaue Oster-„Lang“-Fml von amos verwenden, die bis 9999, dem Xl-DatumsEndjahr, richtig rechnen soll.
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: Ostern IMMER richtig (auch vor 1900): NUR Gauß
von: WF
Geschrieben am: 19.11.2015 07:43:40
siehe:
http://excelformeln.de/formeln.html?welcher=3
WF

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Gruppierung per Makro ansprechen"