Microsoft Excel

Herbers Excel/VBA-Archiv

Formelfehler

Betrifft: Formelfehler von: rest
Geschrieben am: 25.11.2012 09:41:02

Guten Morgen
Ich habe da mal ein Problem.
Die Formel bekamm ich früher hier im Forum. Jetzt ist mir aber aufgefallen, dass das Datum im Jahr 2015 nicht korrekt dargestellt wird., wäre der 9.4..

In Zelle A2 staht das Jahr mit dem Namen gewjahr
Die Formel in der Zelle AO8 berechnet die Näfelser Fahrt und sagt aus:
Die Näfelser Fahrt gilt als höchsten Feiertag im Kanton Glarus. Dieser wird jeweils am ersten Donnerstag im April gefeiert, es sei denn dieser Feiertag fällt exakt auf den Donnerstag vor dem Karfreitag, dann verschiebt sich dieser um eine Woche.

Kalender

 ANAOAP
3Ferien und Feiertage 12.04.2015
4F1Do, 1. Jan 2015Neujahr
5F2Fr, 10. Apr 2015Karfreitag
7F3Mo, 13. Apr 2015Ostermontag
8F4Do, 2. Apr 2015Näfelser Fahrt
10F5Do, 21. Mai 2015Auffahrt
11F6Mo, 1. Jun 2015Pfingstmontag

Formeln der Tabelle
ZelleFormel
AP3=DM((TAG(MINUTE(gewjahr/38)/2+55)&".4."&gewjahr)/7;)*7-WENN(JAHR(1)=1904;5;6)
AN4=WENN(AO4="";"";1)
AO4=DATUM(gewjahr;1;1)
AN5=WENN(AO5="";"";2)
AO5=AP3-2
AN7=WENN(AO7="";"";3)
AO7=AP3+1
AN8=WENN(AO8="";"";4)
AO8=WENN(AO9-DATUM(gewjahr;4;7-WOCHENTAG(DATUM(gewjahr;4;1)-4;3))=1;DATUM(gewjahr;4;7-WOCHENTAG(DATUM(gewjahr;4;1)-4;3))+7;DATUM(gewjahr;4;7-WOCHENTAG(DATUM(gewjahr;4;1)-4;3)))
AN10=WENN(AO10="";"";5)
AO10=AP3+39
AN11=WENN(AO11="";"";6)
AO11=AP3+50


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Um eine Lösung bin ich sehr dankbar

Gruss Reto

  

Betrifft: AW: Formelfehler von: rest
Geschrieben am: 25.11.2012 10:58:10

Habe eben bemerkt, dass diese Formel trotzdem stimmt.
Aber die Osterformel, welche ich von Hajo aus einer Feiertagsberechnungsdatei habe funktioniert nicht.
In den Optionen ist bei 1904 auch ein Haken.
Makros gibt es ansonsten keine in der Datei.

Was mache ich falsch ???

Reto


  

Betrifft: AW: Formelfehler von: Hajo_Zi
Geschrieben am: 25.11.2012 10:59:56

Das ist eben der Vorteil von Datumswerte 1904. Viele Formeln sind dafür nicht ausgelegt.

GrußformelHomepage


  

Betrifft: AW: Formelfehler von: rest
Geschrieben am: 25.11.2012 11:13:39

Hallo
Besten Dank, aber jetzt weiss ich immer noch nicht warum die Formel um eine Woche daneben ist.
2015 stimmt nicht
2016 stimmt
2017 stimmt
2018 stimmt nicht
2019 stimmt
2020 stimmt
2021 stimmt nicht

woran kann das liegen ?

Reto


  

Betrifft: AW: Formelfehler von: Hajo_Zi
Geschrieben am: 25.11.2012 11:17:42

wie Du schon geschrieben hast an Datumswerte 1904.

Gruß Hajo


  

Betrifft: AW: Formelfehler von: rest
Geschrieben am: 25.11.2012 11:24:35

Hallo
Besten Dank für die Info.
Jetzt habe ich es geschnallt
Ich dachte immer, dass die Einstellungen in den Optionen global sind.
Nachdem ich den Haken rausgenommen habe, funktioniert es.
Super
Wünsche noch einen schönen Sonntag, MERCI

Reto


  

Betrifft: AW: Formelfehler von: Hajo_Zi
Geschrieben am: 25.11.2012 11:49:25

für negative Zeiten gibt es auch andere Lösungen.
http://hajo-excel.de/chCounter3/getfile.php?id=169

Gruß Hajo


 

Beiträge aus den Excel-Beispielen zum Thema "Formelfehler"