Formelfehler?

Bild

Betrifft: Formelfehler? von: Hans
Geschrieben am: 27.03.2005 15:34:54

Hallo,
ich habe folgende Formel eingegeben: =WENN($I$9=1;C21;WENN($I$9=2;C22;WENN($I$9=3;C23;WENN($I$9=4;C24;WENN($I$9=5;C25;WENN($I$9=6;C26;WENN($I$9=7;C27;WENN($I$9=8;C28;wenn($I$9=9;C29;""))))))))) Das letzte "wenn" meldet Excel als Formelfehler. Was mach ich falsch? Kann mir jemand einen Tip geben?
Danke und Frohe Ostern
Hans

Bild


Betrifft: AW: Formelfehler? von: Jörg Gradert
Geschrieben am: 27.03.2005 15:40:35

Hallo Hans,
siehe hier

http://www.excelformeln.de/formeln.html?welcher=128

Gruß Jörg


Bild


Betrifft: AW: Formelfehler? von: Hans
Geschrieben am: 27.03.2005 15:58:45

Danke Jörg,
das war klasse und schnell.
Gruß
Hans


Bild


Betrifft: AW: WENN mir schlecht wird von: FP
Geschrieben am: 27.03.2005 16:36:23

Hallo Hans,

vor lauter WENN, dann mache ich es so:

Funktioniert hier als Beispiel für die Werte 1 bis 9 in I9.

Aber das kannst Du ganz leicht ausbauen. Ist das nicht viel einfacher als WENN(...WENN(...WENN.....

Tabelle1
 BCDEFGHI
9c24      4
10        
11        
12        
13        
14        
15        
16        
17        
18        
19        
20        
21 c21      
22 c22      
23 c23      
24 c24      
25 c25      
26 c26      
27 c27      
28 c28      
29 c29      
30 c30      
Formeln der Tabelle
B9 : =INDEX(C21:C29;I9)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: WENN mir schlecht wird von: Hans
Geschrieben am: 27.03.2005 17:29:43

Hallo Franz,
danke, ich schau mir das gleich mal näher an. Vielleicht wird es mir dann nicht mehr so schlecht.
Gruß aus Ostfriesland
Hans


Bild


Betrifft: AW: WENN mir schlecht wird von: Hans
Geschrieben am: 27.03.2005 18:18:19

Moin Franz,
die Formel funzt fantastisch. Ich muss nur noch herausfinden warum. Allerdings fehlt dabei der Effekt, dass, wenn das Feld I9 leer ist, B9 auch vollkommen leer sein sollte. Es erscheint dann "#WERT!".
Gruß
Hans


Bild


Betrifft: AW: na WENN das so ist ... von: FP
Geschrieben am: 27.03.2005 18:30:46

Hallo Hans,

dann brauchst Du doch EIN WENN: ;-)

=WENN(I9=0;"";INDEX(C21:C29;I9))

Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: na WENN das so ist ... von: Hans
Geschrieben am: 27.03.2005 18:57:40

Hallo Franz,
suuuuper. Die kurze Formel verleitet mich geradezu, noch ein paar Varianten einzubauen.
danke
Hans


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formelfehler?"