Summewenn und Teilergebnis kombiniert

Bild

Betrifft: Summewenn und Teilergebnis kombiniert von: Bettina
Geschrieben am: 11.03.2005 11:47:48

hallo zusammen,
ich möchte aus einem teilergebnis eine summewenn-funktion machen. irgendwie funktioniert die verschachtelung leider nicht.
hat jemand einen tipp für mich?

=SUMMEWENN(teilergebnis(9;M11;M210);0;G11:G210)

diese formel gibt immer eine fehlermeldung.
danke für eure hilfe.
gruss,
bettina

Bild


Betrifft: AW: Summewenn und Teilergebnis kombiniert von: Boris
Geschrieben am: 11.03.2005 12:11:36

Hi Bettina,

prinzipiell so:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:1000)))*(A2:A1000="x")*B2:B1000)

Also:
Summiere aus der nach Spalte A gefilterten Liste alle Werte aus Spalte B, wenn in Spalte A ein "x" steht.
Die Spalte A darf dabei keine Leereinträge haben - sonst kommt es zu falschen Ergebnissen.
Zwingend notwendig ist hier der Teilergebnisparamter 3.

Grüße Boris


Bild


Betrifft: AW: Summewenn und Teilergebnis kombiniert von: bettina
Geschrieben am: 11.03.2005 12:32:53

hallo boris,
danke!
so sieht mein ergebnis aus
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("l"&ZEILE(11:210)))*(L11:L210>0)*G11:G210)

sollte reichtig sein.
gruss,
bettina


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summewenn und Teilergebnis kombiniert"