Microsoft Excel

Herbers Excel/VBA-Archiv

10000 addieren mit Anführungsszeichen


Betrifft: 10000 addieren mit Anführungsszeichen von: Jenny
Geschrieben am: 15.04.2017 14:42:14

Hallo könnt ihr mir bitte bei folgender Problematik helfen?

https://www.herber.de/bbs/user/112891.xlsx

Suche eine Formel, die schaut ob in Spalte I eine 1 oder eine 2 steht.

Steht da eine 1 soll einfach das was in Spalte A steht erneut ausgegeben werden.
Steht da eine 2 soll zu der Zahl in Spalte A 10000 addiert werden.

Und beide Ausgaben sollen weiterhin die Anführungszeichen wie in Spalte A haben.

Also im Prinzip suche ich das was in Spalte J steht.
Gibts da ne Formel?

Gruß und Danke
Jenny

  

Betrifft: kleiner Nachtrag von: Jenny
Geschrieben am: 15.04.2017 14:48:44

In der kompletten Tabelle gibt es auch Zahlen größer 1000 in Spalte A die von der Addition betroffen sind, also mit =WENN(I31=1;A31;TEIL(A31;9;1)&10&RECHTS(A31;4)) ist mir nicht geholfen da das nur mit Zahlen kleiner 1000 funktioniert.

Gruß
Jenny


  

Betrifft: J1: =""""&WECHSELN(A1;"""";)+(I1-1)*10000&"""" von: lupo1
Geschrieben am: 15.04.2017 14:52:05




  

Betrifft: AW: 10000 addieren mit Anführungsszeichen von: Matthias L
Geschrieben am: 15.04.2017 15:02:22

Hallo

Tabelle2

 ABCDEFGHIJK
30        "2817"       1        "2817"        "2817"
31        "731"       2"10731""10731"
32        "1402"       1        "1402"        "1402"

Formeln der Tabelle
ZelleFormel
J30=A30
K30=WENN(I30=1;A30;WENN(I30=2;""""&--WECHSELN(A30;"""";"")+10000&"""";""))
K31=WENN(I31=1;A31;WENN(I31=2;""""&--WECHSELN(A31;"""";"")+10000&"""";""))
J32=A32
K32=WENN(I32=1;A32;WENN(I32=2;""""&--WECHSELN(A32;"""";"")+10000&"""";""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Matthias


  

Betrifft: AW: 10000 addieren mit Anführungsszeichen von: Jenny
Geschrieben am: 15.04.2017 15:35:15

Hallo ihr beiden,

danke für eure beiden wunderbar funktionierende Formeln.

Eine Frage hätte ich mal noch am Rande.
Zuerst ich habe die Spalten ein wenig vertauscht, also nicht wundern.

Aber ich frage mich, weshalb Lupos Formel

=""""&WECHSELN(E1;"""";)+(D1-1)*10000&""""

die 8 Leerzeichen am Anfang löscht

und Matthias Formel sie nur im Fall D1=2 löscht,

ich also aus seiner Formel

=WENN(D1=1;GLÄTTEN(E1);WENN(D1=2;""""&--WECHSELN(D1;"""";"")+10000&"""";""))

machen muss damit die Anführungszeichen in jedem Fall gelöscht werden?

Danke für die Antwort
Jenny


  

Betrifft: Leerzeichen nicht Anführungszeichen owt von: Jenny
Geschrieben am: 15.04.2017 15:36:27

.


  

Betrifft: AW: Leerzeichen nicht Anführungszeichen owt von: Matthias L
Geschrieben am: 15.04.2017 16:54:07

Hallo

Das war ja nicht Teil Deiner Aufgabe/Deiner Bitte um Hilfe.
Also habe ich dieser Tatsache keine größere Beachtung geschenkt.
Glätten müsste dann vor die gesamte Formel.

Tabelle2

 ABCDEFGHIJKL
30        "2817"       1        "2817""2817""2817"
31        "731"       2        "731""10731""10731"
32        "1402"       1        "1402""1402""1402"

Formeln der Tabelle
ZelleFormel
J30=A30
K30=GLÄTTEN(WENN(I30=1;A30;WENN(I30=2;""""&--WECHSELN(A30;"""";"")+10000&"""";"")))
L30=""""&WECHSELN(A30;"""";)+(I30-1)*10000&""""
J31=A31
K31=GLÄTTEN(WENN(I31=1;A31;WENN(I31=2;""""&--WECHSELN(A31;"""";"")+10000&"""";"")))
L31=""""&WECHSELN(A31;"""";)+(I31-1)*10000&""""
J32=A32
K32=GLÄTTEN(WENN(I32=1;A32;WENN(I32=2;""""&--WECHSELN(A32;"""";"")+10000&"""";"")))
L32=""""&WECHSELN(A32;"""";)+(I32-1)*10000&""""


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Matthias


  

Betrifft: AW: Leerzeichen nicht Anführungszeichen owt von: Jenny
Geschrieben am: 15.04.2017 16:57:17

Nein das war auch nicht teil der Aufgabe, sollte auch kein Vorwurf an dich sein.
Mir war halt nur der Unterschied aufgefallen, dass Lupos Formel das von allein macht und deine die Glätten Formel benötigt und wollte einfach aus Neugier fragen weshalb.

Gruß
Jenny


  

Betrifft: AW: Leerzeichen nicht Anführungszeichen owt von: Matthias L
Geschrieben am: 15.04.2017 17:08:44

Hallo

sollte auch kein Vorwurf an dich sein.
Hab ich auch nicht so aufgefasst.

Ich hab mich eben nur nicht in der Formel darum gekümmert, weils nicht gefordert war ;-)

Gruß Matthias


  

Betrifft: AW: Leerzeichen nicht Anführungszeichen owt von: Jenny
Geschrieben am: 16.04.2017 07:50:15

Hallo Matthias,

nur ich habe das Glätten bewusst an diese Stelle gesetzt, nicht ganz drumherum.

Weil deine Formel im Fall I1=2 genauso wie Lupos Formel von alleine glättet, nur im Fall I1=1 nicht.

Gruß
Jenny


  

Betrifft: Wo sind die Leerzeichen? von: lupo1
Geschrieben am: 16.04.2017 08:21:32

Gibt man eine Zahl umrankt von Leerzeichen ein, ignoriert Excel die Leerzeichen. Auch dahinter.

Gibt man einen Text ein (auch "539" ist ein Text!), bleiben sie erhalten.

In meiner Formel
=""""&WECHSELN(A1;"""";)+(I1-1)*10000&""""

noch leicht kürzbar zu
=""""&WECHSELN(A1;"""";)+(I1-1)/1%%&""""

wechsle ich zuerst die " raus. Durch die anschließende Rechenoperation +... wird dieser Text (der direkt nach WECHSELN noch die Leerzeichen drum rum hat) zu einer Zahl (mit automatisch verschwindenden Leerzeichen, ohne GLÄTTEN), die dann manuell anschließend mit & wieder die " verpasst bekommt und zu einem Text wird.


  

Betrifft: da gibts Keine ... von: Matthias L
Geschrieben am: 16.04.2017 08:56:06

Hallo lupo

Weil deine Formel im Fall I1=2 genauso wie Lupos Formel von alleine glättet, nur im Fall I1=1 nicht.
Jenny meinte ja auch mich damit.

Das hatte ich Jenny aber bereits erläutert, das ich micht nicht ums "Glätten" gekümmert habe
weil es nicht gefordert war.

Die Ausgangsfrage war ja so:
Steht da eine 1 soll einfach das was in Spalte A steht erneut ausgegeben werden.

=WENN(I30=1;A30;WENN(I30=2;""""&--WECHSELN(A30;"""";"")+10000&"""";""))
Also habe ich auch das was in A30 steht wiedergegeben.

Deine Formel funktioniert Bestens, lupo.

Gruß Matthias


Beiträge aus den Excel-Beispielen zum Thema "10000 addieren mit Anführungsszeichen"