Zellenwert automatisch um einen Schritt erhöhen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:


Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Zellenwert automatisch um einen Schritt erhöhen
von: Stefan
Geschrieben am: 26.06.2002 - 08:14:17

Hallo an alle,

habe folgendes problem und dafür gibt es doch bestimmt eine Lösung!
Ich habe zwei Spalten beginndend bei H5 und es endet bei I200. Jetzt möchte ich in die H Spalte unterschiedliche vierstellige Werte eingeben wobei sich die Werte mehrmals wiederholen können. In der I Spalte soll sich dabei automatisch bezüglich zum Wert in der H Spalte eine Zahl beginnend bei 300 um jeweils einen Schritt erhöhen.
Dabei ist zu beachten das die Zahl 300 bei jedem Wert vorkommt der zum ersten mal in Spalte H eingegeben wurde.
hier ein Beispiel:
H ____ I
6440 300
6440 301
6530 300
6440 302
6320 300
6581 300
6440 303

Kann mir bei diesem Problem jemand helfen?
Gruß Stefan...





nach oben   nach unten

Versteh' ich nicht...
von: @lex
Geschrieben am: 26.06.2002 - 08:42:32

Hallo Stefan,
erläutere das Problem bitte genauer.
Nach welchem Kriterium wird in Spalte I der Wert um 1 erhöht ?

VG,
Alex


nach oben   nach unten

Ich auch nicht...
von: Michael Scheffler
Geschrieben am: 26.06.2002 - 08:54:48

Was hat denn H mit I zu tun?

nach oben   nach unten

Schliesse mich an - ich auch nicht (nT)
von: Alan Hathway
Geschrieben am: 26.06.2002 - 08:56:58

Schliesse mich an - ich auch nicht (nT)

nach oben   nach unten

Re: Ich auch nicht...
von: @lex
Geschrieben am: 26.06.2002 - 08:57:57

Und ich dachte schon, ich würde heute morgen auf der Leitung stehen. 2 Beiträge angeschaut und keinen verstanden :-)

nach oben   nach unten

Re: Ich auch nicht...
von: Alan Hathway
Geschrieben am: 26.06.2002 - 09:02:13

Wo ist Dein Selbstvertrauen hin?

https://www.herber.de/forum/messages/131294.html

ist noch ein Beispiel - wo ich nur "Huh?" denke und weiter gehe

:-)

Alan Hathway

nach oben   nach unten

Re: Zellenwert automatisch um einen Schritt erhöhen
von: Stefan
Geschrieben am: 26.06.2002 - 09:04:36

OK ich versuchs nochmal anders zu erklären:
Ich möchte nur die Spalte H als Eingabe von Werten nutzen.
Der Wert in Spalte I soll automatisch durch die Eingabe in Spalte H erzeugt werden, beginnend bei 300 für jeden eingegebenen Wert in Spalte H. Nur wenn ein gleicher Wert in Spalte H eingegeben wurde, soll sich der Wert in Spalte I um einen Wert erhöhen usw...
Ich hoffe ich habe es jetzt ein bischen besser beschrieben!
Gruß Stefan...
nach oben   nach unten

Re: Zellenwert automatisch um einen Schritt erhöhen
von: RainerJ
Geschrieben am: 26.06.2002 - 09:05:42

Hallo

Also wenn ich das begriffen haben sollte, dann in folgende Formel
in die erste Zeile in Spalte I eingeben und nach unten ausfüllen.

=ZÄHLENWENN($H$1:H1;H1)+299

Gruss
Rainer

nach oben   nach unten

Re: Ich glaub schon
von: Harald Kapp
Geschrieben am: 26.06.2002 - 09:08:30

Hallo,
ich denke, folgendes soll passieren.
Bei ersten Auftreten einer 4-stelligen Zahl in Spalte I soll dazu in Spalte H der Wert 300 eingetragen werden. Wenn die gleiche 4stellige Zahl in Spalte I weiter unten noch einmal auftaucht, soll in Spalte H der 300er-Wert jedes Mal inkrementiert werden, etwa so:

MS Excel von Harald Kapp an Alan Hathway
 AB
16000300
26002300
36003300
46004300
56000301
66000302
76002301
86004301
96005300
106001300
116001301

Dabei steht in den Zellen der Spalte B (in meinem Beispie) die Formel z.B. in Zelle B11:
=300+ZÄHLENWENN($A$1:A11;A11)-1

Gruß Harald

nach oben   nach unten

Re: Zellenwert automatisch um einen Schritt erhöhen
von: RainerJ
Geschrieben am: 26.06.2002 - 09:08:49

OK

noch eine kleine Erweiterung um in I nicht 299 erscheinen zu lassen sondern 0

=WENN(ZÄHLENWENN($H$1:H1;H1)>0;ZÄHLENWENN($H$1:H1;H1)+299;0)

nach oben   nach unten

Re: Zellenwert automatisch um einen Schritt erhöhen
von: Stefan
Geschrieben am: 26.06.2002 - 09:12:30

Hallo Rainer,

Super, vielen Dank hat prima geklappt!!!!!
Gruß Stefan...


nach oben   nach unten

Nicht mit Formeln lösbar - nur VBA
von: Alan Hathway
Geschrieben am: 26.06.2002 - 09:12:43

Wenn ich es richtig verstehe

Zwei Beispiele
1) Der Anwender gibt in H5 6000 ein. Es soll 300 in I5 erscheinen
Der Anwender gibt in H6 6000 ein. Es soll 301 in I6 erscheinen

2) Der Anwender gibt in H6 6000 ein. Es soll 300 in I6 erscheinen
Der Anwender gibt in H5 6000 ein. Es soll 301 in I5 erscheinen

Das kann nur mit einem Makro gemacht werden.

Mit INPUTBOX die


nach oben   nach unten

Re: Ich glaub schon
von: Alan Hathway
Geschrieben am: 26.06.2002 - 09:17:36

Du hast recht

Ich habe gelesen
> Dabei ist zu beachten das die Zahl 300 bei jedem Wert vorkommt der zum ersten mal in Spalte H eingegeben wurde.

Darauf habe ich dieses auf der ZEITLICHEN Reihenfolge bezogen. Er meinte aber anscheinend (oder ist zu frieden mit) der ZELLEN Reihenfolge. Siehe

Zwei Beispiele
1) Der Anwender gibt in H5 6000 ein. Es soll 300 in I5 erscheinen
Der Anwender gibt in H6 6000 ein. Es soll 301 in I6 erscheinen

2) Der Anwender gibt in H6 6000 ein. Es soll 300 in I6 erscheinen
Der Anwender gibt in H5 6000 ein. Es soll 301 in I5 erscheinen

Das kann nur mit einem Makro gemacht werden.

Hauptsache der Stefan ist zu frieden. :-)

Alan Hathway

nach oben   nach unten

Re: Ich glaub schon
von: Stefan
Geschrieben am: 26.06.2002 - 09:22:27

Danke Leute für Eure Mühe!!!
Die Lösung von Rainer J ist für mich OK.
Gruß Stefan

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Zellenwert automatisch um einen Schritt erhöhen"