verweis auf nachbarzelle

Bild

Betrifft: verweis auf nachbarzelle
von: jet
Geschrieben am: 05.12.2003 02:53:31

hi!
koennt ihr mir bitte weiterhelfen: ich braeuchte eine verweisfkt., die mir einen wert aus einer tabelle sucht (nicht in einer fest definierten spalte) und mir dann einfach nur den wert rechts davon wiedergibt.
bsp.: verweis-treffer ist in b2, dann gib mir c2 wieder
treffer in d3, ergebnis e3 ....etc..
gruss
jet

Bild


Betrifft: SVERWEIS??
von: Christoph Dümmen
Geschrieben am: 05.12.2003 06:15:45

meinst Du
=sverweis(suchkriterium;BereichWoSuchen;Rückgabespalte)??

Christoph


Bild


Betrifft: AW: SVERWEIS??
von: jet
Geschrieben am: 07.12.2003 23:21:44

Ja, meine ich, wobei es nicht nur eine Rueckgabespalte gibt, sondern einfach nur die Nachbarzelle zurueckgegeben werden soll. Weisst du da eine Loesung?
Gruss
Jun


Bild


Betrifft: link auf www.excelformeln.de
von: Günther Oppold
Geschrieben am: 05.12.2003 07:00:12

Hi jet,

Schau mal unter www.excelformeln.de
vielleicht hilft Dir die Formel weiter. Du müsstest zum Auslesen der ermittelten Zelle (bei der errechneten Spalte +1 hinzufügen) mit indirekt arbeiten

(angenommen die FORMEL ergibt als Lösung: C3, dann =indirekt(FORMEL)

http://www.excelformeln.de/formeln.html?welcher=58
dort steht:

Lösung
Suchbegriff: "x"
Es wird spaltenweise durchsucht, also C5 wird vor D4 gefunden.

In A1 steht die Spalte:
{=MIN(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A2:A65536;;SPALTE(1:1)-1;;);"x")>0;SPALTE(1:1)))}

in B1 steht die Zeile:
=VERGLEICH("x";BEREICH.VERSCHIEBEN(A:A;;A1-1;;);0)

Alternativ:
Die folgende Formel in B1 gibt die Adresse in A1-Schreibweise zurück:

{=ADRESSE(VERGLEICH("x";BEREICH.VERSCHIEBEN(A:A;;MIN(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A2:A65536;;SPALTE(1:1)-1;;);"x")>0;SPALTE(1:1)))-1;;);0);MIN(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A2:A65536;;SPALTE(1:1)-1;;);"x")>0;SPALTE(1:1))))}

Variante:
Für einen überschaubaren Bereich - hier A2:F100 - langen (es wird jetzt zeilenweise durchsucht):
Zeile in B1:
{=MIN(WENN(A$2:F$100="x";ZEILE(2:100)))}
Spalte:
=VERGLEICH("x";INDIREKT("A"&B1):INDIREKT("F"&B1);0)
Adresse:
{=ADRESSE(MIN(WENN(A$2:F$100="x";ZEILE(2:100)));VERGLEICH("x";INDIREKT("A"&MIN(WENN(A$2:F$100="x";ZEILE(2:100)))):INDIREKT("F"&MIN(WENN(A$2:F$100="x";ZEILE(2:100))));0))}

Ist sicher, daß der Suchbegriff NUR EINMAL vorkommt, langt:
=ADRESSE(MAX((A2:F100="x")*ZEILE(2:100));MAX((A2:F100="x")*SPALTE(A:F)))




Gruß
Günther


Bild

Beiträge aus den Excel-Beispielen zum Thema " verweis auf nachbarzelle"