00.01.1900 vermeiden

Bild

Betrifft: 00.01.1900 vermeiden
von: Achim H.
Geschrieben am: 01.09.2015 18:12:40

Hallo Excelfreunde
Ich habe diesen Sverweis und bekomme bei leeren Zellen diese Rückmeldung 00.01.1900.
Wie kann ich diese Rückmeldung bei leerer Zelle ausschließen?
=WENN(ISTFEHLER(SVERWEIS(D1;SchülerGrundlagendaten!$C$5:$CA$490;42;0));"";SVERWEIS(D1; SchülerGrundlagendaten!$C$5:$CA$490;42;0))
Danke Gruß Achim H.

Bild

Betrifft: AW: 00.01.1900 vermeiden
von: Daniel
Geschrieben am: 01.09.2015 18:18:15
Hi
wenn du eine Spalte mit Zahlenwerten auswertest:
=Wenn(IstZahl(SVerweis(..));SVerweis(...);"")
Gruß Daniel

Bild

Betrifft: AW: 00.01.1900 vermeiden
von: Achim H.
Geschrieben am: 01.09.2015 18:34:55
Hallo Daniel
Danke. Dein Gedankenansatz war die richtige Richtung. Für mein Problem war IstLeer die passende Lösung.
Gruß Achim H.

Bild

Betrifft: SVERWEIS() liefert als Ergebnis von Leerzellen ...
von: ... neopa C
Geschrieben am: 01.09.2015 18:47:26
Hallo Achim,
... ausgegeben eine 0 aber "intern" das korrekte Ergebnis "". Wenn Du das genau wieder haben willst, musst Du das "interne" Ergebnis entsprechend prüfen . Z.B. auch so: WENN(SVERWEIS(...)="";"";SVERWEIS(...)) Das ist quasi die gleiche Prüfung, wie sie Dir auch Daniel mit der Prüfung auf ISTZAHL() vorgeschlagen hat.
In Deinem Fall ist aber wahrscheinlich beides nicht notwendig, weil Du offensichtlich Datumswerte suchst (darauf deutet Deine Datumsformatangabe) Da kannst Du die ausgegebenen 0-Werte durch benutzerdefiniertes Zahlenformat z.B so: TT.MM.JJJJ;; (wichtig sind die beiden Semikolons!) einfach ausblenden.
Und da Du XL 2010 im Einsatz hast, kannst Du auch Deine zusätzliche WENN()-Formel mit ISTFEHLER() sparen. Nutze jetzt besser für diese Prüfung WENNFEHLER()
Gruß Werner
.. , - ...

Bild

Betrifft: AW: SVERWEIS() liefert als Ergebnis von Leerzellen ...
von: Daniel
Geschrieben am: 01.09.2015 19:11:24
Intern ist das korrekte Ergebnis auch nicht "", sondern nichts ("" ist ein Textstring)
allerdings kann die Formel nicht "nichts" als Wert zurückgeben und bei MS hat man sich dann entschieden, in diesem Fall die Zahl 0 als Rückgabewert der Funktion zu verwenden und nicht den Text "" (Excel ist ja auch ein Rechenprogramm)
die Abfrage "IstZahl" hätte meiner ansicht nach auch den Vorteil, dass sie gleichzeitig auch noch den Fehlerfall "Suchwert nicht vorhanden" mit abdeckt, wenn man in diesem Fall ebenfalls den Text "" als Ergebnis haben will und nicht den #NV-Fehler.
Gruß Daniel

Bild

Betrifft: AW: WENN(ISTZAHL(...) könnte hier ...
von: ... neopa C
Geschrieben am: 01.09.2015 19:28:41
Hallo Daniel,
... zum gewünschten führen, weil wie ich bereits auch schrieb, wahrscheinlich Datumswerte oder NICHTS als Ergebnisse ausgegeben werden sollen. Dafür würde ich aber lediglich WENNFEHLER() und zusätzlich benutzerdefiniertes Zahlenformat einsetzen. Wenn die Ergebniswerte auch Textwerte sein können, ist mein Vorschlag des Vergleiches mit ="" und der Klammerung mit WENNFEHLER() wohl etwas günstiger.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dropdown wechselseitig verknüpfen"