Note in Dezimalzahl umwandeln

Bild

Betrifft: Note in Dezimalzahl umwandeln
von: Timo
Geschrieben am: 30.04.2015 14:18:16

Hallo zusammen!
Ich habe folgendes Problem: Ein Schulnotenverwaltungsprogramm gibt mir die Möglichkeit, alle Noten der Schülerinnen und Schüler in einer Exceltabelle auszugeben. Diese gibt sie als Standartnoten aus (2+, 3-,...). Ich möchte die Noten jedoch als Dezimalzahl angezeigt bekommen. Gibt es die Möglichkeit in Excel, alle Noten automatisch umzuändern oder muss ich diese alle manuell in eine Dezimalzahl umschreiben?
Ich freue mich auf Rückmeldungen und sage schon jetzt vielen Dank!

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Daniel
Geschrieben am: 30.04.2015 14:24:15
Hi
du kannst in einer Hilfstabelle die StandardNoten in der ersten Spalte auflisten und in die Zelle daneben die dazugehörige Dezimalzahl schreiben.
Dann kannst du mit Hilfe des SVerweises in einer Formel den Dezimalwert zur Standardnote auslesen.
gruß Daniel

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Timo
Geschrieben am: 30.04.2015 14:32:28
Vielen Dank! Probiere ich nachher mal aus.

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Hajo_Zi
Geschrieben am: 30.04.2015 14:24:21

Tabelle1

 EF
9'2+2
10'3-3

verwendete Formeln
Zelle Formel Bereich N/A
F9:F10=WECHSELN(WECHSELN(E9;"+";"");"-";"")*1  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.26 einschl. 64 Bit




Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Timo
Geschrieben am: 30.04.2015 14:32:00
Hey! Vielen Dank für deine schnelle Rückmeldung. Allerdings verstehe ich deine Formel nicht ganz. Aus der 2+ soll eine 1,7 werden, aus der 2- eine 2,3. Wie schreibe ich das um?

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Hajo_Zi
Geschrieben am: 30.04.2015 14:42:21
Stand das im ersten Beitrag?
Ich erstelle die Lösung für das was im Beitrag dargestellt wurde. Wird diese Darstellung geändert, überlasse ich anderen die Lösung, da ich schon eine Lösung erstellt hatte und dafür Zeit investiert habe. Ich arbeite nicht für den Papierkorb.
Gruß Hajo

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Daniel
Geschrieben am: 30.04.2015 14:44:03
Hi
viellicht so, wenns regelmäßig ist (+ immer +0,3, - immer -0,3)(Note in A1)
=LINKS(A1;1)+(WENN(RECHTS(A1;1)="+";-0,3;WENN(RECHTS(A1;1)="-";0,3;0)))
Gruß Daniel

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: Rudi Maintaire
Geschrieben am: 30.04.2015 14:55:38
Hallo,
=LINKS(A1;1)+WENNFEHLER(WAHL(VERGLEICH(RECHTS(A1;1);{"+"."-"};);-0,3;0,3);0)
Gruß
Rudi

Bild

Betrifft: etwas "obfuscated" ...
von: lupo1
Geschrieben am: 30.04.2015 15:08:32
B1: =RUNDEN((3*LINKS(A1)+CODE(TEIL(A1&",";2;1))-44)/3;1)

Bild

Betrifft: AW: etwas "obfuscated" ... ohne Runden()
von: Rudi Maintaire
Geschrieben am: 30.04.2015 15:38:27
Hallo,
gute Idee!
=LINKS(A1)+(CODE(TEIL(A1&",";2;1))-44)*0,3
tut's auch.
Gruß
Rudi

Bild

Betrifft: Tiehmwörk
von: lupo1
Geschrieben am: 30.04.2015 16:29:36
... da war ich wohl blind. :)

Bild

Betrifft: AW: Note in Dezimalzahl umwandeln
von: UweD
Geschrieben am: 30.04.2015 15:13:27
Hallo
Tabelle1

 ABC
1Eingabe   
24+3,7ausreichend

verwendete Formeln
Zelle Formel Bereich
B2 =SVERWEIS(A2;Tabelle2!A:D;2;0) 
C2 =SVERWEIS(A2;Tabelle2!A:D;4;0) 



Tabelle2
 ABCD
1NotenNotenBewertungspunkteText
21+0,796-100sehr gut
31191-95sehr gut
41-1,387-90sehr gut
52+1,782-86gut
62277-81gut
72-2,373-76gut
83+2,768-72befriedigend
93363-67befriedigend
103-3,359-62befriedigend
114+3,754-58ausreichend
124449-53ausreichend
134-4,345-48ausreichend
145+4,736-44mangelhaft
155527-35mangelhaft
165-5,318-26mangelhaft
17660-17ungenügend

Tabellendarstellung in Foren Version 5.49


Gruß UweD

Bild

Betrifft: Deine Bewertungspunkte in eine Note
von: lupo1
Geschrieben am: 30.04.2015 15:31:45
B1: =RUNDEN(RUNDEN((7,65-A1/14)*3;)/3;1) Note, aus Punkten in A1
stimmt von 100% (0,7 sehr gut) bis 40% (4,7 mangelhaft) für Deine Punkteskala (ganze Punkte), die es aber auch anders aufgeteilt gibt (eher logarithmisch: IHK-Notenschlüssel u.a.). Sollen die 9er Sprünge am unteren Ende korrekt werden, muss sie verlängert werden.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Note in Dezimalzahl umwandeln"