Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summe dynamisch (März bis aktueller Monat)

Summe dynamisch (März bis aktueller Monat)
20.08.2015 13:52:15
D.
Hallo, habe eine Tabelle von März 2015 bis März 2016. Eine spalte berechnet die Summe bis zum aktuellen Monat -1. bisher
Z.B. für diesen Monat - März bis Juli (nicht August, da August noch nicht ganz durch ist).
Wie kann ich das durch eine dynamische Formel machenn
Bisher mache ich einfach nur SUMME(
SUMME(C24:F24) und ändere das F in G zum nächsten Monat, geht das auch automatisch?
VG

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summe dynamisch (März bis aktueller Monat)
20.08.2015 14:04:08
SF
Hola,
das ginge z.B. mit Summenprodukt.
Gruß,
steve1da

AW: es wäre auch mit nur SUMME() möglich ...
20.08.2015 14:21:42
...
Hallo,
... kombiniert mit INDEX(). Allerdings um dies konkreter anzugeben, wäre eine kleine Beispieldatei Deinerseits hilfreich.
Gruß Werner
.. , - ...

AW: es wäre auch mit nur SUMME() möglich ...
20.08.2015 14:32:11
D.
Hi, danke für die Info, anbei die Beispieldatei
https://www.herber.de/bbs/user/99715.xlsx
YTD: Apr bis letzter Monat
YTG: dieser Monat bis März
Danke!

AW: es wäre auch mit nur SUMME() möglich ...
20.08.2015 14:45:14
...
Hallo D.,
...in O2: =SUMME(C2:INDEX(2:2;VERGLEICH(TEXT(HEUTE();"MMM JJJJ");$1:$1;)-1)) und in
P2: =SUMME(INDEX(2:2;VERGLEICH(TEXT(HEUTE();"MMM JJJJ");$1:$1;)):N2) und Formeln nach unten kopieren.
Gruß Werner
.. , - ...

Anzeige
AW: es wäre auch mit nur SUMME() möglich ...
20.08.2015 14:58:25
D.
Hi, kriege leider kein Ergebnis (N/A), könntest du mir erklären was das ;$1:$1 macht hinter dem Jahr?

AW: dann sieh mal ...
20.08.2015 15:06:59
...
Hallo,
... $1:$1 steht nicht "hinter dem Jahr" und sie ist lediglich die Suchmatrix für das Suchkriterium welches ich mit TEXT(HEUTE();"MMM JJJJ") erst ermitteln muss, weil Du in C1:N1 keine echte Exceldatumswerte zu stehen hast sondern lediglich Textwerte. Hättest Du da echte Exceldatumswerte würde die Formel anders lauten und die Gefahr dass Du Dich in C1:N1 verschrieben hast wäre da wesentlich geringer.
 CDEFGHIJKLMNOP
1Apr 2015May 2015Jun 2015Jul 2015Aug 2015Sep 2015Oct 2015Nov 2015Dec 2015Jan 2016Feb 2016Mar 2016YTDYTG
25.4786.6019.97318.4555.3674.1905.0449.08013.9073.7547.7694.10340.50753.214
37.1728.5249.8406.9306.4269.6446.6508.4038.1545.9666.1785.11832.46656.539
41.0024.5647046962.9423.0484.7312.8023.0462.8104.0222.1426.96625.544
52893544433191.2891.9211.6842.2122.3451.7111.7001.7021.40514.564

Formeln der Tabelle
ZelleFormel
O2=SUMME(C2:INDEX(2:2;VERGLEICH(TEXT(HEUTE(); "MMM JJJJ"); $1:$1;)-1))
P2=SUMME(INDEX(2:2;VERGLEICH(TEXT(HEUTE(); "MMM JJJJ"); $1:$1;)):N2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Anzeige
AW: dann sieh mal ...
20.08.2015 15:16:05
D.
Danke, jetzt habe ich den Fehler. Ich habe die englische Version und dort is JJJJ natürlich YYYY. Hatte das nicht geändert. Vielen Dank

52 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige