#DIV/0! bei Mittelwert über mehrere Zellen


Betrifft: #DIV/0! bei Mittelwert über mehrere Zellen
von: alex_de_souza
Geschrieben am: 18.04.2019 13:26:47

Hallo,
ich möchte den Mittelwert über mehrere Zellen bilden, wobei in einigen Zellen derzeit aufgrund fehlender Daten #DIV/0! steht.
Im Internet habe ich mehrere Formeln gefunden, die #DIV/0! ignorieren und den Mittelwert bilden. Jedoch ist in den Formeln immer nur eine Range Bsp. A3:A10 eingetragen.
Gibt es die Möglichkeit auch für einzelne Zellen? Beispielsweise möchte ich den Mittelwert von A3,A27,A51,A75, usw... wobei derzeit bei allen Zellen nach A51 #DIV/0! steht.
Gibt es eine Lösung dafür?
LG

Betrifft: Aggreagt und Klammern
von: Daniel
Geschrieben am: 18.04.2019 13:31:43
HI
zum Ignorieren von Fehlerwerten nimm Aggregat.
setze die Einzelnen Zellen in Klammern, um anzuzeigen dass das ein Zellbereich sein soll:
=Aggregat(1;6;(A3;A27;A51;A75))
Gruß Daniel

Betrifft: Mit AGGREGAT fktioniert bei ZellBereichen ...
von: Luc:-?
Geschrieben am: 18.04.2019 13:53:59
…beides, Daniel & Alex,
man kann per zusätzlicher Klammern einen diskontinuierlichen Bereich angeben (bei den ~WENNs-Fktt und INDIREKT nicht!) oder auch einfach alle aufführen (ohne zusätzliche Klammern). Nur in den sog MatrixVarianten (ab Argument1=14) ist nur die KlammerVariante möglich, da das 4.Argument für die Angabe von k benutzt wdn muss. Das ergibt sich schon aus den integrierten Xl-Fktt, denn AGGREGAT ist quasi ein Verteiler mit integrierter DatenVorbereitung.
Gruß + FrOst, Luc :-?

„Der beste Beweis für intelligentes Leben im Universum ist, dass noch niemand versucht hat, Kontakt mit uns aufzunehmen.“ H.Lesch, 2018, Sonneberg
Deshalb Intelligenz steigern mit …


Betrifft: AW: Aggreagt und Klammern
von: alex_de_souza
Geschrieben am: 18.04.2019 13:58:11
Hat super funktioniert, vielen Dank!

Betrifft: AW: #DIV/0! bei Mittelwert über mehrere Zellen
von: SF
Geschrieben am: 18.04.2019 13:38:21
Hola,
eliminer die #DIV/0 mit Wennfehler. Dann als Matrixformel:
=MITTELWERT(WENN((REST(ZEILE(A3:A300);24)=3)*(A3:A300<>"");A3:A300))
Die Formel mit Strg-Shift-Enter abschließen.
Gruß,
steve1da

Betrifft: AW: #DIV/0! bei Mittelwert über mehrere Zellen
von: alex_de_souza
Geschrieben am: 18.04.2019 14:00:24
Vielen Dank steve! :)

Excel-Beispiele zum Thema "#DIV/0! bei Mittelwert über mehrere Zellen "