Microsoft Excel

Herbers Excel/VBA-Archiv

Excel fügt "@" in Formel hinzu (FormulaLocal)

Betrifft: Excel fügt "@" in Formel hinzu (FormulaLocal) von: Moritz
Geschrieben am: 07.09.2020 11:36:33

Hallo zusammen,


wenn ich über ein Excel-Makro mittels folgendem Befehl eine Formel in eine Zelle schreibe

Range("AH" & Zeile_Ziel).FormulaLocal = "=SVERWEIS(LINKS(L" & Zeile_Ziel & ";3);WENN(' _
Tabellenblatt'!$B$5:'Tabellenblatt'!$B$62=RECHTS(L" & Zeile_Ziel & ";3);'Tabellenblatt'!$A$5:'Tabellenblatt'!$C$62;““);3)"


kommt folgende Formel in Excel an

=SVERWEIS(LINKS(L20;3);WENN(@'Tabellenblatt'!$B$5:'Tabellenblatt'!$B$62=RECHTS(L20;3);' _
Tabellenblatt'!$A$5:'Tabellenblatt'!$C$62;““);3)


Das "@"-Zeichen in der WENN-Funktion kommt dabei hinzu und macht die Formel unbrauchbar. Sobald ich händisch in der Zelle das "@"-Zeichen entferne funktioniert die Formel wieder.


Warum fügt Excel hier das "@"-Zeichen ein und hat jemand eine Idee, wie ich es hinbekomme, dass dieses nicht mit eingefügt wird?


Vielen Dank bereits im Voraus für Eure Mithilfe.

Moritz

Betrifft: AW: hast Du Excel365 im Einsatz? owT
von: neopa C
Geschrieben am: 07.09.2020 11:40:00

Gruß Werner
.. , - ...

Betrifft: AW: hast Du Excel365 im Einsatz? owT
von: Moritz
Geschrieben am: 07.09.2020 11:41:02

ja Excel365

Betrifft: AW:dann stell ich thread offen, hab kein XL365 owT
von: neopa C
Geschrieben am: 07.09.2020 11:43:24

Gruß Werner
.. , - ...

Betrifft: AW: Excel fügt "@" in Formel hinzu (FormulaLocal)
von: Daniel
Geschrieben am: 07.09.2020 11:49:05

Hi

aufgrund des Zellbezugs "Tabellenblatt'!$B$5:'Tabellenblatt'!$B$62" in der WENN-Funktion ist das eine Matrixformel.
bei Handeingabe erkennt Excel 365 das automatisch.
bei VBA müsste die Formel wahrscheinlich mit .FormulaArray in die Zelle geschrieben werden.
ober du passt die Formel so an, dass im ersten Parameter der WENN-Funktion kein Zellbereich, sondern ein Einzelwert steht, damit die Formel wieder eine normale Formel ist und keine Matrxiformel mehr.

Gruß Daniel

Betrifft: AW: Excel fügt "@" in Formel hinzu (FormulaLocal)
von: peterk
Geschrieben am: 07.09.2020 12:07:12

Hallo

Verwende Range.Formula2Local

Peter

Betrifft: AW: Excel fügt "@" in Formel hinzu (FormulaLocal)
von: Moritz
Geschrieben am: 07.09.2020 12:16:09

Vielen Dank für die Antworten
Range.Formula2Local funktioniert!

Beiträge aus dem Excel-Forum zum Thema "Excel fügt "@" in Formel hinzu (FormulaLocal)"