Zeilen automatisch ausfüllen

Bild

Betrifft: Zeilen automatisch ausfüllen
von: Roland
Geschrieben am: 18.02.2005 10:35:18
Hallo,
Ich möchte bei einer einfachen Tabelle eine Zelle
automatisch ausfüllen.
Dass heisst ich möchte dass so lösen.
- Wenn ich in Zelle B6 etwas eingebe, egal was, sollte in
Zelle A6 eine 1 kommen.
- Wenn ich in Zelle B9 etwas eingebe, sollte in
Zelle A9 eine 2 kommen.
und so weiter. Dass heisst einfach ausgedrückt, sollte er mir in der
ersten Zeile eine Nummerierung bringen, aber nur wenn ich in Spalte B
was eingebe.
Ist das irgendwie möglich ?
Danke im Voraus

Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: Reinhold
Geschrieben am: 18.02.2005 10:46:40
Hallo Roland,
im VBAProject in z.B. Tabelle1 folgendes eingeben

Private Sub Worksheet_Change(ByVal Target As Range)
  If Target.Cells.Count = 1 Then
    If Target.Column = 2 Then
      Target.Offset(0, -1).Value = Application.WorksheetFunction.Max(Columns(1).Cells) + 1
    End If
  End If
End Sub

Grüße Reinhold
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: Bernhard
Geschrieben am: 18.02.2005 10:49:08
if..then..else
in A6 z.B. =wenn(b6>0;1;"")
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: c0bRa
Geschrieben am: 18.02.2005 10:52:09
datei vergessen :)
https://www.herber.de/bbs/user/18281.xls
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: c0bRa
Geschrieben am: 18.02.2005 10:49:47
hallo...
hier mal mein vorschlag:
A1=WENN(B1="";"";ZÄHLENWENN($B$1:B1;"<>"))

Das Forum lebt auch von Rückmeldungen...
c0bRa
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: Roland
Geschrieben am: 18.02.2005 11:06:09
Hallo...
Ihr seid ja schnell wie nix anderes....
Besten Dank für die tolle Hilfe...
wünsch euch allen ein schönes Weekend...
Thx
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: Roland
Geschrieben am: 18.02.2005 11:11:58
Hallo nochmal..
Die formel funktioniert 1A...
Gibts eine Möglichkeit dass ich in einer
anderen Zelle, sagen wir C60 die letzte der
eingefügten nummen in der spalte A kriege ?
thx...
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: c0bRa
Geschrieben am: 18.02.2005 11:15:56
hi nochmal
is ja fast schon zu einfach *duck* :D
=KGRÖSSTE(A:A;1)
c0bRa
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: c0bRa
Geschrieben am: 18.02.2005 11:23:16
oder meinst du die, bei der in Spalte B die letzte eingabe gemacht worden ist?
weil dann denk ich mal wirds haarig mit formeln...
da musst du dann denk ich mal auf VBA zurückgreifen
Bild

Betrifft: AW: Zeilen automatisch ausfüllen
von: Roland
Geschrieben am: 18.02.2005 11:26:05
Ich frag mich schon, was Ihr so Studiert habt...
kann man(n) Excel an der Uni Studieren... :-))
Wirklich super, besten Dank...
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeilen automatisch ausfüllen"