Herbers Excel-Forum - das Archiv

Buchstaben mit Zahlenwert verknüpfen?

Bild

Betrifft: Buchstaben mit Zahlenwert verknüpfen?
von: Peter

Geschrieben am: 15.12.2006 13:49:02
Guten Tag,
ich habe hier bereits ein wenig rumgestöbert,konnte jedoch leiderkeine Antwort auf meine Frage finden. Dazu kommt noch, dass ich leider kaum Erfahrung mit Excel habe.
Und zwar geht es mir darum: Wenn ich einen Dienstplan erstelle, dann füge ich dort nicht die Stundenzahl direkt ein, sondern schreibe "T"(Tagschicht), "S"(Spätschicht), usw...
Ist es möglich, Excel beizubringen, dass "T" für 7, "S" für 10, usw steht? Das ich quasi am Ende nicht die Zahlen, sondern die Buchstaben zusammenzähle?
MIt freundlichen Grüßen,
P. Schmidt
Bild

Betrifft: AW: Buchstaben mit Zahlenwert verknüpfen?
von: Klaus-Dieter

Geschrieben am: 15.12.2006 13:53:47
Hallo Peter,
so würde das gehen:
 ABCD
3Fr. 01.12.2006STagschicht56
4Sa. 02.12.2006 Spätschicht60
5So. 03.12.2006   
6Mo. 04.12.2006T  
7Di. 05.12.2006T  
8Mi. 06.12.2006T  
9Do. 07.12.2006T  
10Fr. 08.12.2006T  
11Sa. 09.12.2006   
12So. 10.12.2006   
13Mo. 11.12.2006S  
14Di. 12.12.2006S  
15Mi. 13.12.2006S  
16Do. 14.12.2006S  
17Fr. 15.12.2006S  
18Sa. 16.12.2006   
19So. 17.12.2006   
20Mo. 18.12.2006T  
21Di. 19.12.2006T  
22Mi. 20.12.2006T  

Formeln der Tabelle
ZelleFormel
D3=ZÄHLENWENN(B3:B22;"T")*7
D4=ZÄHLENWENN(B3:B22;"S")*10

Viele Grüße Klaus-Dieter

Online-Excel
Bild

Betrifft: AW: Buchstaben mit Zahlenwert verknüpfen?
von: Peter
Geschrieben am: 15.12.2006 14:39:24
Super, das hilft mir schonmal ein ganzes Stück weiter. KAnn ich die Formeln jetzt auch so nutzen, das Excel alles auf einmal schafft? Oder muss ich für jede "Schicht-Art" den Befehl erneut eingeben?
Bild

Betrifft: AW: Buchstaben mit Zahlenwert verknüpfen?
von: Klaus-Dieter

Geschrieben am: 15.12.2006 20:16:33
Hallo Peter,
meinst du das so?
 ABCD
1Fr. 01.12.2006SStunden116
2Sa. 02.12.2006   
3So. 03.12.2006   
4Mo. 04.12.2006T  
5Di. 05.12.2006T  
6Mi. 06.12.2006T  
7Do. 07.12.2006T  
8Fr. 08.12.2006T  
9Sa. 09.12.2006   
10So. 10.12.2006   
11Mo. 11.12.2006S  
12Di. 12.12.2006S  
13Mi. 13.12.2006S  
14Do. 14.12.2006S  
15Fr. 15.12.2006S  
16Sa. 16.12.2006   
17So. 17.12.2006   
18Mo. 18.12.2006T  
19Di. 19.12.2006T  
20Mi. 20.12.2006T  

Formeln der Tabelle
ZelleFormel
D1=ZÄHLENWENN(B1:B20;"T")*7+ZÄHLENWENN(B1:B20;"S")*10

Viele Grüße Klaus-Dieter

Online-Excel
 Bild
Excel-Beispiele zum Thema "Buchstaben mit Zahlenwert verknüpfen? "
Eingabe in Großbuchstaben wandeln Nur Buchstaben in eine UserForm-TextBox
Zeichenfolge in Ziffern und Buchstaben aufteilen Ersten mit einem neuen Buchstaben beginnenden Namen fett schreiben
Letzte Zeile mit einem bestimmten Anfangsbuchstaben markieren Umwandlung einer Zeichenfolge in Spalte A in Großbuchstaben
In einer Namensliste Großbuchstaben einsetzen Buchstaben aus Textdatei entfernen und neu speichern
Buchstabenindex des Arbeitsblattes mit der Fundzelle