Microsoft Excel

Herbers Excel/VBA-Archiv

Werte zwischen zwei Zahlen zählen | Herbers Excel-Forum


Betrifft: Werte zwischen zwei Zahlen zählen von: Bernd
Geschrieben am: 27.11.2009 10:20:51

Hallo zusammen,

ich kämpfe zur Zeit mit folgendem Problem:

In in einer bestimmten Spalte stehen verschiedene Werte zwischen -1 und +1. Ich möchte nun ermitteln, wie viele Werte nun z.B: zwischen -0,05 und -0,09 vorhanden sind. Zählenwenn funktioniert hier ja nicht und die Formel mit Summenprodukt wirft unsinnige Werte aus.
Beispiel der Vorbesprechnung:
=ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;">"&B19) Ergebnis = 4
=ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;"<"&C19) Ergebnis = 7
=SUMMENPRODUKT(('Grunddaten berechnet'!$R7:$R4000>B19)*('Grunddaten berechnet'!$R7:$R4000 = Ergebnis 3985
Hier sollte der Wert 1 stehen

Ich hoffe ihr könnt mir weiterhelfen

Gruß Bernd

  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: Ptonka
Geschrieben am: 27.11.2009 10:33:49

Hallo Bernd,

versuche es mal mit Subtrahieren:

=ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;"<"&C19) - ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;">"&B19)

Gruß,
Ptonka


  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: KlausF
Geschrieben am: 27.11.2009 10:39:19

Hallo Bernd!

Ich würde mit Zählenwenn die Anzahl bis zu den einzelnen Intervallobergrenzen errechnen lassen und dann aus den Differenzen die Intervallwerte selbst ermitteln.
z.B.:
=ZÄHLENWENN(A1:A100;"<=0,09") ergibt 7 ~f~
~f~ =ZÄHLENWENN(A1:A100;"<=0,05") ergibt 4
dann liegen in dem Intervall 0,05-0,09 3 Werte.

Gruß aus dem Erzgebirge
Klaus


  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: Bernd
Geschrieben am: 27.11.2009 10:51:25

Hallo Klaus,

funktioniert leider nicht. Ich stelle mal eine Datei ein. Im Blatt Grunddaten berechnet sind in der Spalte R die zu überprüfenden Werte und das Ergebnis soll im Blatt Cluster dargestellt werden

https://www.herber.de/bbs/user/66221.xls


  

Betrifft: Du musst die Leerzellen eliminieren von: WF
Geschrieben am: 27.11.2009 11:08:23

Hi,

=SUMMENPRODUKT((R7:R4000 > B19)*(R7:R4000 < C19)*(R7:R4000 <> ""))

Salut WF


  

Betrifft: AW: Du musst die Leerzellen eliminieren von: Bernd
Geschrieben am: 27.11.2009 11:14:57

Hi WF,

das ist es!!! Vielen Dank! Da bleibt mir ja am Wochenende meine Haarfarbe erhalten :-))

Liebe Grüße aus Frankfurt und ein schönes Wochenende

Bernd


  

Betrifft: AW: Du musst die Leerzellen eliminieren von: Bernd
Geschrieben am: 27.11.2009 12:32:47

Hallo WF,

bin noch mal da.
Die Formel Summenprodukt hat Probleme mit negativen Zahlenwerten. Bei Berechnungen mit Werten zwischen -0,0001 und -0,99999 wird nur 0 ausgegeben. Kann man das abfangen. Die Multiplikation mit -1 hilft auch nicht weiter (bei mir zumindest nicht)

Gruß Bernd


  

Betrifft: AW: Du musst die Leerzellen eliminieren von: ingoG
Geschrieben am: 27.11.2009 14:03:24

Hallo Bernd,
kann es sein, dass Du minimum und maximum vertauscht hast ;-)
sicher sollte dass folgende ergänzung verhindern:


=SUMMENPRODUKT((R7:R4000 > min(B19;c19))*(R7:R4000 < max(B19;c19))*(R7:R4000 <> ""))


Gruß Ingo
PS eine Rückmeldung wäre nett...


  

Betrifft: AW: Du musst die Leerzellen eliminieren von: Bernd
Geschrieben am: 30.11.2009 08:36:10

Hallo Ingo,

bin am Freitag nicht mehr dazu gekommen.
Aber auch so funktionierts leider nicht.

Gruß Bernd


  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: ingoG
Geschrieben am: 27.11.2009 11:13:04

Hallo Bernd,

Deine Formel muss heissen:

=ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;"<"&C11) - ZÄHLENWENN('Grunddaten berechnet'!$R7:$R4000;"<="&B11)



das erste zählenwenn zählt alle kleiner dem Maximum unabhängig vom minimum.
das zweite zählenwenn zählt dann alle, die kleiner-gleich dem Minimum sind (du hast ja offene intervalle)
die differenz ist genau dein Ergebnis.

Gruß Ingo
PS eine Rückmeldung wäre nett...


  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: Bernd
Geschrieben am: 27.11.2009 11:17:18

Hallo ingoG,

hab's mit der Lösung von WF bekommen. Trotzdem: Herzlichen Dank

Bernd


  

Betrifft: Danke für die Rückeldung mT von: ingoG
Geschrieben am: 27.11.2009 11:20:39

Hallo Bernd,

kein Problem, wobei uU zählenwenn schneller sein kann (ist aber nur bei großen Datenmengen relevant)...

Gruß Ingo


  

Betrifft: AW: Werte zwischen zwei Zahlen zählen von: Bernd
Geschrieben am: 27.11.2009 10:41:50

Hallo Ptonka,

das hab ich auch schon getestet, liefert aber leider den Wert 3 und der sollte 1 sein
(überprüft mit =UND(R7<$X$18;R7>$Y$18) für 10 Zeilen. 9 x falsch und 1 x wahr)

Gruß Bernd


Beiträge aus den Excel-Beispielen zum Thema "Werte zwischen zwei Zahlen zählen"