Excel Matrix durchlaufen

Bild

Betrifft: Excel Matrix durchlaufen
von: Martin
Geschrieben am: 01.05.2015 17:03:52

Hallo,
ich schreibe an einem kleinen Kalkulator und habe folgende Aufgabenstellung:
In Spalte 'A' Stehen Artikelnamen, in Spalte 'B' deren Betrag und die Spalten C-M repräsentieren Personen, die evtl. einen Teilbetrag am Betrag aus 'B' bezahlen müssen.
Nun soll der Teilbetrag der Personen berechnet werden. Eine Person zahle einen Teil am Artikel mit, wenn in der jeweiligen Zeile ein "x" in der Spalte der Person steht.
Nun brauche ich eine Formel, die zuerst zeilenweise schaut, ob beim jeweiligen Artikel ein "x" bei besagter Person vorhanden ist. Falls ja, muss geschaut werden wie viel weitere Personen ein "x" in der Zeile stehen haben um den exakten Zeilbetrag ermitteln zu können und schlussendlich muss der Betrag durch die Anzahl "x" geteilt werden, dann Teilbetrag vorhanden. Dann muss das Zeile für Zeile passieren und alle Teilbeträge der Person addiert werden.
Ich bekomme das bisher nur mithilfe einer extra Spalte 'C' hin, in der die Teilbeträge wie folgt berechnet werden:
=WENN(UND($B2<>"";ZÄHLENWENN($D2:$M2;"x")>0);$B2/ZÄHLENWENN($D2:$M2;"x");"")~f~
Dann werden die Endbeträge so berechnet:
~f~=WENN(SUMMEWENN($D$2:$D$1000;"x";$C$2:$C$1000)<>0;SUMMEWENN($D$2:$D$1000;"x";$C$2:$C$1000);"")
Wie kann ich das ohne die Extraspalte lösen?
Danke vorab!

Bild

Betrifft: AW: Excel Matrix durchlaufen
von: Hubert
Geschrieben am: 02.05.2015 00:06:20
Hallo Martin
hier mein Lösungsvorschlag über VBA.
Schau in meine hochgeladene Datei. Dort erhältst du über den Button Summen
die gewünschten Ergebnisse.
Das geht in VBA zwar vielleicht noch etwas eleganter und kürzer, aber ich komm zum richtigen Ergebnis.
https://www.herber.de/bbs/user/97415.xlsm
Gruß, Hubert

Bild

Betrifft: AW: Excel Matrix durchlaufen
von: Martin
Geschrieben am: 02.05.2015 14:59:05
Hallo Hubert,
vielen Dank für deinen Lösungsansatz.
Über VBA habe ich das Problem auch bereits gelöst, leider darf die Datei keine Makros enthalten.
Ich weiß nicht, ob SUMMENPRODUKT der richtige Lösungsansatz ist oder ob es überhaupt nicht ohne Zwischenschritt geht. Ich grüble jetzt schon eine ganze Weile ohne Erfolg..

Bild

Betrifft: AW: Excel Matrix durchlaufen
von: Hubert
Geschrieben am: 03.05.2015 12:09:37
Hi Martin
Leider habe ich Formeltechnisch auch noch keine Lösung gefunden.
Falls doch noch, werde ich mich melden.
Ich lass deine Frage daher noch auf Offen stehen.
Gruß, Hubert

Bild

Betrifft: Summenprodukt
von: Frank
Geschrieben am: 03.05.2015 13:48:07
Hallo Hubert,
über Summenprodukt könnt es gehen, das liefert Dir, wenn richtig gemacht, die Anzahl der beteiligten Personen. Dazu darfst Du aber keine "x" verwenden, sondern musst statt dessen Zahlen ("1") nehmen. Was aber gleichzeitig den Vorteil hätte, dass man gewichten könnte: Hubert kriegt ne 2 und Matthias und Günter eine 1. Dann zahlt Hubert die Hälfte und die anderen beiden ein Viertel...
Übrigens: Beispieldatei wäre hilfreich, dann könnte der interessierte Helfende gleich da drin rumbasteln.
Grüsse,
Frank

Bild

Betrifft: AW: Summenprodukt
von: Hubert
Geschrieben am: 03.05.2015 21:32:42
Hallo Martin
also mit einer Formel bekomme ich das hin, habe aber dafür
in Spalte C eine "Hilfsspalte" eingefügt (die ausgeblendet ist) und
die in den Formeln in Zeile 10 benutzt wird.
Schau dir das mal hier an:
https://www.herber.de/bbs/user/97442.xlsx
@Frank
Nur zur Info: ich war hier nicht der Fragensteller, sondern Martin.
Eine Beispieldatei war von mir schon in der ersten Antwort gebastelt.
Trotzdem Danke.
Grüße, Hubert

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel Matrix durchlaufen"