Differenz zwischen versch. Start- und Endzeiten

Bild

Betrifft: Differenz zwischen versch. Start- und Endzeiten
von: Hans
Geschrieben am: 05.05.2015 16:50:57

Hallo,
ich habe eine Störungsliste einer Anlage, in die einzelnen Spalten folgende sind:
Störgrund (Zahl)
Start:1 / Ende:0
Uhrzeit
Dabei ist in der Zeile eine 1, wenn der Fehler beginnt.
In einer Zeile weiter unten ist eine 0, wenn der Fehler endet.
Also beispielsweise:
4711 - 1 - 12:34:56
4711 - 0 - 12:36:24
4711 - 1 - 12:49:31
4711 - 0 - 13:12:34
und das recht häufig.
Wie muss eine Formel aussehen, um die Zeitdifferenz zwischen Start- und Endzeitpunkt jeweils herauszufinden? Ist dies mit Excel (ohne VBA) überhaupt möglich?
Vielen Dank und viele Grüße
Hans

Bild

Betrifft: Angaben sind eindeutig ,,,
von: der neopa C
Geschrieben am: 05.05.2015 17:05:04
Hallo Hans,
... was genau willst Du ermitteln? Die Gesamtdauer der Störung je Störgrund? Oder die Zeit von der ersten Störung bis zum Ende der letzten Störung je Störgrund? Oder?
Gruß Werner
.. , - ...

Bild

Betrifft: Angaben sind natürlich nicht ! eindeutig owT
von: der neopa C
Geschrieben am: 05.05.2015 19:17:53
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: Daniel
Geschrieben am: 05.05.2015 19:35:15
Hi
was wäre denn für die gezeigte Tabelle dein Wunschergebnis?
- die Differenz zwischen erster und Letzter Zeile? (dh von 12:34 bis 13:12) => 38 Minuten
- die Zeitdauern der einzelnen Störungen aufsummiert( von 12:34 bis 12:36 plus von 12:49 bis 13:12) => 25 Minuten
Gruß Daniel

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: Hans
Geschrieben am: 05.05.2015 19:45:15
Hallo Werner, hallo Daniel,
ich möchte die Dauer jeder einzelnen Störung herausfinden. Die eigentliche Datei enthält täglich ca. 600 Störungen - und es gibt mehrere Störgrundnummern - , so dass ich dies gerne per Excel-Formel machen möchte. Ich könnte mir vorstellen, dass in der Lösung irgendwo so etwas vorkommt wie Summewenn, aber so richtig hab ichs noch nicht hinbekommen...
Viele Grüße
Hans

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: Daniel
Geschrieben am: 05.05.2015 20:02:52
Hi
wenn du die Zeitsumme für die Stillstandszeiteen der Störung 4711 wissen willst, dann pobiere mal die Formel:
=SummeWenns(C:C;A:A;4711;B:B;0)-SummeWenns(C:C;A:A;4711;B:B;1)
oder
=Summenprodukt((A1:A99=4711)*1;1-B1:B99*2;C1:C99)
Gruß Daniel

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: DD
Geschrieben am: 05.05.2015 19:51:24
Hallo Hans,
vielleicht so?
https://www.herber.de/bbs/user/97482.xlsx
Gruß Dieter_D

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: Hans
Geschrieben am: 06.05.2015 06:58:45
Hallo zusammen,
vielleicht habe ich die Datei etwas zu einfach angegeben:
Wie bereits geschrieben, sind in der Datei nicht nur ein paar wenige, sondern über 50.000 Störungen zu finden. Pro Tag kommen ca. 600 Meldungen hinzu.
Außerdem gibt es verschiedene Störgründe. Zusätzlich können sich diese auch noch überlappen:
4711 - 1 - 12:34:56
0815 - 1 - 12:34:58
4711 - 0 - 12:36:24
2342 - 1 - 12:40:40
0815 - 0 - 12:42:42
4711 - 1 - 12:49:31
4711 - 0 - 13:12:34
2342 - 0 - 13:14:15
Und ich wüsste gerne die Dauer JEDER EINZELNEN Störung...
Viele Grüße
Hans

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: GeorgH
Geschrieben am: 06.05.2015 14:56:25
Hallo Hans,
bezogen auf dein letztes Beispiel:
Daten stehen im Bereich A1:C8
In Zelle D2 folgende Formel eintragen:
=WENN(B2=0;WENN(INDEX(B:B;AGGREGAT(14;6;($A$1:A1=A2)*ZEILE($C$1:C1);1))<>1;"letzter Status <> 1"; C2-AGGREGAT(14;6;($A$1:A1=A2)*($C$1:C1);1));"")
Zelle D2 mit [hh]:mm:ss formatieren und anschließend in den Bereich D3:D8 kopieren.
PS: Damit würde ich allerdings immer nur die ca. 600 Meldungen eines Tages bearbeiten.
Dies auch unter Berücksichtigung, dass du in deinem Beispiel nur Uhrzeiten aufgeführt hast und nicht Datum mit Uhrzeit wie "06.05.2015 12:34:56"
Viele Grüße
Georg

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: Hans
Geschrieben am: 07.05.2015 07:03:23
Hallo Georg,
danke für die Antwort. Leider kriege ich kein Ergebnis, wenn ich deine Formel nutze. Habe sie auch angepasst, aber bekomme trotzdem entweder "letzter Status <> 1" oder eine leere Zelle (also "").
Kannst du mir erklären, was welcher Teil der Formel tut?
Viele Grüße
Hans

Bild

Betrifft: AW: Differenz zwischen versch. Start- und Endzeiten
von: GeorgH
Geschrieben am: 08.05.2015 13:00:12
Hallo Hans,
konnte leider nicht früher antworten.
Habe mal eine Beispieldatei hochgeladen. Formelableitung ist mit drin.
https://www.herber.de/bbs/user/97536.xlsx
Viele Grüße
Georg

Bild

Betrifft: Anmerkungen ...
von: der neopa C
Geschrieben am: 08.05.2015 16:12:25
Hallo Georg,
... zunächst finde ich es prima, dass Du Dich der spez. AGGREGAT()-Funktionalität kombiniert mit INDEX() angenommen hast (mich würde interessieren, ob Du das schon länger tust)
Im vorliegenden Fall könnte man auch alternativ (kürzer) mit folgender Matrixfunktinalitäs-Formel in D2: =WENN(B2=0;WENNFEHLER(C2-VERWEIS(9;1/(A$1:A1=A2)/(B$1:B1=1);C:C);"");"") bei gleicher Voraussetzung (die Du schon genannt hast) zum gleichen Ergebnis gelangen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Anmerkungen ...
von: Hans
Geschrieben am: 12.05.2015 09:09:12
Hallo Georg und Werner,
vielen Dank für eure Antworten - habe sie jetzt auch umgesetzt.
Meine Lösung, die ich zwischenzeitlich umgesetzt habe, setzt einfach voraus, dass 1 und 0 zu einer Störung immer abwechselnd kommen - eure Lösung ist natürlich viel eleganter. Vielen Dank!
Nur der Vollständigkeit mein Lösungsansatz:
1. in einer extra Spalte (Q) die Zeile des letzten Auftretens einer Fehlernummer dokumentieren: =MAX(ZEILE($E$1:E1)*($E$1:E1=E2))
2. in Spalte R mit der Zeilennummer die entsprechende Zellennummer zusammenstellen, in der der Zeitwert ist:
=WENN(Q2=0;;ADRESSE(Q2;1))
3. in Spalte S die Zeit:
=WENN(R2=0;;INDIREKT(R2))
4. in Spalte T: wenn der Fehler aufgehört hat (0) wird die Differenz zwischen letztem Auftreten und der aktuellen Zeit genommen:
=WENN(C2=0;WENN(Q2=0;;A2-S2);)
Die restliche Auswertung mache ich dann mit einer Pivot-Tabelle (nachdem ich in Performance-probleme mit Matrix-Formeln gelaufen bin).
Vielen Dank und viele Grüße
Hans

Bild

Betrifft: AW: mit PIVOT-Tabelle
von: Daniel
Geschrieben am: 07.05.2015 09:34:52
Hi
du kannst ggf eine Auswertung nach Störungsart mit Hilfe der Pivotabelle machen.
hierbei ziest du dann im Pivotwizard auch noch die Spalte mit den 0 und 1 nach "Spaltenbeschriftungen"
dann werden Start- und Endzeit in untereschiedliche Spalten geschrieben und du kannst in einer Hilfsspalte die Differenz bilden um die Störungsdauer zu berechnen.
oder du erstellst vorher eine Hilfstabelle mit der Formel:
=Wenn(B1=0;C1;-C1)
und wertest dann dieses Spalte in der Pivottabelle aus.
Dann wird die Differenz gleich automatisch gebildet.
Gruß Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Differenz zwischen versch. Start- und Endzeiten"