Microsoft Excel

Herbers Excel/VBA-Archiv

Differenz zwischen Datumsangaben

Betrifft: Differenz zwischen Datumsangaben von: Thomas
Geschrieben am: 29.10.2020 21:21:09

Liebe Excel-Gemeinde,

heute bräuchte ich bitte wieder Eure Hilfe.

In Spalte A stehen Datumsangaben.

Wenn die Differenz zwischen den Daten 1 ist, soll am Ende des Bereiches die Differenz zwischen dem ersten und letzten Datum erscheinen.

Link führt zur Beispieldatei

Tausend Dank

Thomas

https://www.herber.de/bbs/user/141175.xlsx

Betrifft: AW: Differenz zwischen Datumsangaben
von: Hajo_Zi
Geschrieben am: 30.10.2020 05:18:19

Hallo Thomas,

=MAX(A2:A12)-MIN(A2:A12)

GrußformelHomepage

Betrifft: AW: Differenz zwischen Datumsangaben
von: Thomas
Geschrieben am: 30.10.2020 05:37:13

Hallo Hajo,
danke für den Tipp.
Genau das soll in Spalte B aber am Ende des Datumsbereiches in Spalte A berechnet werden.
Ändert sich die Differenz zwischen den Daten zu >1 soll die Rechnung von neuen beginnen.
???
Danke und Gruß
Thomas

Betrifft: AW: Differenz zwischen Datumsangaben
von: Hajo_Zi
Geschrieben am: 30.10.2020 13:38:51

schreibe in die letzte Zeile
Wenn(A13="";MAX(A2:A12)-MIN(A2:A12);"")

und runterziehen


Gruß Hajo

Betrifft: AW: das ergibt nicht das schon ermittelte owT
von: neopa C
Geschrieben am: 30.10.2020 15:19:26

Gruß Werner
.. , - ...

Betrifft: AW: ohne Hilfssp.: mit geschachtelt. AGGREGAT()...
von: neopa C
Geschrieben am: 30.10.2020 09:35:01

Hallo Thomas,

... mit einer Hilfsspalte würde es einfacher gehen als nachfolgend aufgezeigt.
Und ohne eine solche HSp. in B2 z.B. so:

=WENN((A3="")+(A3-A2>1)+(A4-A3=1);"";WENNFEHLER(AGGREGAT(15;6;ZEILE(A$1:A1)/(AGGREGAT(15;6;A3-A$2:A2;ZEILE(A$2:A2))-AGGREGAT(15;6;A3-A$2:A2;ZEILE(A$1:A1))>1);1);ZEILE(A1)))

Und Formel nach unten ziehend kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: ohne Hilfssp.: mit geschachtelt. AGGREGAT()...
von: Thomas
Geschrieben am: 30.10.2020 10:48:13

Hallo Werner.
Tausend Dank.
Ich muss mich ein bisschen Intensiver mit Aggregat befassen.
Gruß
Thomas
P.S.
Melde mich später noch mal via Mail

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 30.10.2020 11:05:06

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Differenz zwischen Datumsangaben"