Microsoft Excel

Herbers Excel/VBA-Archiv

Summe nicht ganz korrekt

Betrifft: Summe nicht ganz korrekt von: Guesa
Geschrieben am: 03.10.2020 09:29:01

Hallo Forum
Ein Kollege hat mir folgende Liste geschickt, in der eine simple Summenformel steht. Er hat die einzelnen Daten mit einem Taschenrechner nachgerechnet und festgestellt, dass die Summe um 0,01 von der in Excel berechneten Summe abweicht.
Summe Excel = 9,45 Taschenrechner = 9,46. Ich gebe mal die Frage: Wieso da verschiedene Ergebnisse herauskommen
an die Fachleute im Forum weiter.

Gruß, Guesa

https://www.herber.de/bbs/user/140610.xlsx

Betrifft: AW: Summe nicht ganz korrekt
von: Guesa
Geschrieben am: 03.10.2020 09:54:29

Hallo Forum
Habe es jetzt gerade selber herausgefunden. Die Multiplikationen müssen auf 2 gerundet werden.
=RUNDEN((A2*B2*C2)*D2;2)
Dann stimmt die Summe wieder mit dem Taschenrechner überein.

Gruß, Guesa

Betrifft: AW: dem ist aber nur so ...
von: neopa C
Geschrieben am: 03.10.2020 10:00:45

Hallo Guesa,

... wenn die Zwischenwerte in E2:E29 auch gerundet ausgeben werden sollen/müssen.
Rechnerisch korrekt ist nämlich das von Excel ermittelte Ergebnis, weil er mit den nicht gerundeten Werten rechnet.

Ohne die gerundeten Zwischenergebnisse in E2:E29 ergibt sich nämlich als Gesamtsumme die ausgewiesenen 9,45 auch direkt mit z.B. : =SUMMENPRODUKT(A2:A29*B2:B29*C2:C29*D2:D29)

Gruß Werner
.. , - ...