Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS - nach links? | Herbers Excel-Forum


Betrifft: SVERWEIS - nach links? von: JensP
Geschrieben am: 09.01.2009 11:14:51

Hallo,

beim SVERWEIS wird die einzugebende Spaltenanzahl immer vom aktuellen Ort nach rechts berechnet.
Gibt es irgendeine Möglichkeit, diesen Befehl auch nach links zu nutzen?
Wahrscheinlich müsste die angegebene Matrix wohl dann auch anders eingegeben werden?

Danke für Eure Antworten!

  

Betrifft: AW: SVERWEIS - nach links? von: robert
Geschrieben am: 09.01.2009 11:18:36

hi,

gib mal bei Online-Recherchen deinen betreff ein,

dort wirst du schnell fündig

gruß
robert


  

Betrifft: AW: SVERWEIS - nach links? von: Daniel
Geschrieben am: 09.01.2009 11:20:40

Hi

nein, geht nicht.
der SVerweis sucht immer in der linken Spalte der angegebenen Matrix.
man kann aber den SVerweis auch über eine Kombination aus INDEX und VERGLEICH nachbauen, dann ist es egal, wo die Spalten stehen:

= Index(Ergebnisspalte, Vergleich(Suchbegriff, Suchspalte, 0), 1)

Gruß, Daniel


  

Betrifft: geht von: WF
Geschrieben am: 09.01.2009 12:19:37

Hi Daniel,

die Kombi Index/Vergleich ist logo das Optimum - man kann den SVERWEIS aber auch vergewaltigen:

=SVERWEIS("Suchbegriff ";WAHL({1.2};B1:B10;A1:A10);2;0)

Salut WF


  

Betrifft: AW: geht von: Daniel
Geschrieben am: 09.01.2009 12:47:55

Hi

interessant, danke für den Tip

Gruß, Daniel


  

Betrifft: AW: SVERWEIS - nach links? von: Bibo
Geschrieben am: 09.01.2009 11:26:29

Hallo JensP,

mal als Anregung:

Tabelle2

 ABCDEF
1Hund1  2Katze
2Katze2    
3Maus3    

Formeln der Tabelle
ZelleFormel
F1=INDEX(A1:A3;VERGLEICH(E1;B1:B3;0))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß

Bibo


Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS - nach links?"