Standardabweichung von Werten in Zeitraum

Bild

Betrifft: Standardabweichung von Werten in Zeitraum
von: rx1600
Geschrieben am: 19.08.2015 02:06:31

Hallo Excel Freunde,
ich suche bei Euch Rat für folgendes Werte-Datums Problem:
Eine Reihe an unsortierten Werten ist im Areal B5 bis F9 eingegeben. Dazu sind im Areal H5 bis L9 Tage / Daten, die jeweils einem Wert zuzuordnen sind. Diese Daten sind im unregelmäßigen Abstand zueinander, können aber auch gleich sein. Die Tage sind den Werten gespiegelt zugeordnet, d.h. Wert B5 hat das Datum in H5 und Wert F9 das Datum L9. Ich will die Standardabweichung der Werte in mehreren Monaten errechnen. Dazu muss ich die Werte innerhalb eines Zeitraums ermitteln. Der Zeitraum ist von Monatsanfang bis Monatsende. Danach wird eine neue Standardabweichung der Werte für den nächsten Monat errechnet. Es sind viele solcher Areale und ich kann die Daten nicht einfach umstellen. Ich kann mir nicht mehr helfen und suche nun Euren Rat.
Ein Screenshot ist beigefügt.
Userbild
Vielen Dank.
Grüße, rx1600

Bild

Betrifft: AW: Standardabweichung von Werten in Zeitraum
von: rx1600
Geschrieben am: 19.08.2015 15:53:02
Irgend eine Idee wie man das evtl. formeln könnte?

Bild

Betrifft: AW: mit einer MATRIXformel ...
von: ... neopa C
Geschrieben am: 19.08.2015 17:47:25
Hallo,
... z.B. so (Formel beginnt für Monat Okt 14; nach rechts ziehend kopieren:

 BCDEFGHIJKL
5345156136165  16.10.201404.11.201405.11.201410.11.2014 
612162623265  29.10.201405.11.201407.01.201512.01.2015 
71325     07.01.2015    
81213651215215 29.10.201405.11.201407.11.201411.11.201404.12.2014
915     29.10.2014    
10           
11           
12143,772094,6 1243,3       

Formeln der Tabelle
ZelleFormel
B12{=WENNFEHLER(STABW.N(WENN((MONAT($H$5:$L$9)=REST(SPALTE(I1); 12)+1)*(JAHR($H$5:$L$9)=KÜRZEN(SPALTE(J1)/12;)+2014); $B$5:$F$9)); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit einer MATRIXformel ...
von: rx1600
Geschrieben am: 20.08.2015 10:29:08
Wunderbar! Funktioniert! Vielen Dank! Habe mich noch gefragt, wozu SPALTE(I1) und SPALTE(J1) gut sein soll, weil keine Werte drin sind. Aber es funktioniert!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Standardabweichung von Werten in Zeitraum"