Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1496to1500
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Nur auf die Nachkommast. 0,25 oder auf 0,75 runden

Nur auf die Nachkommast. 0,25 oder auf 0,75 runden
11.06.2016 21:23:26
Joerschi
Hallo liebes Forum,
bei einem vorgebenen Zahlenwert soll nur auf 0,25 oder 0,75 gerundet werden.
x,5 oder x,00 soll ignoriert werden bzw. wenn ein Wert schon auf diese Nachkommastellen lautet,
dann möglichst auf die nächste 0,25/0,75 hochrunden.
Beispiele:
A) 5,26 zu 5,25
B) 5,51 zu 5,75
C) 5,00 zu 5,25 (4,75 wäre als Ergebnis auch ok)
D) 5,50 zu 5,75 (5,25 wäre als Ergebnis auch ok)
Screenshot:
Userbild
Musterdatei:
https://www.herber.de/bbs/user/106169.xlsx
Das reine Runden auf x,25er-Stellen kenne ich (siehe Screenshot Formel oben), jedoch bei einer Eingrenzung auf nur x,25 oder x,75 komme ich nicht weiter.
Hätte jemand einen Rat, wie man das angehen könnte?
Z. B. Runden auf x,25er und das mit einer weiteren Formel verknüpfen?
Danke vorab für jeden Hinweis
Viele Grüße
Joerschi

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Nur auf die Nachkommast. 0,25 oder auf 0,75 runden
11.06.2016 21:36:29
Daniel
Hi
im Prinzp rundest du hier auf 0,5, aber 0,25 verschoben:
=RUNDEN((A1+0,25)/0,5;0)*0,5-0,25
oder unter nutzung der neuen Komfortfunktionen:
=VRUNDEN(A1+0,25;0,5)-0,25
Gruß Daniel

AW: Danke - Nachfrage, wenn Wert aus Formel berech
11.06.2016 21:49:58
Joerschi
Hi Daniel,
besten Dank - es funktioniert.
Dennoch eine Nachfrage: sobald der zu rundende Wert ein Formelwert ist (also ein Formel in der Zelle), dann scheint es nicht mehr zu klappen. Es wird nur noch auf 0,25 oder 0,75 gerundet.
Woran kann das liegen bzw. wie könnte man das ändern?
Viele Grüße
Joerschi

AW: Danke - Nachfrage, wenn Wert aus Formel berech
11.06.2016 21:54:44
Joerschi
Erledigt - Fehler gefunden.
Es lag an einer Prozentumrechnung .... (argh)
Viele Grüße
Joerschi

Anzeige
AW: Danke - Nachfrage, wenn Wert aus Formel berech
11.06.2016 21:55:04
Daniel
Hi
kann ich nicht nachvollziehen.
es sollte egal sein, ob die Zahl als Fixwert oder Formel in der Zelle steht.
Kannst du mal die Datei zeigen?
Gruß Daniel

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige