Microsoft Excel

Herbers Excel/VBA-Archiv

Wie kann ich auf 0.15 runden

Betrifft: Wie kann ich auf 0.15 runden von: Wolfgang Kienzl
Geschrieben am: 22.08.2004 21:10:21

Hallo Ihr klugen Köpfe

Ich muß meine Zeitwirtschaft umstellen bisher ist sie minutengenau


0 - 07 Min = 0 Min *
08 - 22 Min = 15 Min *
23 - 37 Min = 30 Min
38 - 52 Min = 45 Min
53 - 59 Min = 60 Min

Ich habe folgende Formel da bekomm ich die richtigen Werte (*)

=WENN(ODER(Q6=0;Q6<=0,07);GANZZAHL(O6);WENN(ODER(Q6>=0,08;Q6<=0,22);GANZZAHL(O6)+0,15;WENN(ODER(Q6>=0,23;Q6<=0,37);GANZZAHL(O6)+0,3;WENN(ODER(Q6>=0,38;Q6<=0,52);GANZZAHL(O6)+0,45;WENN(ODER(Q6>=0,53;Q6<=0,59);GANZZAHL(O6)+1;)))))

https://www.herber.de/bbs/user/9936.xls

Wer kann mir helfen
Wolfgang

  


Betrifft: AW: Wie kann ich auf 0.15 runden von: Jörg Gradert
Geschrieben am: 22.08.2004 23:26:19

Hallo Wolfgang,
wie die Werte sich mathematisch auf 0,15 runden lassen, weiss ich auch nicht, aber in deiner Formel müssen die ODER mit UND ersetzt werden, damit sie wie gewünscht funktioniert.

=WENN(UND(Q6=0;Q6<=0,07);GANZZAHL(O6);WENN(UND(Q6>=0,08;Q6<=0,22);GANZZAHL(O6)+0,15;WENN(UND(Q6>=0,23;Q6<=0,37);GANZZAHL(O6)+0,3;WENN(UND(Q6>=0,38;Q6<=0,52);GANZZAHL(O6)+0,45;WENN(UND(Q6>=0,53;Q6<=0,59);GANZZAHL(O6)+1;)))))

Gruss Jörg


  


Betrifft: Fehler entdeckt von: Jörg Gradert
Geschrieben am: 23.08.2004 00:08:18

Hallo Wolfgang,
das erste ODER ist natürlich richtig, allerdings bin ich der Ansicht, dass es möglicherweise reicht für die erste Bedingung =WENN(Q6<=0,07;... zu schreiben, da 0 ja auch <0,07 ist, sonst

=WENN(ODER(Q6=0;Q6<=0,07);GANZZAHL(O6);WENN(UND(Q6>=0,08;Q6<=0,22);GANZZAHL(O6)+0,15;WENN(UND(Q6>=0,23;Q6<=0,37);GANZZAHL(O6)+0,3;WENN(UND(Q6>=0,38;Q6<=0,52);GANZZAHL(O6)+0,45;WENN(UND(Q6>=0,53;Q6<=0,59);GANZZAHL(O6)+1;)))))

Gruss Jörg


  


Betrifft: Warum so kompliziert?? von: M@x
Geschrieben am: 23.08.2004 08:22:13

Hi Wolfgang, Jörg

=RUNDEN(A1*96;0)/96

Gruss

M@x


  


Betrifft: unübliches Zeitformat von: M@x
Geschrieben am: 23.08.2004 08:41:10

Hi,
Ich seh grad, du hast einen File angehängt mit einem unpraktischen Zeitformat.
es ist weder normales Zeitformat 0:15 noch 0,15 Dezimalzeit.
Die Folge sind unhandliche Formeln.
du willst dir Zwar den Doppelpunkt bei der eingabe ersparen, mchst dir dann aber unütze Arbeit beim Programmieren.
ein Alter Trick: gib die Zeit 0,,15 ein undt stelle bei Autokorrektur ,, wird zu :
so kannst du bei der Zeiteingabe am Ziffernblock bleiben

Gruss

M@x


  


Betrifft: AW: unübliches Zeitformat von: Jörg Gradert
Geschrieben am: 23.08.2004 18:54:19

Hallo M@x,
wir befinden uns in einem doppelten (toten) Thread, wie ich später festgestellt habe.

https://www.herber.de/forum/archiv/472to476/t473496.htm#473496

Warum so kompliziert, hast Du dir selbst beantwortet, ich kann deinen Ausführungen bezüglich des Zeitformats folgen und stimme zu.
Ich erwarte hier keine Rückmeldung von Wolfgang mehr, da Beate das Problem zur Zufriedenheit gelöst hat.

Gruss Jörg


  


Betrifft: AW: unübliches Zeitformat von: Wolfgang
Geschrieben am: 23.08.2004 22:23:48

Hi M@x Hi Jörg
Die Zeitwirtschaft habe ich ursprüngich für 25 Personen entwickelt (vor 7 Jahren Qadro Pro)
Die Eingabe sollte so einfach wie möglich sein
Dezimalzeit ist sicher ein Tippfehler 0:15 = 0,25 Dezimalzeit
Vielen Dank für die zahlreichen Antworten



 

Beiträge aus den Excel-Beispielen zum Thema "Wie kann ich auf 0.15 runden"