Microsoft Excel

Herbers Excel/VBA-Archiv

abrunden in bestehende formel einbauen

Betrifft: abrunden in bestehende formel einbauen von: Patrick
Geschrieben am: 21.10.2020 10:48:26

Hallo liebes Forum und deren Mitglieder,


ich habe ein Problemchen für welches ich Hilfe brauche.


folgende Formel existiert.

=WENN(G2<>"";SUMMEWENN($B$2:$B$31;G2;$C$2:$C$31)/3;"")


nun muss aber die ABRUNDEN-Funktion mit eingebaut werden, und zwar so das wenn der wert 1 ist nicht auf 0 gerundet wird.


also alles unter 1 soll Ergebnis 0 sein, alles über 1 soll auf die nächst niedrige ganze zahl ohne nachkommastellen abgerundet werden z.b. 2,4 = 2, 2,5 =2 3,9=2 4,1=4 usw.



Vielen dank im Vorraus


Betrifft: AW: abrunden in bestehende formel einbauen
von: Patrick
Geschrieben am: 21.10.2020 10:55:17

Sorry hatte mich vertippt. Änderungen sind fett Markiert
also alles unter 1 soll Ergebnis 0 sein, alles über 1 soll auf die nächst niedrige ganze zahl ohne nachkommastellen abgerundet werden z.b. 2,4 = 2, 2,5 =2 3,9=3 4,1=4 usw.

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 11:02:03

Hallo Patrick

Da wäre wohl die Funktion ABRUNDEN die Lösung.
=ABRUNDEN(A1;0)
A1 steht für das Ergebnis, das gerundet werden soll, die 0 für die Anzahl der Dezimalstellen

Gruß

Edmund

Betrifft: AW: abrunden in bestehende formel einbauen
von: Patrick
Geschrieben am: 21.10.2020 11:09:10

Hallo Edmund,

das ist mir bekannt, aber wie baue ich das in die vorhandene Formel ein?

Habe einiges versucht und bin kläglich gescheitert.. Ergebnis war immer ein Fehler.

Gruß Patrick

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 11:15:04

Versuche mal:
=WENN(G2<>"";ABRUNDEN(SUMMEWENN($B$2:$B$31;G2;$C$2:$C$31)/3;0);"")

Betrifft: AW: abrunden in bestehende formel einbauen
von: Patrick
Geschrieben am: 21.10.2020 13:22:05

Hallo Edmund,

danke für die Antwort.

Leider ergit es so nicht das gewünschte Ergebnis.

mit deiner Lösung wird auch von 1 auf 0 abgerundet. wenn der Wert 1 ist soll er auch 1 bleiben..

Gruß Patrick

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 13:53:53

Hm, ich habe ja deine Datei nicht zur Hand un d weiß nicht, was du da für Werte hast.
Aber wenn ich das bei mir nachstelle, dann funktioniert es. Sobald das Ergebnis 1 oder größer ist, wird auch 1 angezeigt.
Vergis nicht, dass du in deiner Formel die Summe nochmals durch 3 teilst. Ist das so gewollt?

Gruß

Edmund

Betrifft: AW: abrunden in bestehende formel einbauen
von: Patrick
Geschrieben am: 21.10.2020 14:59:07

Hallo Edmund,



ich habe die Datei hochgeladen. https://www.herber.de/bbs/user/141003.xlsb




es geht um die Formeln in der Spalte i.



wenn ich von dir vorgeschlagene verwende, bekomme ich den Wert 0 ausgegeben wenn das Ergebnis 1 ist.



bitte nicht die VBA Sachen benutzen sonst wird das Tabellenblatt gesperrt.



Gruß Patrick

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 15:31:13

Hallo Patrick

Vielleicht verstehe ich ja einfach auch die Aufgabenstellung nicht.
Wenn ich deine Datei nehme und in die Zelle I2 meine Formel einfüge, tut sie genau das, was ich erwarten würde.

Wenn Du in Zelle C2 den Wert 3 eingibst, wird der durch drei geteilt, ergibt 1 und die 1 wird bei mir auch angezeigt.
Wenn Du den Wert 2,9 eingibst, ist das Ergebnis kleiner 1, wird abgerundet und es wird 0 angezeigt.
Was habe ich falsch verstanden?

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 15:36:21

guckst du mal hier
https://www.herber.de/bbs/user/141005.xlsb

Betrifft: AW: abrunden in bestehende formel einbauen
von: Patrick
Geschrieben am: 21.10.2020 15:45:09

Hallo Edmund,

vielen Dank für deine schnelle Hilfe, es funktioniert perfekt. Aus irgend einem Grund war die Automatische Berechnung von Formeln in Excel deaktiviert.

Deine Formel macht genau was sie soll. Vielen Dank nochmal.

Als ich es selbst versucht habe, hatte ich ;0 vergessen das war dann sicher der Verursacher für den Fehler. Kleine Zahl große Wirkung.

Gruß Patrick

Betrifft: AW: abrunden in bestehende formel einbauen
von: Edmund
Geschrieben am: 21.10.2020 15:54:21

Gerne :)

Beiträge aus dem Excel-Forum zum Thema "abrunden in bestehende formel einbauen"