Anzeige
Archiv - Navigation
140to144
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
140to144
140to144
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Runden 0,05 / 0,1

Runden 0,05 / 0,1
02.08.2002 09:38:39
Skaarj
Hi,

da sich Excel mit speziellen Runden über Formeln recht schwer tut (meine ich zumindest *g*) wollte ich fragen, ob mir jemand ein kleines Makro für folgenden Fall hätte.

Ist Zahl
< 1 dann nix runden

> 1 und < 10 dann runden auf 0,05 (z.B.: bei (5,12 auf 5,10 bzw. 5,17 auf 5,15); (5,13 auf 5,15 bzw. 5,18 auf 5,20; runden))

> 10 dann runden auf 0,1 also 10,14 auf 10,1 und bei 10,16 auf 10,20

Ein Makro würde wirklich sehr helfen! :)

Vielen Dank im voraus!

Tschau


Skaarj

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Runden 0,05 / 0,1
02.08.2002 10:10:24
kviertel
Hallo Skaarj,

Versuch doch mal die Formel "=Runden(A1/20;0)/20"

MfG

Klaus

Re: Runden 0,05 / 0,1
02.08.2002 10:16:55
Skaarj
Hi,

das funktioniert leider nicht so toll :(

Ich brauche ja eine Obergrenze bzw. Untergrenze wegen den unterschiedlichen Rundungsgrenzen.

Skaarj

Re: Runden 0,05 / 0,1
02.08.2002 15:59:02
Mr. Jones
Versuch's mal damit:
Annahme: der zu rundende Wert steht in Zelle A1

=WENN(A1<1;A1;WENN(A1<10;RUNDEN(A1*20;0)/20;RUNDEN(A1;1)))

Anzeige

306 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige