Herbers Excel-Forum - das Archiv

auf und abrunden

Bild

Betrifft: auf und abrunden
von: roland
Geschrieben am: 18.09.2003 23:13:21
hi teute
ich will die anzeige einer summe ........z. b
34.51 € auf 34.50 abrunden
34.52 € auf 34.50 abrunden
34.53 € auf 34.55 aufrunden
34.54 € auf 34.55 aufrunden
34.56 € auf 34.55 abrunden
34.57 € auf 34.55 abrunden
34.58 € auf 34.60 aufrunden
34.59 € auf 34.60 aufrunden

wie kann ich das bewerkstelligen...?
nur mit formatierung z b ??

mit ner WENN abfrage z. b. ??

oder brauchts ein makro ?

vielen dank...für die muehe ...

gruss

roland

Bild

Betrifft: AW: auf und abrunden
von: Sigi
Geschrieben am: 18.09.2003 23:30:14
Hallo Roland,

mit folgender Formel ...

"=RUNDEN(A1*20;0) / 20"

Gruß
Sigi
Bild

Betrifft: AW: auf und abrunden
von: Beni
Geschrieben am: 18.09.2003 23:34:55
Hallo Roland,
Du kannst X- Matrix einbauen =RUNDEN("Matrix"*(1/0.05);0)*0.05
=RUNDEN(A1*(1/0.05);0)*0.05
=RUNDEN(A1*0.076*(1/0.05);0)*0.05
Gruss Beni
Bild

Betrifft: AW: danke beni
von: roland
Geschrieben am: 19.09.2003 00:14:05
hi beni..danke erst mal

muss das erst mal probieren

gruss roland
Bild

Betrifft: AW: auf und abrunden
von: roland
Geschrieben am: 19.09.2003 00:05:58
hi sigi

danke es funkts.....kei ahnig genau warum:-)

aber ein schönhets fehler ist dass er z.b

23,41 auf 23,4 anzeigt sollte 23,40 (zwei stellen) anzeigen ..hmm

23,44 = 23,45

23,48 = 23,50 nicht 23,5 oder soll da währungsformatierung etwa gehn?

vielen dank nochmal...roland
Bild

Betrifft: AW: auf und abrunden
von: Sigi
Geschrieben am: 19.09.2003 09:42:17
Hallo Roland,

ganz einfach das Zellenformat auf "#.##0,00" einstellen!

Gruß
Sigi
 Bild