Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
140to144
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
140to144
140to144
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

aufrunden ab 4,0 auf 10.Ab 14 auf 20 usw.

aufrunden ab 4,0 auf 10.Ab 14 auf 20 usw.
25.07.2002 21:45:02
Hans
Hallo zusammen,
wie mache ich das
aufrunden ab 4,0 auf 10
Ab 14,0 auf 20
ab 24,0 auf 30 usw.
danke euch im voraus für die späte Hilfe.
Gruß
Hans

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: aufrunden ab 4,0 auf 10.Ab 14 auf 20 usw.
25.07.2002 21:49:34
Heinz
Hallo Hans,

versuchs mal mit AUFRUNDEN(a1;-1)

Negative Zahlen nach dem Strichpunkt runden auf 10er-Potenzen.

Gruß Heinz

da rundet er schon ab1 auf.O.T
25.07.2002 22:01:24
Hans
klappt nicht
So geht's...
25.07.2002 22:30:10
Charlie
Hallo, Hans!

=WENN(RECHTS(A1;1)*1>=4;AUFRUNDEN(A1;-1);A1)

Es wird die rechte Stelle in A1 geprüft und wenn sie 4 oder größer ist, wird auf den nächsten vollen Zehner gerundet.

Viel Erfolg,
Charlie

Re: da rundet er schon ab1 auf.O.T
25.07.2002 22:31:58
Heinz
Hallo Hans,

Was hast du eingegeben?

Bei mir steht in

A1 4; die Funktion =Aufrunden(a1;-1) ergibt 10
A2 14; die Funktion =Aufrunden(a2;-1) ergibt 20
A3 24; die Funktion =Aufrunden(a3;-1) ergibt 30

Beschreib mal was nicht klappt.

Gruß Heinz

Anzeige
Re: da rundet er schon ab1 auf.O.T
25.07.2002 22:38:08
Charly
...wenn in A1 1 steht ergibt das auch 10
Charly
danke aber bei keinem hats geklappt habs Ergebniss
26.07.2002 15:54:18
Hans
Hallo,
danke euch für eure Mühe,aber das hat nicht geklappt.
Bin gerade gestresst von der Arbeit gekommen,hab mich zur Entspannung an den Rechner gesetzt und in Excel rumexperimentiert.
Hier das Ergebniss.
=OBERGRENZE(A1-3,99;10)
Tschau und danke
Hans

Re: danke aber bei keinem hats geklappt habs Ergebniss
26.07.2002 16:05:15
Charlie
Hallo, Hans!

Aber so ganz richtig liegst Du mit Deiner Lösung wohl auch nicht, denn was liefert Deine Formel bei z.B. 11, nämlich 10.

Die Fragestellung war aber dass ab 4, 14, 24... auf den nächsten Zehner aufgerundet, bei kleineren Werten aber nicht auf den nächstkleineren Zehner abgerundet werden soll.

Was an meiner Formel
=WENN(RECHTS(A1;1)*1>=4;AUFRUNDEN(A1;-1);A1)
nicht funktionieren soll, versteh ich nicht. Ergebnis bei z.B. 2 ist 2, bei 5 ist 10, bei 11 ist 11, bei 14 ist 20, ....

Naja, vielleicht habe ich das Problem auch nur mißverstanden.

Gruß,
Charlie

Anzeige
Re: danke aber bei keinem hats geklappt habs Ergebniss
26.07.2002 16:12:07
Hans
Hallo Charly,
du hast recht,es war falsch von mir formuliert an das abrunden hab ich nicht gedacht.
Trotz allem es ist toll,daß solche Personen wie du und andere hier mir und anderen Unwissenden helfen.
Ich habe hier schon enorm viel gelernt.
Danke
Hans

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige