Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen aller Leerzeilen

Betrifft: Zählen aller Leerzeilen von: Boris
Geschrieben am: 22.08.2004 21:36:04

Hallo,

ich habe eine Tabelle in der auch leerzeilen vorkommen. Ich muß die Anzahl von Leerzeilen in abhängigkeit von bedingungen zählen. Also die Zellen gehen von A1:A4206 und eine der Bedingungen ist V1. Wie kann ich das machen? Bitte helft mir

MfG

Boris

  


Betrifft: Ich versteh nur Bahnhof... von: {Boris}
Geschrieben am: 22.08.2004 21:46:52

Hi Boris,

könntest du vielleicht etwas konkreter werden?
Was denn für ne Bedingung, wenn die Zeile leer ist...?!?
Und was ist V1 - die Zelle V1 (wenn ja: was steht drin?) oder irgendein String?

Grüße Boris


  


Betrifft: AW: Ich versteh nur Bahnhof... von: Boris
Geschrieben am: 22.08.2004 22:02:21

Also ich hab eine Zelle (A) die von A1 bis A4206 mit Werten beschrieben ist. Aus dieser Zelle muß ich dir leeren Werte herausfinden.
Außerdem hab ich ne 2te Zelle die mit den Werten V1 bis V7 (B) gefüllt ist. Die Aufgabe der Formel ist es, die Werte von A zu zählen, wenn sie erstens Leer sind und zweitens mit den Werten in Übereinstimmen.



Boris


  


Betrifft: SUMMENPRODUKT von: {Boris}
Geschrieben am: 22.08.2004 22:07:28

Hi Boris,

zunächst mal: Zellen, Zeilen und Spalten.
A1:A4206 sind 4206 Zellen in Spalte A.

Soviel zu den Termini technici.

=SUMMENPRODUKT((B2:B4206="V1")*(A2:A4206=""))

Grüße Boris


  


Betrifft: AW: SUMMENPRODUKT von: Boris
Geschrieben am: 22.08.2004 22:28:18

OK danke funktioniert. Ich hab noch ne Frage. Wie kann ich aus dem A Bereich Werte auszählen, ohne sie doppelt zu zählen?

Boris


  


Betrifft: Anzahl unterschiedlicher Einträge ermitteln von: {Boris}
Geschrieben am: 22.08.2004 22:37:39

Hi Boris,

ich versteh deine Frage jetzt so - in Spalte A sind 3 unterschiedliche Einträge vorhanden (a,b und c):

 
 AB
1a3
2b 
3a 
4b 
5a 
6c 
Formeln der Tabelle
B1 : {=SUMME(WENN(A2:A4206<>"";1/ZÄHLENWENN(A2:A4206;A2:A4206)))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Grüße Boris


  


Betrifft: AW: Anzahl unterschiedlicher Einträge ermitteln von: Boris
Geschrieben am: 22.08.2004 23:12:17

kann ich dass auch mit der Abfrage von z.B. V1 kombinieren?

Boris


  


Betrifft: AW: Anzahl unterschiedlicher Einträge ermitteln von: Frank
Geschrieben am: 23.08.2004 11:49:37

Hi Boris
heisst das, Du möchtest Die unterschiedlichen Werte aus Spalte A haben, wenn Spalte B = 'V1' ist?. Wenn ja nutze folgende Matrix Formel:
=ANZAHL(1/HÄUFIGKEIT(WENN((B1:B100="V1")*(A1:A100<>"");VERGLEICH(A1:A100;A1:A100;0));ZEILE(INDIREKT("1:"&ANZAHL2(A1:A100)))))


Gruß
Frank


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen aller Leerzeilen"