Microsoft Excel

Herbers Excel/VBA-Archiv

Leerzeilen weglassen | Herbers Excel-Forum


Betrifft: Leerzeilen weglassen von: Tim Arne
Geschrieben am: 05.02.2010 08:09:33

Moinsen!

Wie kann ich aus einem Datenbereich DT4 bis DT2985 nur die Zeilen per Formel in einen anderen Bereich bringen, so dass die Leerzeilen "übersprungen" werden?

Die Daten sollen in EB4 bis EH4 und dann soll die Formel runtergezogen werden. Wichtig ist, dass die Angaben zur Zeile auch zusammenhängend bleiben, da u.U. eine einzelne Zelle eines Datensatzes auch leer sein kann, aber nur komplette leere Zeilen sollen "übersprungen" werden.

Freue mich über eure Tipps. Vielen Dank im Voraus!

Tim Arne

  

Betrifft: AW: Leerzeilen weglassen von: Tim Arne
Geschrieben am: 05.02.2010 08:17:55

Hier mein gescheiterter Versuch:

=WENN(ZEILE(DT4)>ANZAHL2(DT:DT);"";INDEX(DT:DT;KKLEINSTE(WENN(NICHT(ISTLEER(DT$4:DT$2985));ZEILE($4:$2985));ZEILEN($4:4))))

ließt zwar den ersten Datensatz aus, aber lässt sich nicht kopieren.


  

Betrifft: AW: Leerzeilen weglassen von: Daniel
Geschrieben am: 05.02.2010 09:02:31

Hi

da würde ich erstmal in den Quelldaten eine Hilfsspalte einfügen, die für alle gefüllten Zeilen die Zeilen-Nr als Ergebnis hat und für alle Leerzeilen ein "x".

=wenn(anzahl2(...)=?;Zeile();"x")



dann kannst du im Quellbereich die Daten einfach über INDEX und KKLEINSTE auf diese Hilfsspalte einlesen



Gruß, Daniel


  

Betrifft: nur komplett leere Zeilen eliminieren von: WF
Geschrieben am: 05.02.2010 09:05:14

Hi Arne,

die Zeilen sind A1 bis D???

ist einfach mit Hilfsspalte ab K1:
=WENN(ANZAHL2(A1:D1)>0;ZEILE();"")
runterkopieren

in F1 steht:
=WENN(ZEILE()>ANZAHL($K:$K);"";INDEX(A:A;KKLEINSTE($K:$K;ZEILE(A1))))
bis i1 und runter kopieren

Nullwerte deaktivieren

Ne Lösung ohne Hilfsspalte überleg ich noch.

Salut WF


  

Betrifft: AW: nur komplett leere Zeilen eliminieren von: Tim Arne
Geschrieben am: 05.02.2010 14:11:49

klingt gut. das jilft mir weiter


Beiträge aus den Excel-Beispielen zum Thema "Leerzeilen weglassen"