Microsoft Excel

Herbers Excel/VBA-Archiv

Leerzeilen bei Teilergebnis füllen

Betrifft: Leerzeilen bei Teilergebnis füllen von: Peter
Geschrieben am: 03.07.2015 20:28:38

Hallo zusammen, ich möchte die Leerzeilen, die beim Teilergebnis entstehen, jeweils mit dem Wert aus der Zelle darüber füllen. Da aber 2 Teilergebnisse übereinander gelegt sind, sollen nicht alle Leerzeilen gefüllt werden. Im Beispiel sollen in der Spalte C die Zeilen 18, 26, 31, 37, 42 ... gefüllt werden, aber nicht Zeile 32, 43.... Gleiches gilt für Spalte D
Das Makro, das ich "gebastelt" habe, füllt aber leider alle Zeilen. Kann mir dabei bitte jemand helfen.
Danke im Voraus.
Gruß Peter

https://www.herber.de/bbs/user/98627.xlsm

  

Betrifft: ohne VBA mit einer ExcelStandardfunktionalität ... von: der neopa C
Geschrieben am: 03.07.2015 20:48:19

Hallo Peter,

... dazu markiere einfach Spalte C, betätige [F5], aktiviere "Inhalte" und dann "Leerzellen" dann schreibe in die Bearbeitungszeile diese einfache Formel: =WENN(B1="";"";INDEX(C:C;ZEILE()-1)) und betätige anschließend die Tastenkombination [Strg]+[Enter]

Gruß Werner
.. , - ...


  

Betrifft: Standardfunktion von: Peter
Geschrieben am: 03.07.2015 20:56:59

Hallo Werner, wow. Wo bekommt man solches Excel-Wissen ??
Vielen Dank, das bringt mir viel Zeitersparnis.
Grüße Peter


  

Betrifft: Das würde mich auch mal interessieren! von: Herbert Grom
Geschrieben am: 04.07.2015 17:58:43

Hallo Werner,

Du Teufelsbraten! Dann spuck's mal aus und lass uns an Deinem Wissen der Extraklasse teilhaben!

Servus


  

Betrifft: noch bin ich nicht ganz gegrillt ;-) ... von: der neopa C
Geschrieben am: 04.07.2015 20:10:35

Hallo Herbert,

... allerdings stehe ich kurz davor, denn für mich ist alles über 25° schon ungemütlich und alles über 30° eine Zumutung. Heute sind es nun noch immer fast 36° und für Morgen sollen nochmal 3° mehr werden, somit eindeutig schon die Vorhölle.

Also die Standardfunktionalität kenne ich schon aus guten alten Spotlight-Zeiten. Von wem ich das da aufgeschnappt habe, weiß ich natürlich heute nicht mehr. Na und die spez. Verwendung von INDEX() ist ja größtenteils auch auf meinen Mist gewachsen und das auch schon seit einigen Jahren Und bei der Hitze tut Mist was? Ja genau ...

Gruß Werner
.. , - ...

oT: Grüß mir Angelika und macht Euch noch einen kühlen Abend, wie wir uns jetzt auch.


  

Betrifft: AW: noch bin ich nicht ganz gegrillt ;-) ... von: Herbert Grom
Geschrieben am: 04.07.2015 20:58:43

Also gut, dann schreibe ich Dir nicht, dass ich hier in meinem klimatisierten Wohnzimmer sitze, mit gerade einmal 22,5 Grad. ;o)=)

Aber ich fühle mit Dir, denn ich weiß was es bedeutet, wenn es einem unerträglich heiß ist. Das ist ja auch mit ein Grund, warum ich immer so dafür Kämpfe, dass unsere Exceltreffen immer in den kühleren Jahreszeiten stattfinden.

Behalte nur einen kühlen Kopf und viele Grüße, von uns beiden an Euch beide!

Servus


 

Beiträge aus den Excel-Beispielen zum Thema "Leerzeilen bei Teilergebnis füllen"