Herbers Excel-Forum - das Archiv

Formel zu lang oder was?

Bild

Betrifft: Formel zu lang oder was?
von: Micha

Geschrieben am: 17.02.2005 13:02:59
hallo,
habe folgendes Problem mit folgender Formel:
=WENN(UND(J12="";K12="");G12;WENN(UND(J12="";K12<>"");G12/12*Monat(K12);WENN(UND(K12="";J12<>"";(TAG(J12)<15);G12/12*(12-(Monat(J12)-1));WENN(UND(K12="";J12<>"";TAG(J12)>=15);Gesamt/24+(Gesamt/12*(12-Monat(J12)));WENN(UND(J12<>"";K12<>"";Jahr(J12)-Administration!$B$2=0;Tag(Personaldaten!J12<15);Personaldaten!G12/12*(Monat(Personaldaten!K12)+1-Monat(Personaldaten!J12));WENN(UND(J12<>"";K12<>"";Jahr(J12)-Administration!$B$2=0;Tag(Personaldaten!J12>=15);Personaldaten!G12/24+(Personaldaten!G12/12*(Monat(Personaldaten!K12)+1-Monat(Personaldaten!J12))))))))))))
Nach Fertigstellung der Schreibarbeiten drückt man ja dann enter und es funktioniert! Aber nicht bei mir! Da kommt ne Fehlermeldung:
"Die eingegebene Formel enthält einen Fehler
..."
Ist die Formel zu lang oder was ist hier los?
Bitte helfen! Schnell! ;=((
Ich sehr verzweifelt!
Danke! Micha
Bild

Betrifft: AW: Formel zu lang oder was?
von: Tim
Geschrieben am: 17.02.2005 13:05:08
Du kannst das ja mit der Funktion LÄNGE() testen. Formeln dürfen max. 1024 Zeichen haben.
Tim
Bild

Betrifft: AW: Formel zu lang oder was?
von: Luc
Geschrieben am: 17.02.2005 13:13:29
Hallo Micha,
vor dem 4.WENN scheint eine 3.Klammer zu fehlen (analog vor 5.WENN, weiter hab ich nicht geprüft!).
Gruß Luc
Bild

Betrifft: AW: Formel zu lang oder was?
von: Micha
Geschrieben am: 17.02.2005 13:55:46
yo danke. hat gestimmt. funzt aber trotzdem noch nicht. leider!
Bild

Betrifft: AW: Formel zu lang oder was?
von: Luc

Geschrieben am: 18.02.2005 09:13:25
Hallo Micha,
vor dem letzten WENN fehlt auch eine Klammer. Außerdem sind dann hinten zu viel (wohl aus Autokorrektur, kann xl aber korrigieren). Zum letzten WENN ist außerdem keine Alternative bei Nichterfüllung der Bedingung angegeben - müsste in diesem Fall das Ergebnis FALSCH bringen, wenn die Formel ansonsten funktioniert.
Gruß Luc
 Bild
Excel-Beispiele zum Thema "Formel zu lang oder was?"
Anzeigen von Werten und Formeln Zeile einfügen und Formeln und Werte übernehmen
Formeln mit Zelladressen speichern Zeilenumbruch in Formel erzwingen
Aktueller Arbeitsblattname in Formel Variable in Formel einbauen
Ein Zeichen in einer Formel suchen Variable in Excel-Formel einbauen.
Summenformel unter Zahlenreihe eintragen Arbeitszeittabelle und SVERWEIS-Formel