Formel wurde zulang!! ;-(

Bild

Betrifft: Formel wurde zulang!! ;-(
von: Karsten
Geschrieben am: 29.03.2005 16:05:48
Hallo Forum,
ich habe bisher jede zweite Zelle mit folgender Formel gezählt wenn dort etwas eingetragen war:
=SUMME(ANZAHL2(O8;O10;..;..;O64;O66);ANZAHL2(O68;O70;..;..;O124;O126);ANZAHL2(..) usw.
Nun mußte ich aber die genutzte Zeilen von bisher 8 bis 221 auf 8 bis 363 erhöhen. Die obige Formel funktioniert solange, solange die Spalten nur einen Buchstaben enthalten. Sobald der zweite dazu kommt, wird die Formel zulang.
Weis jemand einen Tip oder einen Lösungsansatz??
Ziel ist es jede zweite Zelle in einer Spalte zu überwachen und bei einem Inhalt (Text o. Zahl) hoch zuzählen.
Schon mal Danke im vorraus.
Gruß Karsten

Bild

Betrifft: AW: Formel wurde zulang!! ;-(
von: c0bRa
Geschrieben am: 29.03.2005 16:19:20
hallo...
wie wärs mit:
=SUMMENPRODUKT(($A$1:$A$1000)*(REST(ZEILE($A$1:$A$1000);2)=0))
?
wennst die anderen zeilen zählen willst, dann nimm =1 statt =0

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: sry... klammerfresser ^^
von: c0bRa
Geschrieben am: 29.03.2005 16:21:48
=SUMMENPRODUKT(($A$1:$A$1000<>"")*(REST(ZEILE($A$1:$A$1000);2)=0))
ist richtig
Bild

Betrifft: AW: Formel wurde zulang!! ;-(
von: u_
Geschrieben am: 29.03.2005 16:22:24
Hallo,
nur die Anzahl der Einträge?
=SUMMENPRODUKT((O8:O363<>"")*(REST(ZEILE(O8:O363);2)=0))
Gruß
Bild

Betrifft: AW: Formel wurde zulang!! ;-(
von: Karsten
Geschrieben am: 30.03.2005 08:34:12
@ sry & u_
Danke für die Lösung, klappt wunderbar.
Gruß Karsten
Bild

Betrifft: AW: Formel wurde zulang!! ;-(
von: Karsten
Geschrieben am: 04.04.2005 09:45:08
Hallo c0bRa & u_,
leider funktioniert die Formel.
=SUMMENPRODUKT((G8:G362<>"")*(REST(ZEILE(G8:G362);2)=0))
doch nicht richtig. Liegt aber an meinem Anfangs-Thread. Sorry, Asche auf mein Haupt.
Das Problem ist, das ich einmal alles aus den geraden Zellen und einmal aus den ungeraden Zellen auswerten muß.
Das ganze ist ein ziemlich große Matrix, wo zwei Zeilen einen Auftrag darstellen und das ganze dann Informationen in zwei Spalten hat.
Beispiel:
----------------------
Spalte-------------| F | G |
----------------------
-------------------| KW 01 |
----------------------
Z8: Kunde/FA | Blau | 458 |
----------------------
Z9: Status/fertig | geplant | 04.04.05 |
----------------------
Die Auswertung hat die Aufgabe, alle gesetzen Aufträge (Zeile 8, Spalte G) auszuwerten und wenn abgearbeitete Ihr Datum haben gegen zurechnen (Zeile 9, Spalte G).
Somit ist die von Euch genannte Formel nicht nutzbar.
Gib es vielleicht eine andere Lösung.
Gruß Karsten
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel wurde zulang!! ;-("