Microsoft Excel

Herbers Excel/VBA-Archiv

Formel zu Lang | Herbers Excel-Forum


Betrifft: Formel zu Lang von: Heinz H
Geschrieben am: 31.12.2009 20:52:35

So Leute heute zum letzten mal

Die Formel ist zu lang, daher kann es der Recorder nicht aufzeichnen.
Welche Lösung gibt es bitte dafür ?

Heinz

01.12.2001

 J
7 

Formeln der Tabelle
ZelleFormel
J7=WENN(A7="";0;WENN(ISTFEHLER(VERGLEICH(A7;$W$64:$W$81;0)); WENN(UND(C7="";D7=0;E7="";F7=0;L7=0); 0;WENN(L7="Pflegefreistellung";0;WENN(L7="Krank";0;WENN(L7="Urlaub";0;WENN(H7<G7;H7-G7;WENN(H7>G7;H7-G7)))))); ""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

  

Betrifft: Die Formel im Direktfenster umwandeln ... von: Backowe
Geschrieben am: 31.12.2009 21:20:15

Hallo Heinz,

... und von Hand nachbearbeiten. Hier die Vorgehensweise, wenn Du den VBA-Editor geöffnet hast, dann drücke STRG + G.

Sub Formel()
Range("J7").Formula = "=IF(A7="""",0,IF(ISERROR(MATCH(A7,$W$64:$W$81,0)),IF(AND(C7="""",D7=0,E7="""",F7=0,L7=0),0,IF(L7=""Pflegefreistellung"",0,IF(L7=""Krank"",0,IF(L7=""Urlaub"",0,IF(H7G7,H7-G7)))))),""""))"
End Sub

'Schreibe ins Direktfenster: ?activecell.formula und drücke Enter.

'?ActiveCell.Formula
'=IF(A7="",0,IF(ISERROR(MATCH(A7,$W$64:$W$81,0)),IF(AND(C7="",D7=0,E7="",F7=0,L7=0),0,IF(L7="Pflegefreistellung",0,IF(L7="Krank",0,IF(L7="Urlaub",0,IF(H7G7,H7-G7)))))),""))
'Danach die Formel etwas nachbearbeiten. Das war es schon.

Code eingefügt mit Syntaxhighlighter 4.15


Gruß Jürgen


  

Betrifft: AW: Die Formel im Direktfenster umwandeln ... von: Heinz H
Geschrieben am: 31.12.2009 21:28:18

Hallo Jürgen

Die Formel würde in J6:J35 eingefügt gehören.

Das bekomme ich leider nicht hin.
Habe die Mappe mal hochgeladen.

Gruß
Heinz

https://www.herber.de/bbs/user/66913.xls


  

Betrifft: Du kannst im Direktfenster auch ... von: Backowe
Geschrieben am: 31.12.2009 22:16:45

Hallo Heinz,

... ?activecell.formular1c1 benutzen.

Range("J6:J35").FormulaR1C1 = "=IF(RC[-9]="""",0,IF(ISERROR(MATCH(RC[-9],R64C23:R81C23,0)),IF(AND(RC[-7]="""",RC[-6]=0,RC[-5]="""",RC[-4]=0,RC[2]=0),0,IF(RC[2]=""Pflegefreistellung"",0,IF(RC[2]=""Krank"",0,IF(RC[2]=""Urlaub"",0,IF(RC[-2]RC[-3],RC[-2]-RC[-3])))))),""""))"
Gruß Jürgen


  

Betrifft: AW: Du kannst im Direktfenster auch ... von: Heinz H
Geschrieben am: 01.01.2010 08:34:37

Hallo Jürgen

Recht herzlichen DANK

Gruß
Heinz


  

Betrifft: AW: Du kannst im Direktfenster auch ... von: Heinz H
Geschrieben am: 01.01.2010 09:02:10

Guten morgen

Bekomme leider immer Laufzeitfehler !

Heinz


  

Betrifft: AW: Danke-Hab es geschaft OwT. von: Heinz H
Geschrieben am: 01.01.2010 10:18:02




Beiträge aus den Excel-Beispielen zum Thema "Formel zu Lang"