Fünf Zahlen nach Duplikaten durchsuchen?!?

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: Fünf Zahlen nach Duplikaten durchsuchen?!?
von: Oliver S.
Geschrieben am: 10.04.2005 14:01:38
Hallo an alle,
die wie ich am Sonntag vor der Kiste sitzen. Mir fällt mal wieder kein richtiger Ansatz für nachfolgende Aufgabe ein. Ich habe in 5 Sppalten (A, B, C, D und E) in Zeile 10 Zahlen zu stehen. Nun möchte ich herausfinden, ob zwei, drei, vier oder alle fünf Zahlen gleich sind, oder ob z.B. nur zwei die gleiche Zahl haben und die anderen drei Zahlen ebenfalls gleich sind. Fällt dazu jemanden etwas gescheites ein? Mir leider nicht.
Danke Euch jetzt schon mal für die Tips,
Oliver

Bild

Betrifft: AW: Fünf Zahlen nach Duplikaten durchsuchen?!?
von: ransi
Geschrieben am: 10.04.2005 14:41:54
hallo
als ansatz mal so:
 
 ABCDE
1067721
11verschiedene4   
Formeln der Tabelle
A10 : =ZUFALLSBEREICH(1;10)
B10 : =ZUFALLSBEREICH(1;10)
C10 : =ZUFALLSBEREICH(1;10)
D10 : =ZUFALLSBEREICH(1;10)
E10 : =ZUFALLSBEREICH(1;10)
B11 : {=SUMME(1/ZÄHLENWENN(A10:E10;A10:E10))}
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Bild

Betrifft: AW: Fünf Zahlen nach Duplikaten durchsuchen?!?
von: Peter Feustel
Geschrieben am: 10.04.2005 14:49:12
Hallo Oliver,
als Ansatz in VBA:


Sub Doppelte()
Dim iSpalte  As Integer
Dim iNFolge  As Integer
   
   For iSpalte = 1 To 5
      If iSpalte = 5 Then Exit For
      For iNFolge = iSpalte + 1 To 5
         If Cells(10, iSpalte).Value = Cells(10, iNFolge).Value Then
            MsgBox "Spalte " & Chr(iSpalte + 64) & " ist gleich " & Chr(iNFolge + 64)
         End If
      Next iNFolge
   Next iSpalte
End Sub

     Code eingefügt mit Syntaxhighlighter 2.5

Viele Grüße Peter
Bild

Betrifft: Der Ansatz ist schon mal nicht schlecht!
von: Oliver S.
Geschrieben am: 10.04.2005 14:55:47
Hallo Ihr beiden!
@ransi: Danke Dir für Deine Antwort. Zunächst einmal Asche auf mein Haupt, ich hatte vergessen zu schreiben, dass ich eine VBA Lösung suche. Außerdem benötige ich keine Zahl, die aussagt, wieviele verschiedene Zahlen vorhanden sind, sondern als Beispiel wenn in den Zellen 6, 7, 7, 2, 1 steht, dann möchte ich als Ergebnis bekommen das die 7 zweimal, die 6, die 2 und die 1 je einmal vorkommen.
@peter: So ähnlich habe ich mir das schon vorgestellt. Ich schau mal, was ich aus Deinem Ansatz so machen kann, damit ich wie oben beschrieben erhalte, wie oft welche Zahl vorhanden ist. Also nach obigen Beispiel: Die 7 kommt 2x vor, die Zahlen 1,2 und 6 je 1x.
Gruß,
Oliver
Bild

Betrifft: AW: Der Ansatz ist schon mal nicht schlecht!
von: ransi
Geschrieben am: 10.04.2005 16:11:27
hallo oliver
probier mal so:
Public

Sub test()
Dim alle(1 To 5) As Variant
Dim I As Integer
For I = 1 To 5
    alle(I) = WorksheetFunction.CountIf(Range("a10:e10"), Cells(10, I).Value)
Next
MsgBox alle(1) & " mal " & [a10] & Chr(13) _
& alle(2) & " mal " & [b10] & Chr(13) _
& alle(3) & " mal " & [c10] & Chr(13) _
& alle(4) & " mal " & [d10] & Chr(13) _
& alle(5) & " mal " & [e10]
End Sub

ransi
Bild

Betrifft: Ganz dicht dran an der Lösung!
von: Oliver S.
Geschrieben am: 10.04.2005 16:22:28
Hallo ransi,
danke Dir für Deinen erneuten Lösungsansatz. Das ist schon 95% von dem, so wie ich es erreichen möchte. Einen kleinen Schönheitsfehler hat der VBA Code noch. Wenn z.B. als Beispiel die Zahlen 1, 2, 1, 3 und 4 in den Zellen stehen, erhalte ich als Text in der MsgBox folgenden Text:
2 mal 1
1 mal 2
2 mal 1
1 mal 3
1 mal 4
Nun wäre es schön, wenn wie in diesem Beispiel das Zweite
2 mal 1
nicht erscheint, da das ja eigentlich doppelt gemoppelt ist. Weißt Du eventuell noch, wie man das ausschließen kann? Ich hoffe, dass Dir da noch etwas einfällt.

Gruß,
Oliver
Bild

Betrifft: Besser kann ichs nicht
von: ransi
Geschrieben am: 10.04.2005 16:35:49


      
hallo oliver
besser kriege ichs nicht:
Public Sub test()
Dim alle(1 To 5) As Variant
Dim I As Integer
For I = 1 To 5
If WorksheetFunction.CountIf(Range(Cells(10, 1), Cells(10, I)), Cells(10, I)) > 1 Then GoTo weiter
    alle(I) = WorksheetFunction.CountIf(Range(
"a10:e10"), Cells(10, I).Value) & " mal " & Cells(10, I)
weiter:
Next
MsgBox alle(1) & Chr(13) _
& alle(2) & Chr(13) _
& alle(3) & Chr(13) _
& alle(4) & Chr(13) _
& alle(5)
End Sub
ransi 


Bild

Betrifft: geht doch :
von: ransi
Geschrieben am: 10.04.2005 16:44:45


      
hallo oliver
geht doch besser.
eben nicht konsequent zu ende gedacht:
Public Sub test()
Dim alle(1 To 5) As Variant
Dim I As Integer
For I = 1 To 5
If WorksheetFunction.CountIf(Range(Cells(10, 1), Cells(10, I)), Cells(10, I)) > 1 Then GoTo weiter
    alle(I) = WorksheetFunction.CountIf(Range(
"a10:e10"), Cells(10, I).Value) & " mal " & Cells(10, I) & Chr(13)
weiter:
Next
MsgBox alle(1) _
& alle(2) _
& alle(3) _
& alle(4) _
& alle(5)
End Sub
ransi 


Bild

Betrifft: AW: geht doch :
von: Oliver S.
Geschrieben am: 10.04.2005 16:52:05
Hi ransi,
ich danke Dir, genau so hatte ich mir das vorgestellt. Suber genial, danke noch mal.
Gruß,
Oliver
Bild

Betrifft: AW: geht doch :
von: ransi
Geschrieben am: 10.04.2005 16:52:47


      
hallo
jetzt ist aber nix mehr drin:
Public Sub test()
Dim alle(1 To 5) As Variant
Dim I As Integer
For I = 1 To 5
If WorksheetFunction.CountIf(Range(Cells(10, 1), Cells(10, I)), Cells(10, I)) = 1 Then _
    alle(I) = WorksheetFunction.CountIf(Range(
"a10:e10"), Cells(10, I).Value) & " mal " & Cells(10, I) & Chr(13)
Next
MsgBox alle(1) & alle(2) & alle(3) & alle(4) & alle(5)
End Sub
ransi 


Bild

Betrifft: AW: Fünf Zahlen nach Duplikaten durchsuchen?!?
von: th.heinrich
Geschrieben am: 10.04.2005 14:58:36
hi Oliver,
noch ein ansatz.
Tabelle1
 ABCDE
112341
221112
Formeln der Tabelle
A2 : =ZÄHLENWENN($A$1:$E$1;A1)
B2 : =ZÄHLENWENN($A$1:$E$1;B1)
C2 : =ZÄHLENWENN($A$1:$E$1;C1)
D2 : =ZÄHLENWENN($A$1:$E$1;D1)
E2 : =ZÄHLENWENN($A$1:$E$1;E1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

wie Du die ausgabe haben moechtest oder ob z.B. nur zwei die gleiche Zahl haben und die anderen drei Zahlen ebenfalls gleich sind solltest Du bitte genauer erklaeren.
gruss thomas
Bild

Betrifft: nachdem ich schon mal angefangen habe ohne VBA
von: th.heinrich
Geschrieben am: 10.04.2005 15:24:08
sers Oliver,
Tabelle1
 ABCDE
111341
21 ist 3 mal enthalten1 ist 3 mal enthalten3 ist 1 mal enthalten4 ist 1 mal enthalten1 ist 3 mal enthalten
Formeln der Tabelle
A2 : =A1&" ist "&ZÄHLENWENN($A$1:$E$1;A1)&" "&"mal enthalten"
B2 : =B1&" ist "&ZÄHLENWENN($A$1:$E$1;B1)&" "&"mal enthalten"
C2 : =C1&" ist "&ZÄHLENWENN($A$1:$E$1;C1)&" "&"mal enthalten"
D2 : =D1&" ist "&ZÄHLENWENN($A$1:$E$1;D1)&" "&"mal enthalten"
E2 : =E1&" ist "&ZÄHLENWENN($A$1:$E$1;E1)&" "&"mal enthalten"
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: AW: nachdem ich schon mal angefangen habe ohne VBA
von: Oliver S.
Geschrieben am: 10.04.2005 15:44:22
Hallo Thomas,
das ist schon mal ganz dicht an dem, was ich erreichen möchte. Nun muss ich nur noch sehen, wie ich dass in VBA übertrage, bzw. umsetze. Danke Dir jedenfalls für Deine Beispiele.
Gruß,
Oliver
Bild

Betrifft: AW: nachdem ich schon mal angefangen habe ohne VBA
von: Peter Feustel
Geschrieben am: 10.04.2005 22:07:19
Hallo Oliver,
vielleicht so - siehe Beispiel-Mappe.
Die ist sicherlich nicht optimal, erfüllt aber die Anforderung.
https://www.herber.de/bbs/user/20955.xls
Viele Grüße Peter
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Fünf Zahlen nach Duplikaten durchsuchen?!?"