Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn / Wert ist minimum + Anzahl


Betrifft: Zählen wenn / Wert ist minimum + Anzahl
von: Patrik
Geschrieben am: 28.11.2018 11:21:43

Hallo, ich bräuchte mal eure Hilfe.

Ich habe eine Liste an Werten aus einem Tippspiel

Die Spieler sind in C2, C3, C4

Jeweils darunter (Also C3-C37...) befinden sie die Ergebnisse der einzelnen Spieltage

Bsp:

Paul Anton Dieter
15 12 8
4 11 12
8 8 2
...

Nun will ich an einer anderen stelle zählen wer wie oft einen Spieltag Verloren hat und wie oft jemand ein Spieltag gewonnen.
In dem Beispiel wäre das Ergebniss:
Gewonnen: Paul 2x(Da gleiches ergebniss am 3 Spieltag) Anton 1x(Da gleiches ergebniss am 3 Spieltag)

Wie realisiere ich das nun am besten?

  

Betrifft: AW: Zählen wenn / Wert ist minimum + Anzahl
von: Hajo_Zi
Geschrieben am: 28.11.2018 16:16:33

nur wenige schauen auf Deinen Rechner und sehen die Datei.
Ich möchte gerne den Fehler im Original sehen.

Ich baue keine Datei nach. Die Zeit hat schon jemand investiert.

Ein Nachbau sieht meist anders aus als das Original. Darum sollte das Original verlinkt werden.

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten anonymisieren bzw. pseudonymisieren.

Benutze hier im Forum die Funktion zum hochladen. Falls Du die nicht benutzen möchtest beachte, von unsicheren Servern wie z.B. www.file-upload.net lade ich keine Datei runter. (lt. Einschätzung meines Virenprogramms)

GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.
Die Beiträge werden auch ignoriert, es erfolgt keine Antwort.


  

Betrifft: AW: für "gewonnen" bedarf es das Maximum ...
von: neopa C
Geschrieben am: 28.11.2018 16:53:32

Hallo Patrik,

... und die Ermittlung am einfachsten mit Hilfsspalten:

Formel E1 nach links ziehend kopieren und die Hilfsspalten-Formeln nach unten.
Die Anzahl der verlorenen Spiele kannst Du analog mit einem Vergleich der Hilfsspaltenwerte in Spalte H ermitteln (vorausgesetzt für Dich ist der Zweite nicht auch ein Verlierer; in dem Fall brauchst Du nur die Anzahl der Spieltage minus der ermittelten Anzahl an Gewinnen berechnen)

 BCDEFGH
1gewonnen:312   
2SpieltagPaulAntonDieter MaxMin
3115128 158
4241112 124
53882 82
6481011 118
75986 96
8       

Formeln der Tabelle
ZelleFormel
E1=SUMMENPRODUKT(N(E3:E37=$G3:$G37)*($G3:$G37>0))
G3=MAX(C3:E3)
H3=MIN(C3:E3)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...