Microsoft Excel

Herbers Excel/VBA-Archiv

Zeit ermitteln bei Drehfeld-Betätigung


Betrifft: Zeit ermitteln bei Drehfeld-Betätigung von: Siegfried
Geschrieben am: 16.08.2018 19:33:01

Hallo zusammen,

bisher habe ich die vergangene Zeit zwischen dem Start eines Codes und dem Ende mit einer Timer-Anweisung ermittelt (Ende - Start).
Diese Leistung möchte ich auch bei einem Tabellensteuerelement (Drehfeld) haben.

Bei der Betätigung des Drehfeldes wird eine Iterations-Berechnung ausgeführt, die seine Zeit braucht.

Für den Start habe ich:

Sub Drehfeld10_BeiÄnderung()
   Range("B20").FormulaR1C1 = "=NOW()"
End Sub
Wie kann ich das Ende messen und in Range("B21") anzeigen?

Gruß
Siegfried

  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Hajo_Zi
Geschrieben am: 16.08.2018 19:34:57

Hallo Siegfried,

es sollte fest sein?
Range("B20")=now

GrußformelHomepage

Beiträge von Werner, Luc, robert, J.O.Maximo und folgende lese ich nicht.


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Siegfried
Geschrieben am: 16.08.2018 19:50:24

Hallo Hajo,

Deine Antwort hilft mir leider nicht weiter.

In B20 habe ich schon die Startzeit.
Die Zeit nach Abschluss der Berechnung möchte ich in B21 haben.

Gruß
Siegfried


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Hajo_Zi
Geschrieben am: 16.08.2018 19:53:46

Hallo Siegfried,

Ich habe mich an Dein Code gehalten.
Es ist also ein Problem B20 in B21 zu ändern?
Ist Excel das richtige Programm?


Gruß Hajo


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Siegfried
Geschrieben am: 16.08.2018 20:07:10

Hallo Hajo

mein vielleicht naiver Gedanke ist,
wenn ich bei Ausführung eines VBA-Codes die vergangene Zeit ermitteln kann (mit Excel),
dann sollte dies auch bei Betätigung eines Tabellensteuerelementes möglich sein.

Meim Problem ist:
Wie kann ich die aktuelle Zeit bei Abschluss der Berechnung in eine Zelle schreiben?

Gruß
Siegfried


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Hajo_Zi
Geschrieben am: 17.08.2018 08:49:38

Gut mein Vorschlag hat Dir nicht gefallen. Ich glaube nicht das jemand einen anderen Vorschlag hat. Aber warten wir mal ab.
Ich bin dann raus.

Gruß Hajo


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: {Boris}
Geschrieben am: 17.08.2018 09:06:05

Hi,

zum Testen:

Iteration an - max. Iteration 30000

A1: =WENN(D1=0;0;WENN(A1=30000;30000;A1+1))

E1: =JETZT()-HEUTE()

F1: =WENN(A1=30000;JETZT()-HEUTE();0)

E1 und F1 formatiert als hh:mm:ss

Gib in D1 dann eine 1 ein und sieh was passiert. Das Ganze kannst Du wiederholen, wenn Du D1 wieder löscht und dann wieder ne 1 eingibst.

Wichtig: Die Iterationszelle (im Beispiel A1) muss aufgrund der Berechnungsreiehenfolge VOR der Zelle F1 sein.

Reicht Dir das so bereits?`

VG, Boris


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Siegfried
Geschrieben am: 17.08.2018 13:24:08

Hi Boris,

Danke,
mit Deiner Hilfe kann ich jetzt die vergangene Zeit messen.

Du fragst, ob mir das so reicht.
Diese Frage bringt mich auf den Gedanken, dass Du noch eine andere Möglichkeit siehst.
Richtig?

Gruß
Siegfried


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: {Boris}
Geschrieben am: 17.08.2018 14:46:32

Hi Siegfried,

ich meinte das eher bezogen auf die Anpassung an Deine konkrete Mappe mit den Drehfeldern.
Bekommst Du das hin?

VG, Boris


  

Betrifft: AW: Zeit ermitteln bei Drehfeld-Betätigung von: Siegfried
Geschrieben am: 17.08.2018 16:25:49

Hi Boris,

die Sache mit der Anpassung an meine Mappe ist kein Problem

mein Hintergedanke war, dass ich wie bei der Startzeit

Sub Drehfeld10_BeiÄnderung()
     Range("B20").FormulaR1C1 = "=NOW()"
End Sub
mit einer ähnlichen Anweisung auskomme, der Art
Sub Drehfeld10_BeiBerechnung() _BeiAktion
    Range("B21") = Now()-Today()
End Sub
Gruß
Siegfried


Beiträge aus dem Excel-Forum zum Thema "Zeit ermitteln bei Drehfeld-Betätigung"