Funktion indirekt für mehrere Tabellenblätter

Bild

Betrifft: Funktion indirekt für mehrere Tabellenblätter
von: Thomas
Geschrieben am: 26.11.2015 18:55:04

Hallo.
Ich habe 13 Tabellenblätter, 12 sind mit den Monatsnamen benannt. Ich möchte aus allen Tabellenblättern die Werte der Spalte B summieren. Im Tabellenblatt "Gesamt" sind die Zellen A2 - A13 mit den Monatsnamen gefüllt. Ich bin soweit, dass ich mit =Summe(indirekt(a2&"!B:B")) die Werte für Januar aus dem Tabellenblatt bekomme. Mein Plan die Formel =summe(indirekt(A2&":"&A14"!B:B")) zu verwenden blieb ohne Erfolg. Wer kann mir helfen?
Vielen Dank im Voraus.

Bild

Betrifft: AW: Funktion indirekt für mehrere Tabellenblätter
von: Sepp
Geschrieben am: 26.11.2015 19:04:33
Hallo Thomas,
Tabelle1

 C
245

Formeln der Tabelle
ZelleFormel
C2{=SUMME(Januar:Dezember!B:B)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


Bild

Betrifft: AW: Funktion indirekt für mehrere Tabellenblätter
von: Thomas
Geschrieben am: 26.11.2015 19:07:52
Hallo Sepp.
Vielen Dank für deine Antwort. Gern würde ich die Tabellenblätter nicht direkt sondern mittels der Funktion indirekt ansprechen.
VG

Bild

Betrifft: AW: Funktion indirekt für mehrere Tabellenblätter
von: Sepp
Geschrieben am: 26.11.2015 19:17:11
Hallo Thomas,
dann so:
Tabelle1

 ABCD
1    
2Januar 12 
3Februar   
4März   
5April   
6Mai   
7Juni   
8Juli   
9August   
10September   
11Oktober   
12November   
13Dezember   

Formeln der Tabelle
ZelleFormel
C2{=SUMME(SUMMEWENN(INDIREKT("'"&A2:A13&"'!B:B"); "<>0"))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
http://www.excelformeln.de/formeln.html?welcher=234
Gruß Sepp


Bild

Betrifft: Du solltest allerdings...
von: Sepp
Geschrieben am: 26.11.2015 19:25:06
... den Bereich B:B auf die maximal zu erwartende Zeilenanzahl begrenzen, sonnst rechnet die Formel jedesmal 12.582.912 Zellen durch!

Gruß Sepp


Bild

Betrifft: AW: Du solltest allerdings...
von: Thomas
Geschrieben am: 26.11.2015 19:33:58
Danke für deine Hilfe, aber er berechnet nur die Werte aus dem ersten Tabellenblatt (Januar) welches angesprochen wird.

Bild

Betrifft: AW: Du solltest allerdings...
von: Sepp
Geschrieben am: 26.11.2015 19:46:05
Hallo Thomas,
den Matrix-Hinweis hast du beachtet? Die {} NICHT eingeben, sondern die Formeleingabe mit STRG+SHIFT+ENTER abschließen!

Gruß Sepp


Bild

Betrifft: AW: Du solltest allerdings...
von: Thomas
Geschrieben am: 26.11.2015 20:39:20
Hatte ich nicht, aber jetzt :)
Vielen Dank!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Funktion indirekt für mehrere Tabellenblätter "