Anzeige
Archiv - Navigation
1744to1748
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Pivot-Tabelle soll Zellinhalt anzeigen

Pivot-Tabelle soll Zellinhalt anzeigen
10.03.2020 22:23:19
Astis
Hallo ich habe eine Tabelle die aufzeigt welcher Kunde welche Produkte hat. Pro Produkt existiert eine Zeile. Die Anzahl der Produkte ist variabel. Derzeit hat also ein Kunde mit 3 Produkten 3 Zeilen. Ziel ist es die Produkte nicht untereinander sondern hintereinander zu stellen. In Access gibt es eine Kreuztabellenabfrage.
In Excel kann ich mit einer Pivot Tabelle mir nur die ANzahl der Produkte, aber nicht den Namen anzeigen lassen. Gibt es da eine Möglichkeit?
aus:
Kunde 1 - Käse
Kunde 1 - Brot
Kunde 2 - Brot
Kunde 3 - Käse
Kunde 3 - Milch
Kunde 3 - Kaffee
soll werden:
Kunde 1 - Käse - Brot
Kunde 2 - Brot
Kunde 3 - Käse - Milch - Kaffee
mein Pivot "Miss"erfolg:
Name Käse - Brot - Milch - Kaffee
Kunde 1 1 1
Kunde 2 1
Kunde 3 1 1 1

1
Beitrag zum Forumthread
Beitrag zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: nicht mit Pivotauswertung ...
11.03.2020 08:32:02
neopa
Hallo Astis,
... wenn es keine Massendatenauswertung (dann möglicherweise eine PowerQuery-Lösung) werden soll, dann z.B. mit einer Formellösung wie folgt. Formel D2 nach unten E1 nach rechts und E2 nach unten und rechts ziehend kopieren:
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
1KundeArtikel KundeArtikel 1Artikel 2Artikel 3 
2Kunde 1Käse Kunde 1KäseBrot  
3Kunde 1Brot Kunde 2Brot   
4Kunde 2Brot Kunde 3KäseMilchKaffee 
5Kunde 3Käse      
6Kunde 3Milch      
7Kunde 3Kaffee      
8        
9        

ZelleFormel
E1=WENN(ZÄHLENWENN(E2:E99;"?*")=0;"";"Artikel "&SPALTE(A1))
D2=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE(A$2:A$99)/(A$2:A$99>"")/(ZÄHLENWENN(D$1:D1;A$2:A$9)=0);1));"")
E2=WENNFEHLER(INDEX($B:$B;AGGREGAT(15;6;ZEILE(A$2:A$99)/($A$2:$A$99=$D2);SPALTE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß Werner
.. , - ...
Anzeige

325 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige