Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert in Abhängigkeit von anderer Spalte

Betrifft: Mittelwert in Abhängigkeit von anderer Spalte von: Walter Schneider
Geschrieben am: 23.07.2008 20:28:18

Wer kann mir bei folgendem Problem weiterhelfen:

In Spalte A habe ich das Alter von mehreren Personen. In Spalte B
das Geschlecht männlich oder weiblich..

Wie kann ich jetzt das Durchschnittsalter der männlichen, bzw. weiblichen Personen ermitteln?

Schon jetzt vielen Dank für Eure Bemühungen.

Walter Schneider

  

Betrifft: AW: Mittelwert Wenn von: Beate Schmitz
Geschrieben am: 23.07.2008 20:48:31

Hallo Walter,

 ABCD
1AlterGeschlechtDurchschnittsalter:
272mm48,25
325mw38,40
439w  
557m  
637w  
728w  
878w  
910w  
1039m  

Formeln der Tabelle
ZelleFormel
D2{=MITTELWERT(WENN(B$2:B$10=C2;A$2:A$10))}
D3{=MITTELWERT(WENN(B$2:B$10=C3;A$2:A$10))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Gruß,
Beate


  

Betrifft: AW: Mittelwert in Abhängigkeit von anderer Spalte von: Sigi
Geschrieben am: 23.07.2008 20:49:13

Hi Walter,

sieh dir die beiden Funktionen Summewenn() und Zählenwenn() an. Dann wie folgt:

=SUMMEWENN(B1:B65000;"m";A1:A65000) / ZÄHLENWENN(B1:B65000;"m")
=SUMMEWENN(B1:B65000;"w";A1:A65000) / ZÄHLENWENN(B1:B65000;"w")

Gruß
Sigi


  

Betrifft: AW: Mittelwert in Abhängigkeit von anderer Spalte von: Andre´
Geschrieben am: 23.07.2008 20:51:26

Hallo Walter,

z.B. mit Pivot https://www.herber.de/bbs/user/54095.xls


MFG Andre

Rückmeldung wäre nett!


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert in Abhängigkeit von anderer Spalte"