Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl unterschiedlicher Werte mit Abhängigkeit

Betrifft: Anzahl unterschiedlicher Werte mit Abhängigkeit von: Arthur
Geschrieben am: 21.08.2014 08:26:21

Hallo Forum.

Früh am Morgen und vlt noch ohne Kaffee könnt ihr mir hoffentlich dennoch helfen. Mir fällt die Formel nicht ein, wie ich die Anzahl unterschiedlicher Werte zählen kann, in Abhängigkeit von einem Kriterium.

Folgendermaßen sieht die Struktur aus:

Kriterium Datum
aaa 20.08.2014
aaa 20.08.2014
aaa 21.08.2014
aaa 22.08.2014
bbb 20.08.2014
ddd 20.08.2014
bbb 20.08.2014
ccc 20.08.2014
ccc 21.08.2014

Das zu findende Ergebnis in diesem Beispiel:
Für aaa sind 3 unterschiedliche Datum vorhanden.
Für bbb nur eines.
Für ccc sind es zwei.
Für ddd eines.

Die verschiedenen Datum zu zählen ginge:
{=SUMME(WENN(B2:B11<>"";1/ZÄHLENWENN(B2:B11;B2:B11)))}
oder
=SUMME((HÄUFIGKEIT(B2:B10;B2:B10)>0)*1)

Wie stelle ich den Bezug zu den Kriterien her?

Danke schön und Gruß, Arthur

  

Betrifft: AW: Anzahl unterschiedlicher Werte mit Abh. von: Daniel
Geschrieben am: 21.08.2014 09:11:58

Hi

Mal so aus dem bauch heraus ohne es getestet zu haben

{=SUMME(WENN(a2:a11="aaa";1/ZÄHLENWENNs(B2:B11;B2:B11;a2:a11;"aaa")))}

Gruß Daniel


  

Betrifft: Thx von: Arthur
Geschrieben am: 21.08.2014 09:17:13

Hallo Daniel.

Wer da mal sagt, dass der Bauch zuweilen nicht unser größtes Gehirn ist .... :0)

Gruß, Arhurt


  

Betrifft: wieso ne komliziertere Formel ? von: WF
Geschrieben am: 21.08.2014 09:27:50

Hi,

Du brauchst doch nur Deine Ursprungsformel leicht ändern:
{=SUMME(WENN(A2:A11="aaa";1/ZÄHLENWENN(B2:B11;B2:B11)))}

Salut WF


  

Betrifft: AW: wieso ne komliziertere Formel ? Weil... von: Daniel
Geschrieben am: 21.08.2014 11:46:11

...die einfachere Formel nicht das richtige Ergebnis liefert.
hier ist das der Fall, wenn das selbe Datum bei mehreren verschiedenen Werten vorkommt.

Gruß


  

Betrifft: stimmt ! von: WF
Geschrieben am: 21.08.2014 12:08:38

.


  

Betrifft: AW: Anzahl unterschiedlicher Werte mit Abhängigkeit von: fcs
Geschrieben am: 21.08.2014 09:30:09

Hallo Arthur,

ich würde eine entsprechende Auswertung mit 2 Pivottabellenberichten.

1. Pivot
Datenquelle ist deine Liste
Als Zeilenbeschriftung verwendest du die Felder Kriterium und Datum
Als Datenfeld Kriterium
Keine Anzeige von Zwischen und Gesamtergebnissen.
Für das Feld "Kriterium" stellst du das Layout unter den Feldeinstellungen so ein, dass die Elementnamen wiederholt werden.

So liefert die Pivot eine Liste deiner Daten ohne Wiederholungen.


2. Pivot
Als Datenquelle verwendest du die beiden ersten Spalten (Kriterium und Datum) des 1. Pivottabellenberichts.
Zeilenbeschriftung = Kriterium, Datenbereich = Feld Datum mit Funktion Anzahl

Diese Lösung ist nicht rechenintensiv und läßt sich bei Bedarf mit ein paar Mausklicks aktualisieren.

Gruß
Franz


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl unterschiedlicher Werte mit Abhängigkeit"