Betrag in Text suchen und ausgeben

Bild

Betrifft: Betrag in Text suchen und ausgeben
von: Tobias Witzke
Geschrieben am: 17.11.2015 09:41:34

Liebe Excel-Spezialisten,
ich habe folgendes Problem und hoffe ihr könnt mir helfen:
In meiner Tabelle steht zb. folgendes in Zelle A1:
Text blabla Verkaufspreis: EUR 4,99 Text blabla
Jetzt hätte ich gerne in B1 den Betrag 4,99 stehen.
Die Texte in Spalte A können unterschiedlich lang sein und die gesuchten Beträge können auch 2- oder 3-stellig vor dem Komma sein. Der Aufbau ist immer:
Text..... Verkaufspreis: EUR Betrag Text.....
Schon dieses Problem kann ich nicht lösen. Jetzt kommt noch hinzu, dass der Inhalt der Zellen in Spalte A auch teilweise so aussehen kann:
Text blabla Verkaufspreis: EUR 11,90, 2 von 2000 Artikeln zu EUR 5,95 Text blabla
Angenommen das wäre der Inhalt von A2 hätte ich am liebsten gerne in B2 den Betrag 11,90 stehen.
Kann mir jemand helfen?
Schöne Grüße
Tobi

Bild

Betrifft: Suche nach "EUR" ...
von: Matthias L
Geschrieben am: 17.11.2015 10:13:10
Hallo
Probier mal, ob das so passt
Tabelle1

 AB
1Text blabla Verkaufspreis: EUR 4,99 Text blabla4,99
2Text blabla Verkaufspreis: EUR 11,90, 2 von 2000 Artikeln zu EUR 5,95 Text blabla11,90

Formeln der Tabelle
ZelleFormel
B1=GLÄTTEN(TEIL(A1;FINDEN("EUR ";A1)+4;5))
B2=GLÄTTEN(TEIL(A2;FINDEN("EUR ";A2)+4;5))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
u.U noch ein Wennfehler drumherum legen
Gruß Matthias

Bild

Betrifft: kleine Korrektur
von: Matthias L
Geschrieben am: 17.11.2015 10:19:26
Hallo
Tabelle1

 AB
1Text blabla Verkaufspreis: EUR 4,99 Text blabla4,99
2Text blabla Verkaufspreis: EUR 11,90, 2 von 2000 Artikeln zu EUR 5,95 Text blabla11,90
3keine Preise im Text 
4Text blabla Verkaufspreis: EUR 1254,99 Text blabla1254,99
5Text blabla Verkaufspreis: EUR 451,99 Text blabla451,99

Formeln der Tabelle
ZelleFormel
B1=WENNFEHLER(GLÄTTEN(TEIL(A1;FINDEN("EUR ";A1)+4;(FINDEN(",";A1)+4)-(FINDEN("EUR ";A1)+4)-1));"")
B2=WENNFEHLER(GLÄTTEN(TEIL(A2;FINDEN("EUR ";A2)+4;(FINDEN(",";A2)+4)-(FINDEN("EUR ";A2)+4)-1));"")
B3=WENNFEHLER(GLÄTTEN(TEIL(A3;FINDEN("EUR ";A3)+4;(FINDEN(",";A3)+4)-(FINDEN("EUR ";A3)+4)-1));"")
B4=WENNFEHLER(GLÄTTEN(TEIL(A4;FINDEN("EUR ";A4)+4;(FINDEN(",";A4)+4)-(FINDEN("EUR ";A4)+4)-1));"")
B5=WENNFEHLER(GLÄTTEN(TEIL(A5;FINDEN("EUR ";A5)+4;(FINDEN(",";A5)+4)-(FINDEN("EUR ";A5)+4)-1));"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Betrag in Text suchen und ausgeben
von: Michael (migre)
Geschrieben am: 17.11.2015 10:17:50
Hallo Tobi!
Sollte klappen (auch bei Beträgen mit mehr Stellen vor dem Komma; danach aber nur 2):
Texte ab A1:

=TEIL(LINKS(A1;SUCHEN(",";A1)+2);SUCHEN("EUR";LINKS(A1;SUCHEN(",";A1)+2);1)+3;LÄNGE(LINKS(A1; SUCHEN(",";A1)+2))) 
Lg
Michael

Bild

Betrifft: Links steht dann aber immer ein Leerzeichen ...
von: Matthias L
Geschrieben am: 17.11.2015 10:28:52
Hallo Michael
Hast Du das Leerzeichen schon bemerkt, welches dann immer als erstes Zeichen steht?
Gruß Matthias

Bild

Betrifft: AW: Links steht dann aber immer ein Leerzeichen ...
von: Michael (migre)
Geschrieben am: 17.11.2015 10:51:25
Hallo Matthias!
In der Tat, nein. Weil ich nur eine Summe drüberlaufen ließ, die anstandslos gerechnet wurde. Danke für den Hinweis, dann halt mal die faule Korrektur:

=GLÄTTEN(TEIL(LINKS(A1;SUCHEN(",";A1)+2);SUCHEN("EUR";LINKS(A1;SUCHEN(",";A1)+2);1)+3;LÄNGE(LINKS(A1; SUCHEN(",";A1)+2)))) 
Schönen Tag!
Michael

Bild

Betrifft: AW: Betrag in Text suchen und ausgeben
von: Tobias Witzke
Geschrieben am: 17.11.2015 11:09:19
Super nett von Euch!
Vielen Dank für die Lösung. Alles funktioniert!
Hab absolut keine Ahnung von Excel und hab gestern bestimmt 3-4 Stunden daran rumprobiert.
Tolles Forum - tolle User - ich bin rundum happy!

Bild

Betrifft: AW: Danke für die nette Rückmeldung, owT Michael
von: Michael (migre)
Geschrieben am: 17.11.2015 11:13:01


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Betrag in Text suchen und ausgeben"