Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Betrag | Herbers Excel-Forum


Betrifft: Formel für Betrag von: Christian
Geschrieben am: 22.02.2012 10:20:32

Hallo
Ich hoffe ihr könnt mir helfen. ich suche ein Formel die mir den Betrag aus der betreffenden Zelle ausgibt.

Tabelle1

 ABCDEFGHIJKL
1ArtBez.StückSumme  Dübel  Schrauben  Muttern  usw-->
2Dübelm82Hier gesuchte Summe  m61m64m67 
3    usw usw  m82m85m88 
4          m103m106m109 
5          usw usw usw usw usw usw 
6                       

Tabellendarstellung in Foren Version 5.30


Wie mache ich das am besten. Index und Vergleich?? Oder wie mache ich das am besten. Oder die Tabelle umbauen. Wäre dankbar für Vorschläge
Danke
Gruß Christian

  

Betrifft: per Arrayformel von: WF
Geschrieben am: 22.02.2012 10:54:05

Hi,

{=INDEX(3:3;VERGLEICH(A2&B2;1:1&3:3;0)+1)}

Salut WF


  

Betrifft: oder auch mit SUMMENPRODUKT von: WF
Geschrieben am: 22.02.2012 11:12:12

=SUMMENPRODUKT((A1:Z1=A2)*(A3:Z3=B2);B3:AA3)

WF


  

Betrifft: AW: oder auch mit SUMMENPRODUKT von: Christian
Geschrieben am: 22.02.2012 11:15:14

Hallo WF
Super,vielen Dank
gruss Christian


  

Betrifft: AW: :-( doch nicht von: Christian
Geschrieben am: 22.02.2012 11:23:16

Hallo
Was mache ich falsch??

Tabelle1

 ABCDEFGHI
1ArtBez.StückSumme  Dübel  Schrauben 
2Dübelm813  m61m64
3Schraubenm1023  m83m85
4          m103m106
5          usw usw usw usw

verwendete Formeln
Zelle Formel Bereich
D2 {=INDEX(3:3;VERGLEICH(A2&B2;1:1&3:3;0)+1)} $D$2
D3 {=INDEX(4:4;VERGLEICH(A3&B3;2:2&4:4;0)+1)} $D$3
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.30


gruss Christian


  

Betrifft: na ja von: WF
Geschrieben am: 22.02.2012 11:38:05

Dübel und Schrauben stehen beide in Zeile 1
Du beziehst Dich aber auf Zeile 2

also:
{=INDEX(4:4;VERGLEICH(A3&B3;1:1&4:4;0)+1)}

WF


  

Betrifft: AW: na ja von: Christian
Geschrieben am: 22.02.2012 12:16:32

Hallo WF
Ich glaube ich hab mich falsch ausgedrückt. sry
Wenn ich in SpalteA "Dübel" eingebe und in SpalteB "m8" soll die Formel mir aus der Spalte Dübel rechts neben "m8" die Zahl rausgeben. Da muesste doch der Index F2:K1000 sein. Soll wie eine Kreuztabelle sein.
Hast Du dafür eine Lösung?
gruss Christian


  

Betrifft: AW: Frage offen von: Christian
Geschrieben am: 22.02.2012 12:17:22

.


  

Betrifft: AW: Frage offen von: Tino
Geschrieben am: 22.02.2012 15:24:20

Hallo,
vielleicht könnte man es so machen?!

 ABCDEFGHI
1ArtBezStückSumme Dübel Schraube 
2Dübelm826 m61m64
3Schraubem10318 m83m85
4     m103m106

Formeln der Tabelle
ZelleFormel
D2=SVERWEIS($B2;BEREICH.VERSCHIEBEN($F:$G;;VERGLEICH($A2;$1:$1;0)-6); 2;FALSCH)*$C2
D3=SVERWEIS($B3;BEREICH.VERSCHIEBEN($F:$G;;VERGLEICH($A3;$1:$1;0)-6); 2;FALSCH)*$C3


Gruß Tino


  

Betrifft: AW: das wars... von: Christian
Geschrieben am: 22.02.2012 16:06:30

Hallo Tino
Danke, das paßt. Dann brauche ich meinen Vater nachher nicht zu fragen.
Gruss Christian


Beiträge aus den Excel-Beispielen zum Thema "Formel für Betrag"