Microsoft Excel

Herbers Excel/VBA-Archiv

Wort aus Liste in Text finden und ausgeben


Betrifft: Wort aus Liste in Text finden und ausgeben von: MarC
Geschrieben am: 25.01.2019 15:44:54

Hi alle,

ich habe eine Liste mit 20 verschiedenen Wörtern (C1 bis C2) und in jeder Zelle von A1 bis A100000 steckt ein Wort von den 20 im Zellen Text drin. Die Wörter sollen gesucht und in B1 bis B100000 ausgegeben werden. Wie mach ich das am besten?

Ich habe es mit Sverweis oder Text Teilen versucht aber irgendwas mache ich noch falsch.

  

Betrifft: AW: Wort aus Liste in Text finden und ausgeben von: Daniel Köstinger
Geschrieben am: 25.01.2019 16:38:55

moin

so?

B1.... =SVERWEIS(C$1:C$20;A$1:A$100000;1;0)
oder:
=WENN(ISTNV(SVERWEIS(C$1:C$20;A$1:A$100000;1;0));"";SVERWEIS(C$1:C$20;A$1:A$100000;1;0))
lg


Beiträge aus dem Excel-Forum zum Thema "Wort aus Liste in Text finden und ausgeben"