Microsoft Excel

Herbers Excel/VBA-Archiv

Text finden und kopieren | Herbers Excel-Forum


Betrifft: Text finden und kopieren von: Bodo_Bachmann69
Geschrieben am: 16.11.2009 22:32:29

Hallo,

ich habe folgendes Problem:
Ich habe in Spalte A einen Text stehen und möchte in Spalte B einen Teil davon kopieren (per Formel).

Soweit bin ich derzeit (ALLE ANGABEN OHNE " AM ANFANG UND AM ENDE):

Zu kopierender Teil (aus Spalte A):
"R7878A"
________________________________________________________________________________
Spalte A:
"Test Test 478 E R7878A Test E78 G Test 655 E"

Spalte B:
"=WENN(ODER(ISTFEHLER(FINDEN("R";A10;1)); ISTFEHLER(FINDEN("A";A10;1)));"";LINKS(R ECHTS(A10;LÄNGE(A10)-FINDEN(" ";A10;1));FINDEN("A";A10;1)-FINDEN(" ";A10;1)))"
________________________________________________________________________________

Ergebnis:
"Test 478 E R7878A"
________________________________________________________________________________

Zusammengefasst kann man folgendes sagen:
Ich möchte nur folgenden Teil kopieren: R7878A, aber kopiert wird alles nach dem ersten Wort.

Ich wäre über jede Hilfe sehr dankbar.

  

Betrifft: Text zwischen "R" und "A" anzeigen von: NoNet
Geschrieben am: 16.11.2009 22:44:42

Hallo Bodo,

versuche es mal mit folgender Funktion :

=WENN(ISTZAHL(SUCHEN("R*A";A10));TEIL(A10;SUCHEN("R*A";A10);FINDEN("A";A10;SUCHEN("R*A";A10))-SUCHEN("R*A";A10)+1);"")

Gruß, NoNet


  

Betrifft: AW: Text zwischen "R" und "A" anzeigen von: Bodo_Bachmann69
Geschrieben am: 16.11.2009 22:52:57

Sorry, leider kommt bei mir folgende Fehlermeldung:
Die Formel bezieht sich auf leere Zellen


  

Betrifft: Wie Bitte ? - Funktion falsch eingegeben ? von: NoNet
Geschrieben am: 16.11.2009 23:05:49

Hey Bodo,

hast Du die Funktion auch korrekt in B10 eingegeben (bzw. kopiert) ?
Bei mir klappt das einwandfrei :

AB
9
10
11

Funktionen der Tabelle :
Zelle Formel 
B10   =WENN(ISTZAHL(SUCHEN("R*A";A10));TEIL(A10;SUCHEN("R*A";A10);FINDEN("A";A10;SUCHEN("R*A";A10))-SUCHEN("R*A";A10)+1);"") 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


  

Betrifft: AW: Wie Bitte ? - Funktion falsch eingegeben ? von: Bodo_Bachmann69
Geschrieben am: 16.11.2009 23:18:36

Oha, sorry!!! Die Formel funktioniert 100&ig. Hatte da wohl im Eifer des Gefechts tatsächlich ein Leerzeichen (o.ä.) mit kopiert. Besten Dank. Endlich funktioniert es (und ich habe mir den ganzen Nachmittag den Kopf zerbrochen, wo denn nun der Fehler ist - also bei meiner Formel^^)


  

Betrifft: AW: Wortauswahl aus Zelle von: Bodo_Bachmann69
Geschrieben am: 17.11.2009 10:52:48

Eine Frage hätte ich noch:
Ist es möglich, in z.B. Zelle "C10" einen Wert einzutragen (in diesem Bsp. "R7878A") und die Formel in B10 integriert den Wert (Suchwort) aus C10?


  

Betrifft: Zu filternder Text aus Zelle übernehmen von: NoNet
Geschrieben am: 17.11.2009 13:08:18

Hallo Bodo,

das geht auch - hier ein paar Beispiele :

ABC
10
11
12
13
14
15

Funktionen im Tabellenblatt :
Zelle Formel 
B10   =WENN(ISTZAHL(SUCHEN(C10;A10));TEIL(A10;SUCHEN(C10;A10);SUCHEN(RECHTS(C10;1);A10;SUCHEN(C10;A10))-SUCHEN(C10;A10)+1);"") 
B11   =WENN(ISTZAHL(SUCHEN(C11;A11));TEIL(A11;SUCHEN(C11;A11);SUCHEN(RECHTS(C11;1);A11;SUCHEN(C11;A11))-SUCHEN(C11;A11)+1);"") 
B12   =WENN(ISTZAHL(SUCHEN(C12;A12));TEIL(A12;SUCHEN(C12;A12);SUCHEN(RECHTS(C12;1);A12;SUCHEN(C12;A12))-SUCHEN(C12;A12)+1);"") 
B13   =WENN(ISTZAHL(SUCHEN(C13;A13));TEIL(A13;SUCHEN(C13;A13);SUCHEN(RECHTS(C13;1);A13;SUCHEN(C13;A13))-SUCHEN(C13;A13)+1);"") 
B14   =WENN(ISTZAHL(SUCHEN(C14;A14));TEIL(A14;SUCHEN(C14;A14);SUCHEN(RECHTS(C14;1);A14;SUCHEN(C14;A14))-SUCHEN(C14;A14)+1);"") 
B15   =WENN(ISTZAHL(SUCHEN(C15;A15));TEIL(A15;SUCHEN(C15;A15);SUCHEN(RECHTS(C15;1);A15;SUCHEN(C15;A15))-SUCHEN(C15;A15)+1);"") 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet
PS: Das FINDEN habe ich jetzt auch durch SUCHEN ersetzt !!!


  

Betrifft: AW: Zu filternder Text aus Zelle übernehmen von: Bodo_Bachmann69
Geschrieben am: 17.11.2009 20:52:18

Perfekt! Vielen Dank. Du bist der Beste^^


Beiträge aus den Excel-Beispielen zum Thema "Text finden und kopieren"