Zwei Spalten miteinander vergleichen

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox


Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Zwei Spalten miteinander vergleichen
von: Thomas
Geschrieben am: 16.07.2002 - 14:12:53

Hallo,

ich habe folgendes Problem:
Ich habe zwei Spalten mit Einträgen wie 622D05. Die Zweite Spalte enthält alle Werte die mir bekannt sind ca. 200. In der ersten Spalte stehen etwa 20 Werte, die aber normalerweise auch in der zweiten Spalte vorhanden sind. Ich brauche nun eine Formel oder besser eine VBA Funktion, die mir in einem Dialogfenster anzeigt wenn in der ersten Spalte ein Wert steht der in der zweiten Spalte nicht vorhanden ist.
Wer kann mir helfen?

Gruß Thomas

nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: andreas e
Geschrieben am: 16.07.2002 - 14:21:52

hallo thomas,

meinst das etwa so ??


MS Excel von andreas e an Thomas
 ABCD
1     
2Tabelle_1AusgabeFormelTabelle_2
3622D05  =WENN(ISTFEHLER(SVERWEIS(A3;D:D;1;FALSCH));"Wert_nicht_vorhanden";"")622D05
4622D06Wert_nicht_vorhanden  622D08
5622D07    622D09
6622D08    622D15
7622D09    anderer1
8622D10Wert_nicht_vorhanden  622D17
9622D11Wert_nicht_vorhanden  anderer2
10622D12Wert_nicht_vorhanden  622D07
11622D13Wert_nicht_vorhanden 
12622D14Wert_nicht_vorhanden 
13622D15   
14622D16Wert_nicht_vorhanden 
15622D17   
16622D18Wert_nicht_vorhanden 
17622D19Wert_nicht_vorhanden  


gruß
andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: Thomas
Geschrieben am: 16.07.2002 - 14:26:30

Ja Danke!!

Ich glaube damit kann ich schon mal was anfangen!!!

Gruß Thomas


nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: Thomas
Geschrieben am: 16.07.2002 - 14:43:07

Wissen sie auch eine lösung mit VBA? Weil ich sie das Ergebnis "weiterverarbeiten" kann!!!

nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: andreas e
Geschrieben am: 16.07.2002 - 14:45:47

wie soll das ergebnis denn weiter verarbeitet werden ?

Übergib es doch einfach an ne variable

weitergabe = range("A2").value

gruß

andreas e

http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr

nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: Thomas
Geschrieben am: 16.07.2002 - 14:50:00

Stimmt!!!!

Alles klar!!! Danke!!!


nach oben   nach unten

Re: Zwei Spalten miteinander vergleichen
von: L.Vira
Geschrieben am: 16.07.2002 - 14:54:06

Option Explicit
Sub matchen()
Dim lz As Long
Dim z As Long
Dim What2Find As Variant 'Suchbegriff aus Spalte 1
Dim dummy As Long
lz = [a65536].End(xlUp).Row
For z = 1 To lz
What2Find = Cells(z, 1)
If Not What2Find = "" Then
On Error Resume Next
dummy = WorksheetFunction.Match(What2Find, Columns(2), 0)
If Err Then
MsgBox What2Find & " nicht gefunden! ", 64, "stelle fest..."
End If
End If
Next
End Sub

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Zwei Spalten miteinander vergleichen"