Microsoft Excel

Herbers Excel/VBA-Archiv

Vier Spalten miteinander Vergleichen

Betrifft: Vier Spalten miteinander Vergleichen von: Richy Notyetrich
Geschrieben am: 07.09.2020 17:52:04

Hallo zusammen,


ich bin leider schon den halben Tag auf der Suche nach einer Lösung bei meinem Excel Problem.

Evtl. hat jemand mit mehr Begabung in Excel eine Idee.


Zu meinem Problem, ich möchte vier Spalten miteinander vergleichen, dabei gehören jeweils zwei Spalten zusammen.

Also die Werte von Spalte A und B soll in der Spalte C und D gefunden und nach Möglichkeit eine Übereinstimmung anzeigen.

Dabei ist zu beachten, dass die Werte nicht nebeneinander stehen, sondern eine zufällige Anordnung haben.

A B C D
16431337 11.754,17 16638980 -4.322,50
16085033 5.333,61 16085034 2.022,22
15104613 63.194,44 16431337 11.754,17
16431337 11.754,17 16085033 5.333,61
16638980 -4.322,50 16473710 -17.694,44
16343183 928.579,17 15104613 63.194,44

Vielen Dank für jede Idee im Vorraus.

Lg

Richy

Betrifft: AW: Vier Spalten miteinander Vergleichen
von: Hajo_Zi
Geschrieben am: 07.09.2020 17:57:13

Hallo Richy,


Tabelle2
 ABCD
11643133711754,1716638980-4322,5
2160850335333,61160850342022,22
31510461363194,441643133711754,17
41643133711754,17160850335333,61
516638980-4322,516473710-17694,44
616343183928579,171510461363194,44
die bedingte Formatierung Fülleffekte, Symbole, Datenbalken
werden in dieser Tabelle nicht dargestellt

Zahlenformate
Zelle Format Inhalt
B1 '#.##0,00  11754,17
B2 '#.##0,00  5333,61
B3 '#.##0,00  63194,44
B4 '0 "2020"  11754,17
B5 '#.##0,00  -4322,5
B6 '#.##0,00  928579,17
Zellen mit Format Standard werden nicht dargestellt

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füll-farbe   Unterstrichen   Schrift- farbe Muster   Muster-farbe Typ Bereich
$C:$C01.Bed.: Formel ist =ZÄHLENWENN(A:A;C1)>0  5287936         2$C:$C
$D:$D01.Bed.: Formel ist =ZÄHLENWENN(B:B;D1)>0  5287936         2$D:$D
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$C:$C01.Bed.   Falsch          2$C:$C
$D:$D01.Bed.   Falsch          2$D:$D
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit



GrußformelHomepage

Betrifft: AW: Vier Spalten miteinander Vergleichen
von: Richy Notyetrich
Geschrieben am: 07.09.2020 19:55:07

Hi,

Vielen Dank für deine Hilfe, aber irgendwie verstehe ich nur Bahnhof?! Was muss ich machen?

Vielen Dank

Lg

Richard

Betrifft: AW: Vier Spalten miteinander Vergleichen
von: Richy Notyetrich
Geschrieben am: 07.09.2020 19:55:08

Hi,

Vielen Dank für deine Hilfe, aber irgendwie verstehe ich nur Bahnhof?! Was muss ich machen?

Vielen Dank

Lg

Richard

Betrifft: AW: Vier Spalten miteinander Vergleichen
von: Hajo_Zi
Geschrieben am: 07.09.2020 19:58:51

Hallo0 Richard,

benutze wie dargestellt die bedingte Formatierung.
Oder benutze das Add.Inn um die Tabelle wieder herzustellen.,

Gruß Hajo

Betrifft: CP CEF
von: lupo1
Geschrieben am: 07.09.2020 18:56:52



Betrifft: kannst Du auch mal "normal" schreiben?
von: Matthias L
Geschrieben am: 07.09.2020 19:46:47

Ein nicht gerade dauerhafter Nutzer des Forums kann mit Deiner Aussage nix anfangen!
Schreib also bitte dazu was Du meinst und verlinke das als Nachweis.
Mir persönlich musst Du es nicht erklären.

Betrifft: war an Lupo gerichtet! owT
von: Matthias L
Geschrieben am: 07.09.2020 19:48:17



Betrifft: Ricky wurde das schon im anderen Forum gesagt ...
von: lupo1
Geschrieben am: 08.09.2020 01:01:13

... somit ist das nur eine Warnung für die Antworter hier.

Betrifft: mir selbst ist das schon klar ...
von: Matthias L
Geschrieben am: 08.09.2020 02:58:18

aber andere "normale Mitleser" können damit nix anfangen!
Woher sollen die denn wissen das Du z.B. mit CP CrossPosting meinst.
Das der 2.String ne Abkürzung für ne Website ist kann der "normale Mitleser"
auch nicht wissen.

Stell Dir mal vor Du gehst zum Fleischer. Da steht ein großes Schild
mit der Aufschrift: WHMG

Betrifft: WHMG - "wegen Hirn-Mangel geschlossen" ...
von: lupo1
Geschrieben am: 08.09.2020 07:31:14

... ist doch ganz klar ;)

Beiträge aus dem Excel-Forum zum Thema "Vier Spalten miteinander Vergleichen"