Untersch. Tabellen vergleichen und markieren

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Untersch. Tabellen vergleichen und markieren
von: Silvia
Geschrieben am: 20.09.2003 11:02:23

Guten Morgen Exceluser,
ich habe jetzt schon bis zum abwinken recherchiert,
aber keine bisherige Lösung konnte ich nach meinen
Erwartungen umbauen, so hoffe ich auf Eure Unterstützung.

Es sind 2 unterschiedlich große Tabellen auf 3 Übereinstimmungen
zu prüfen.
Die Ausgangsdaten befinden sich in der Tabelle "Bauausgabebuch" Zeile 10 bis 203, Spalte A bis O.
Die Zieldaten für die Prüfung befinden sich in der Tabelle "Datenbank", Zeile 10 bis 406, Spalte A bis AQ.
Auf Übereinstimmung zu prüfen sind "Bauausgabebuch" Zelle A,C,H mit
"Datenbank" Zelle A,C,S jeweils ab Zeile 10 beginnend.
Wenn keine Übereinstimmung gefunden wird, soll die Zeile komplett von A bis AQ
in der "Datenbank" mit Font 3 markiert werden. Bei Übereinstimmung wie vor,
jedoch mit Font 5.
Ich hoffe ihr könnt mir helfen.
Viele Grüße
Silvia

Bild


Betrifft: AW: Untersch. Tabellen vergleichen und markieren
von: Franz Pölt
Geschrieben am: 20.09.2003 12:07:54

Hallo Silvia,

wenn es nicht unbedingt ein anderer Font sein muss, hier eine Lösung
a) mit Hilfsspalte (Vorteil: identische können einfach selektiert werden) und
b) bedingter Formatierung (Adressen bitte anpassen):

Excel Jeanie HTML  Tabelle5
 ABCD
1Daten1Daten2Daten3identisch
2abcja
3a cnein
4 bcnein
5ab nein
Formeln der Tabelle
D2 : =WENN((A2&B2&C2=Tabelle3!A2&Tabelle3!B2&Tabelle3!C2);"ja";"nein")
D3 : =WENN((A3&B3&C3=Tabelle3!A3&Tabelle3!B3&Tabelle3!C3);"ja";"nein")
D4 : =WENN((A4&B4&C4=Tabelle3!A4&Tabelle3!B4&Tabelle3!C4);"ja";"nein")
D5 : =WENN((A5&B5&C5=Tabelle3!A5&Tabelle3!B5&Tabelle3!C5);"ja";"nein")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =$D2="ja"Abc
B21. / Formel ist =$D2="ja"Abc
C21. / Formel ist =$D2="ja"Abc
D21. / Formel ist =$D2="ja"Abc
A31. / Formel ist =$D3="ja"Abc
B31. / Formel ist =$D3="ja"Abc
C31. / Formel ist =$D3="ja"Abc
D31. / Formel ist =$D3="ja"Abc
A41. / Formel ist =$D4="ja"Abc
B41. / Formel ist =$D4="ja"Abc
C41. / Formel ist =$D4="ja"Abc
D41. / Formel ist =$D4="ja"Abc
A51. / Formel ist =$D5="ja"Abc
B51. / Formel ist =$D5="ja"Abc
C51. / Formel ist =$D5="ja"Abc
D51. / Formel ist =$D5="ja"Abc
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild


Betrifft: VBA-Lösung gesucht
von: Silvia
Geschrieben am: 20.09.2003 17:13:17

Hallo User,
hallo Franz,
erst einmal vielen Dank für Deinen prima Beitrag.
Das kann ich sicher noch in einem anderen Fall anwenden, aber....

mir ist folgendes aufgefallen:

Funktionieren kann das Ganze nur bei gleichen Zeilenbezügen.
Im Gegensatz zum "Bauausgabebuch", 203 Zeilen, hat die Tabelle "Datenbank" 406 Zeilen (vorläufig).
Das hat auch einen guten Grund. Die Datenbank soll alle Einträge aus dem Bauausgabebuch
aufzeichnen, d.h. historische Daten bleiben erhalten, auch dann, wenn aus dem Bauausgabebuch zeilenweise gelöscht wird, was bei Rechnungsänderungen häufig geschieht.

Bitte seht Euch nochmal meinen Eröffnungs-Beitrag an.
Vielen Dank
Silvia


Bild


Betrifft: AW: wieder keine VBA-Lösung :-)
von: Franz Pölt
Geschrieben am: 20.09.2003 17:59:11

Hallo Silvia,

das ist auch wieder keine VBA-Lösung, aber siehe selbst:

Excel Jeanie HTML
Formeln der Tabelle
D2 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A2)*(Bauausgabebuch!B$2:B$7=B2)*(Bauausgabebuch!C$2:C$7=C2))>0;"ja";"nein")
D3 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A3)*(Bauausgabebuch!B$2:B$7=B3)*(Bauausgabebuch!C$2:C$7=C3))>0;"ja";"nein")
D4 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A4)*(Bauausgabebuch!B$2:B$7=B4)*(Bauausgabebuch!C$2:C$7=C4))>0;"ja";"nein")
D5 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A5)*(Bauausgabebuch!B$2:B$7=B5)*(Bauausgabebuch!C$2:C$7=C5))>0;"ja";"nein")
D6 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A6)*(Bauausgabebuch!B$2:B$7=B6)*(Bauausgabebuch!C$2:C$7=C6))>0;"ja";"nein")
D7 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A7)*(Bauausgabebuch!B$2:B$7=B7)*(Bauausgabebuch!C$2:C$7=C7))>0;"ja";"nein")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =$D2="ja"Abc
B21. / Formel ist =$D2="ja"Abc
C21. / Formel ist =$D2="ja"Abc
D21. / Formel ist =$D2="ja"Abc
A31. / Formel ist =$D3="ja"Abc
B31. / Formel ist =$D3="ja"Abc
C31. / Formel ist =$D3="ja"Abc
D31. / Formel ist =$D3="ja"Abc
A41. / Formel ist =$D4="ja"Abc
B41. / Formel ist =$D4="ja"Abc
C41. / Formel ist =$D4="ja"Abc
D41. / Formel ist =$D4="ja"Abc
A51. / Formel ist =$D5="ja"Abc
B51. / Formel ist =$D5="ja"Abc
C51. / Formel ist =$D5="ja"Abc
D51. / Formel ist =$D5="ja"Abc
A61. / Formel ist =$D6="ja"Abc
B61. / Formel ist =$D6="ja"Abc
C61. / Formel ist =$D6="ja"Abc
D61. / Formel ist =$D6="ja"Abc
A71. / Formel ist =$D7="ja"Abc
B71. / Formel ist =$D7="ja"Abc
C71. / Formel ist =$D7="ja"Abc
D71. / Formel ist =$D7="ja"Abc
 Bauausgabebuch
 ABC
1Daten1Daten1Daten1
2abc
3acd
4ade
5dab
6dbc
7abc
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Servus aus dem Salzkammergut Franz

Bild


Betrifft: Vielen Dank...
von: Silvia
Geschrieben am: 20.09.2003 19:29:03

das ist wirklich eine bemerkenswerte Lösung!
Vielen, vielen Dank.

Gruß S I L V I A


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Untersch. Tabellen vergleichen und markieren"