Das Archiv des Excel-Forums

Untersch. Tabellen vergleichen und markieren

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
Bild

Betrifft: Untersch. Tabellen vergleichen und markieren
von: Silvia

Geschrieben am: 20.09.2003 11:02:23

Guten Morgen Exceluser,
ich habe jetzt schon bis zum abwinken recherchiert,
aber keine bisherige Lösung konnte ich nach meinen
Erwartungen umbauen, so hoffe ich auf Eure Unterstützung.

Es sind 2 unterschiedlich große Tabellen auf 3 Übereinstimmungen
zu prüfen.
Die Ausgangsdaten befinden sich in der Tabelle "Bauausgabebuch" Zeile 10 bis 203, Spalte A bis O.
Die Zieldaten für die Prüfung befinden sich in der Tabelle "Datenbank", Zeile 10 bis 406, Spalte A bis AQ.
Auf Übereinstimmung zu prüfen sind "Bauausgabebuch" Zelle A,C,H mit
"Datenbank" Zelle A,C,S jeweils ab Zeile 10 beginnend.
Wenn keine Übereinstimmung gefunden wird, soll die Zeile komplett von A bis AQ
in der "Datenbank" mit Font 3 markiert werden. Bei Übereinstimmung wie vor,
jedoch mit Font 5.
Ich hoffe ihr könnt mir helfen.
Viele Grüße
Silvia
Bild


Betrifft: AW: Untersch. Tabellen vergleichen und markieren
von: Franz Pölt
Geschrieben am: 20.09.2003 12:07:54

Hallo Silvia,

wenn es nicht unbedingt ein anderer Font sein muss, hier eine Lösung
a) mit Hilfsspalte (Vorteil: identische können einfach selektiert werden) und
b) bedingter Formatierung (Adressen bitte anpassen):

Excel Jeanie HTML  Tabelle5
 ABCD
1Daten1Daten2Daten3identisch
2abcja
3a cnein
4 bcnein
5ab nein
Formeln der Tabelle
D2 : =WENN((A2&B2&C2=Tabelle3!A2&Tabelle3!B2&Tabelle3!C2);"ja";"nein")
D3 : =WENN((A3&B3&C3=Tabelle3!A3&Tabelle3!B3&Tabelle3!C3);"ja";"nein")
D4 : =WENN((A4&B4&C4=Tabelle3!A4&Tabelle3!B4&Tabelle3!C4);"ja";"nein")
D5 : =WENN((A5&B5&C5=Tabelle3!A5&Tabelle3!B5&Tabelle3!C5);"ja";"nein")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =$D2="ja"Abc
B21. / Formel ist =$D2="ja"Abc
C21. / Formel ist =$D2="ja"Abc
D21. / Formel ist =$D2="ja"Abc
A31. / Formel ist =$D3="ja"Abc
B31. / Formel ist =$D3="ja"Abc
C31. / Formel ist =$D3="ja"Abc
D31. / Formel ist =$D3="ja"Abc
A41. / Formel ist =$D4="ja"Abc
B41. / Formel ist =$D4="ja"Abc
C41. / Formel ist =$D4="ja"Abc
D41. / Formel ist =$D4="ja"Abc
A51. / Formel ist =$D5="ja"Abc
B51. / Formel ist =$D5="ja"Abc
C51. / Formel ist =$D5="ja"Abc
D51. / Formel ist =$D5="ja"Abc
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild


Betrifft: VBA-Lösung gesucht
von: Silvia
Geschrieben am: 20.09.2003 17:13:17

Hallo User,
hallo Franz,
erst einmal vielen Dank für Deinen prima Beitrag.
Das kann ich sicher noch in einem anderen Fall anwenden, aber....

mir ist folgendes aufgefallen:

Funktionieren kann das Ganze nur bei gleichen Zeilenbezügen.
Im Gegensatz zum "Bauausgabebuch", 203 Zeilen, hat die Tabelle "Datenbank" 406 Zeilen (vorläufig).
Das hat auch einen guten Grund. Die Datenbank soll alle Einträge aus dem Bauausgabebuch
aufzeichnen, d.h. historische Daten bleiben erhalten, auch dann, wenn aus dem Bauausgabebuch zeilenweise gelöscht wird, was bei Rechnungsänderungen häufig geschieht.

Bitte seht Euch nochmal meinen Eröffnungs-Beitrag an.
Vielen Dank
Silvia


Bild


Betrifft: AW: wieder keine VBA-Lösung :-)
von: Franz Pölt
Geschrieben am: 20.09.2003 17:59:11

Hallo Silvia,

das ist auch wieder keine VBA-Lösung, aber siehe selbst:

Excel Jeanie HTML
Formeln der Tabelle
D2 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A2)*(Bauausgabebuch!B$2:B$7=B2)*(Bauausgabebuch!C$2:C$7=C2))>0;"ja";"nein")
D3 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A3)*(Bauausgabebuch!B$2:B$7=B3)*(Bauausgabebuch!C$2:C$7=C3))>0;"ja";"nein")
D4 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A4)*(Bauausgabebuch!B$2:B$7=B4)*(Bauausgabebuch!C$2:C$7=C4))>0;"ja";"nein")
D5 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A5)*(Bauausgabebuch!B$2:B$7=B5)*(Bauausgabebuch!C$2:C$7=C5))>0;"ja";"nein")
D6 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A6)*(Bauausgabebuch!B$2:B$7=B6)*(Bauausgabebuch!C$2:C$7=C6))>0;"ja";"nein")
D7 : =WENN(SUMMENPRODUKT((Bauausgabebuch!A$2:A$7=A7)*(Bauausgabebuch!B$2:B$7=B7)*(Bauausgabebuch!C$2:C$7=C7))>0;"ja";"nein")
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Formel ist =$D2="ja"Abc
B21. / Formel ist =$D2="ja"Abc
C21. / Formel ist =$D2="ja"Abc
D21. / Formel ist =$D2="ja"Abc
A31. / Formel ist =$D3="ja"Abc
B31. / Formel ist =$D3="ja"Abc
C31. / Formel ist =$D3="ja"Abc
D31. / Formel ist =$D3="ja"Abc
A41. / Formel ist =$D4="ja"Abc
B41. / Formel ist =$D4="ja"Abc
C41. / Formel ist =$D4="ja"Abc
D41. / Formel ist =$D4="ja"Abc
A51. / Formel ist =$D5="ja"Abc
B51. / Formel ist =$D5="ja"Abc
C51. / Formel ist =$D5="ja"Abc
D51. / Formel ist =$D5="ja"Abc
A61. / Formel ist =$D6="ja"Abc
B61. / Formel ist =$D6="ja"Abc
C61. / Formel ist =$D6="ja"Abc
D61. / Formel ist =$D6="ja"Abc
A71. / Formel ist =$D7="ja"Abc
B71. / Formel ist =$D7="ja"Abc
C71. / Formel ist =$D7="ja"Abc
D71. / Formel ist =$D7="ja"Abc
 Bauausgabebuch
 ABC
1Daten1Daten1Daten1
2abc
3acd
4ade
5dab
6dbc
7abc
  Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Servus aus dem Salzkammergut Franz

Bild


Betrifft: Vielen Dank...
von: Silvia
Geschrieben am: 20.09.2003 19:29:03

das ist wirklich eine bemerkenswerte Lösung!
Vielen, vielen Dank.

Gruß S I L V I A


 Bild

Excel-Beispiele zum Thema " Untersch. Tabellen vergleichen und markieren"

Suche über mehrere Tabellen download Benennen von Tabellenblättern mit Monatsnamen download
Druckseitenlinien im Tabellenblatt download Tabellenblattnamen in ein Listenfeld einlesen download
Suchbegriff über mehrere Tabellenblätter suchen. download Tabellenblätter benennen download
Tabellenblatt auswählen download Zustand von Tabellenblatt-Checkboxes ermitteln download
Tabellenblattnamen der VBE-Projekte ändern download Tabellenblattnamen nach Datum download
Gefilterte Daten in neues Tabellenblatt übertragen download Mehrmals vorkommende Werte in neues Tabellenblatt download
Kommentare in geschützte Tabellen einfügen download Tabellen vergleichen download
Grafiken im Tabellenblatt ordnen download Einzelnes Tabellenblatt speichern download
Tabellenblattnamen in eine ListBox einlesen download Tabellenblätter in umgekehrter Reihenfolge drucken download
Anwendername in Tabellenblatt eintragen download Druck aus mehreren Tabellenblättern auf eine Druckseite download
Zwei Tabellen wechselseitig ändern download Tabellen hinzufügen und sortieren download
Tabellenvergleich und Übernahme der Doppel download Tabellencode nach Kopieren des Blattes löschen download
Tabellenblatt in UserForm download Nach Eingabe Werte aus Tabellen Übernehmen download
Letztes Speicherdatum in die Fußzeile aller Tabellenblätter download Ausgewählte Tabellenblätter als eigene Arbeitsmappen speichern download
Den selben Bereichsnamen in mehreren Tabellenblättern download Textdatei in Tabellenblatt importieren download
Tabellen hinzufügen und mit Namen aus einer Liste belegen download Einzelnes Tabellenblatt unter Tagesdatum speichern download
Tabellen für die Werktage eines Monats erstellen download Auswahl aus Tabellenblatt-ListBox in Zellen übernehmen download
Tabellenblattbereich als Email versenden download Daten in jeweils einer Spalte zweier Tabellen vergleichen download
Elemente in Tabellenblatt Pac-Man-artig steuern download Einen vorgegebenen Tabellenblattbereich in neue Arbeitsmappe download
Schaltfläche in einem Tabellenblatt ein- und ausblenden download Teilergebnisse einer Serie von Tabellen in anderes Blatt kopieren download
Letzte Verknüpfung in einem Tabellenblatt löschen download Tabellenblattbereich sortiert als Zellkontextmenü download
Ausgeblendetes Tabellenblatt bei Paßworteingabe anzeigen download Wert in Tabellenblatt suchen und alle Fundwerte in zweite Tabelle download
Bei Tabellenaktivierung im Extras-Menü eigenen Menüpunkt anzeigen download Tabellenblattinhalt unter Weglassung einer Spalte als Textdatei download
ComboBoxes per VBA-Code in Tabellenblatt erzeugen download In einem zweiten Tabellenblatt vorgegebene Zeilen beschriften download
Diagramm exportieren und in Tabellenblatt importieren download Arbeitsmappen- und Tabellenblattnamen auslesen download
Zellen vergleichen und markieren download Spalten A und B vergleichen und Doppel in C listen download
Werte vergleichen download Bereiche auf Übereinstimmung vergleichen download
Werte vergleichen und Ergebnis in Tabelle eintragen download Tabellen vergleichen und Zeilen ersetzen download
Tabellen vergleichen und bei Nichtübereinstimmung markieren download Textdateien vergleichen und Unterschiede dokumentieren download
Spalte A mit B vergleichen und Doppel in C eintragen download Telefonnumern mit Liste vergleichen und durch Namen ersetzen download
Werte vergleichen und übertragen download Teilstrings vergleichen und markieren download
Textmuster vergleichen download Bereich mit Maximalwert markieren download
Zeilen markieren download Markieren in Abhängigkeit vom Quartal download
Listbox-Eintrag durch Mausbewegung markieren download Drei Zellen rechts der aktiven Zelle markieren download
Zelle mit Maximalwert markieren download Alle nichtleeren Zeilen markieren download
Start- und Enddatum abfragen und markieren download Minimalwerte je Zeile markieren download
Nach Verlassen von Spalte B Spalte C markieren download Mit der aktiven Zelle jeweil 9 weitere in der Zeile markieren download
Monatsabhängige Tagesliste anlegen und Wochenenden markieren download Wahlweise Elemente in UserForm-Text- oder -ListBox markieren download
Begriffe in ausgeblendeter Spalte suchen und Fundzeile markieren download Zelle mit kleinsten Wert markieren download
Bestimmte Zeichen in einer UserForm-TextBox markieren download Über die bedingte Formatierung den Minimalwert markieren download
Kopfzelle mit aktivem Autofilter markieren download Doppelt vorkommende Werte markieren download
Doppelte Datensätze farblich markieren und auflisten download Wochenenden und Feiertage in Jahresliste markieren download
Datumsreihen nach Vorgabe markieren download Zeichen in UserForm-TextBox durch ScrollBar-Schieber markieren download
Datumsbereich in Abhängigkeit von 3 Kriterien markieren download Kürzel über Kontextmenü auswählen und markieren download
Suchbegriff abfragen und Fundzeile markieren download Maximalwerte im selektierten Bereich markieren download
Min- und Max-Werte automatisch markieren download In Folgeblättern nicht vorkommende Werte markieren download
Überschrittene Zahlungstermine markieren download Von einer Zeilenauswahl jede zweite markieren download
Zellen in Abhängigkeit der aktuellen Uhrzeit markieren download Datumsbereich gem. Start- und Enddatum markieren download
Letzte Zeile mit einem bestimmten Anfangsbuchstaben markieren download Zellen in Abhängigkeit des Summen-Teilergebnisses markieren download
Cursor-Position rechts und links markieren download Alle ungeraden Zahlen markieren download
Label und Zellen farbig markieren download Doppelt vorkommende Werte in Spalte A markieren download
Artikel mit den in einem Farbindex hinterlegten Farben markieren download Gleiche Einträge markieren download
Werte markieren, die größer als Parallelwerte sind download Markieren von Auswahlbereichen download
Markieren von festgelegten Bereichen download Zeile markieren, in der sich der Cursor befindet download
Datensätze wechselseitig bei Nichtauffinden markieren download Werte, die auch in anderen Spalten vorkommen, markieren download