Das Archiv des Excel-Forums

Formatierungsproblem bei einer Wenn-Formel

Bild

Betrifft: Formatierungsproblem bei einer Wenn-Formel
von: Elmar Steigenberger

Geschrieben am: 20.09.2003 11:08:57

Hallo Ihr lieben Helfer und Helferinnen!

folgendes Problem: Formel

=WENN(AD10="Vb";"";WENN(AD10="HH";$FM10&" HH";
WENN(AD10="qm";Anzqm&" qm";$GB$10&" PT")))

mögliche Ergebnisse:

"" (bei Vb)
16 HH (Haushalte)
1610 qm
16789 PT (Personentage)

Ich will aber, dass Excel, wenn er die 2. oder die 3. Bedingung erfüllt, dass dann nicht 1610 qm sondern 1.610 qm drinsteht und bei der dritten nicht 16789 PT, sondern 16.789 PT.

Geht das? Wie geht das?

liebe e-Grüße
Elmar
Bild


Betrifft: AW: Formatierungsproblem bei einer Wenn-Formel
von: Hajo_Zi
Geschrieben am: 20.09.2003 11:12:34

Hallo Elmar

siehe Dir mal die Funktion Text an.



Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.

Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen.
Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen.
Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet.
Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.


http://home.media-n.de/ziplies/



Bild


Betrifft: AW: Formatierungsproblem bei einer Wenn-Formel
von: Elmar Steigenberger
Geschrieben am: 20.09.2003 11:23:58

Hallo Hajo,

Vielen Dank für die schnelle(n) Antwort(en).

Das hab ich probiert, aber die (Test)-Formel TEXT(GB10;"###0 PT")bringt immer #Wert.

Die Formel TEXT(GB10;"###0") in allen Varianten funktioniert, TEXT(GB10;"###0" + "PT") hat auch nichts gebracht.

Wahrscheinlich stelle ich mich da grad furchtbar dumm an, aber ich kriegs einfach nciht gebacken...

liebe e-Grüße
Elmar


Bild


Betrifft: AW: Formatierungsproblem bei einer Wenn-Formel
von: Hajo_Zi
Geschrieben am: 20.09.2003 11:43:22

HAllo Elmar

ich habe es jetzt nur für die erste Bedingung eingebaut nit dem zweiten Teil komme ich nicht klar.

Atest
 ADAE
10HH1.236 HH
Formeln der Tabelle
AE10 : =WENN(AD10="Vb";"";WENN(AD10="HH";TEXT($FM10;"0.000")&" HH";
WENN(AD10="qm";Anzqm&" qm";$GB$10&" PT")))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Falls Code vorhanden wurde dieser getestet unter Betriebssystem XP Pro und Excel Version XP SBE.
Bitte kein Mail, Probleme sollen im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.

Zurzeit gibt es wieder Probleme mit der E-Mail Benachrichtigung.
Ich bekomme Mails zu Beiträgen an denen ich nicht beteiligt bin und zusätzlich noch Mails zu meinen eigenen Beiträgen. Das Problem mit den eigenen Benachrichtigung kann gelöst werden durch Lösche und Neuanmelden. Dieses möchte ich aber nicht jeden Tag machen. Um dieses Problem erstmal zu beseitigen habe ich die automatische Mailbenachrichtigung abgeschaltet. Aus diesem Grunde ist es dem Zufall überlassen ob auf Rückfragen Antworten von mir kommen.
http://home.media-n.de/ziplies/

Bild


Betrifft: AW: Formatierungsproblem bei einer Wenn-Formel
von: Elmar Steigenberger
Geschrieben am: 20.09.2003 11:50:37

Hallo Hajo,

ja genau so hats funktioniert!

Ein Traum! Nach über 2 Jahren Arbeit an meiner Hausverwaltungssoftware ist das eines der wenigen noch nicht perfekten Dinge, die noch gefehlt haben!

liebe e-Grüße
Elmar


Bild


Betrifft: Danke für die Rückmeldung oT
von: Hajo_Zi
Geschrieben am: 20.09.2003 11:56:36




 Bild

Excel-Beispiele zum Thema " Formatierungsproblem bei einer Wenn-Formel"

Beispiel für die Anwendung der SUMMEWENN-FORMEL download Eine WENN-Formel nur bei der ersten Werteänderung berechnen download